• Welcome to Simple Machines Community Forum. Please login or sign up.
December 06, 2021, 05:38:51 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Firefox not remembering my forum text

Started by Chalky, April 03, 2012, 11:46:05 AM

Previous topic - Next topic

Chalky

Odd problem here, sorry if I'm posting in the wrong place but I don't know where the problem is.

If I'm in the middle of typing a post in my forum, then accidentally navigate away from the page, when I back-browse to my post-form (or forward browse if I used the back button to navigate away) all my typing is lost and I'm looking at a blank post-form.

I do have "Allow browsers to go back to cached pages" checked in my forum server settings, but this is the really weird bit.  I have checked Opera and Chrome and they both remember my typing.  On other forums, including this one, Firefox remembers my typing!  So what is preventing Firefox from remembering my typing on my own forum?  And how do I fix it?  I wondered whether I had somehow broken a cookie, but I ran CCleaner and the problem persists.  Any ideas?

Thanks :)

kat

Yeah. Use Opera. ;)

Is this just happening for you? Or, is everyone using Fartfox affected?

Chalky

I like Firefox  :'(  LOL

None of my members even have FF installed on their machines to test it for me, so I can't answer that.

kat

Get PaleMoon. It's Firefox on steroids. ;)

http://www.palemoon.org

The portable version's good.

Have a look at Firefox's settings, particularly the cache/cookies options.

Chalky

Thanks, I'll have a look at that :)  I don't want to be rained off FF though - I'm sure this is a new problem and that it was remembering my typing in the early day of the forum - being a clumsy oaf I can't believe this is the first time in five weeks or whatever that I've accidentally clicked something while I've been typing....

FF is set to remember history.  It has my forum cookie showing dutifully in the cookie list, which figures, as I never have to login.  I can't see anything more to fiddle with in there  :-\

kat

There're cache settings, somewhere.

Oh, all right. I'll launch bloody Firefox to check... :P

kat



Chalky

Thanks K@, so are you telling me this is a known issue, even with Firefox 11 which is the version I'm using?  And it still hasn't been fixed?  But why should I have the issue on my own forum and not on simplemachines.org?

Screenshots of my Network settings tab attached....

kat

Dunno. My settings are the same as yours and I just checked. It works OK, here.

Obviously, I dunno if it works on your forum, though.

Just a thought, though...

Dunno if it'll affect anything. But, if you look at Admin>Server settings>caching, is your "Caching Level" set to level 1?

Chalky

April 03, 2012, 04:00:27 PM #10 Last Edit: April 03, 2012, 04:19:54 PM by Sabrinova
Yes, level 1.

Please would you be so kind as to see if it does work for you on my forum?

If it's running a bit slow, it's because I'm in the middle of a full back-up of my server via FTP.  My hosting control centre only seems to allow database backups, not files like your fancy cPanel thing does ;)

kat

Eventually, yeah.

Your site's a bit on the Godaddy slow side...

Chalky

LOL I was just editing my post  :laugh:  You did that quick though!  So yours is retaining text?  Hmm.... must be something in my firefox then....

Thank you :)

kat

Bugger...

QuoteWhat is the 3 letter code for our south airport?

Chalky

April 03, 2012, 04:07:18 PM #14 Last Edit: April 03, 2012, 04:20:26 PM by Sabrinova
Oh soz, LOL I jumped miles ahead there, you said yes you'd test it not yes it works ROFL!!!

*** is the answer you want

Edit:  Dammit, it's painfully slow right now isn't it!  How embarrassing!  I swear it isn't normally like this....

kat

As you'll see, mine works, perfectly.

So, it's your Firefox settings, somehow. :P

Chalky

How curious....

Thank you so so much for that K@ :)  I will keep playing with my firefox then, now at least I know where to look...

Thanks :)


MrPhil

To keep FF from losing text, do a "Preview" before moving off the page. That always does it for me.

Chalky

Thanks Mr Phil, that could work, except that in my case, moving off the page isn't usually either intentional or foreseen...

The worst culprit is my backspace button, which somehow, when I'm using it to backspace to correct a mistype, it instead backbrowses to my previous page!  I go forward to return to where I was and all my typing is gone  :(

MrPhil

April 04, 2012, 11:24:07 AM #20 Last Edit: April 04, 2012, 11:33:33 AM by MrPhil
If hitting the Backspace ( <-- ) key moves you off page, that usually means that your cursor is not in the text input field area. This use of Backspace to go back a page may be a peculiarity of Firefox, and means that you have to be a bit more careful of where the focus is when you hit Backspace.

Add: FF can disable this behavior: http://support.mozilla.org/en-US/questions/924490?s=backspace&r=2&e=es&as=s

Chalky

Thank you :)  I will try that and see if it helps counter my natural clumsiness  ;D

Chalky

Quote from: K@ on April 03, 2012, 12:16:32 PM
Get PaleMoon. It's Firefox on steroids. ;)

http://www.palemoon.org

The portable version's good.

Have a look at Firefox's settings, particularly the cache/cookies options.

Honey..... I've finally got sick of FF and switched to Pale Moon, but it's the same   I didn't import anything from FF, this forum as well as vB forums I'm on remember my typed text if I hit the back button then forward again, but my forum doesn't.  I don't want to have to use Chrome!!!

Why???  Why??? Why???

kat

It's a plot to get you to use Opera. ;)

Chalky

Me no wanny use Opera!  Me no likey Opera!  Me gon cry..........

kat

* K@ cuddles his Opera and doesn't let Nova play with it.

(Or Opera) ;)

Chalky

*Nova thinks to herself, K@ can keep it (and Opera  ;))

Opera is the only browser my WP blog menu bar looks wrong in, but if I make it look right in Opera it looks wrong in all the others.  If only there were a WP support form as nice and friendly and helpful as this one....

*Nova goes to the fridge for more wine

So come on then, who can fix my text rememory thingy???

kat

Must be you. I looked at your blog with Opera and it looks fine.



It's got to be something squiffy with either your browser's cache, or your forum's, I reckon.

Still, City stuffed United. So, it's not all bad news. ;)

Chalky

Really?  It isn't floating a little low like in my piccy?

I don't see how there can be a cache problem with a browser I only installed fresh this afternoon... and I'm emptying my forum cache regularly, as all good girls do.

It's making my head hurt....

TheListener

I only use Firefox.

Quoteas all good girls

You're not one of them so no need to worry there.

Chalky

Quote from: Old Fossil on May 01, 2012, 03:50:03 PM

Quoteas all good girls

You're not one of them so no need to worry there.






kat

Nope. Your blog looks perfectly OK.

Little Opera tip...

Tools menu>Preferences>Web pages tab>UNcheck "Fit to width" and set "Page zoom" to 100%.

Chalky

Thanks K@, I just checked and that's how it's already set

*Nova drains the bottle


Thanks for confirming my blog looks ok to you, that's a relief anyway  :)

kat

Must be something else, then (God, I'm clever!!)

Get rid of that bottle of girlie stuff and get a hard one inside you, like a JD.

Hic!

That'll help, I feel sure. ;)

Let me check some other settings, for ya. BBL.

kat

Nope. Can't think of anything else.

Have you got a low screen-res, or something?

Mine's only 1024x768, though.

Chalky

Worry ye not, I have an Isle of Jura in the cupboard - no American bourbons in this house

Thanks hon, I appreciate your help :)

Off to check my screen res...

Chalky


kat

Weirder and weirder...

If you feel adventurous, you could always type "opera:config" in the URL bar and hit "Enter"...

I may have altered something, in there.

I'll see if I can find summat.

kat

Nope, nothing obvious in there.

Odd, innit?

Chalky

Very odd, my Opera is still at the default settings as I don't even use the damn thing except to see how my websites look in different browsers.  My Firefox had a few add-ons but my Pale Moon is fresh on today. 

kat

Neither do I.

OK. Let's try to narrow this down, a bit.

Have a word with your members.

Is the same thing happening to them?

If it is, we can assume it's something weird with your forum.

If it ain't, it's likely to be your browser, innit?

Chalky

My members have tested theirs and they're fine, but then none of them have either FF or PM installed so they can't test those.  But you tested FF with my forum earlier in this thread and it was fine for you.  As for mine, it's so illogical!  My browser (FF and PM) remembers text just fine with other forums, even this one, just not mine.  I've just tested my installations of Chrome, Opera, Safari and even I flaming E and they all work fine on my forum too!  So it's somehow the combination of my FF/PM and my own forum....

kat

* K@ suggests you create an account, for him, so that he can see this, for himself.

Chalky


kat

Pleasure!

Well, I have something, for you.

It's you.

I went to your introductions board and typed a reply to "Squeak".

I pressed the "Back" button.

I pressed the "Forward" button.

All the text was still there.

I used Opera, Firefox, Pale Moon and K-Meleon.

So, it's GOT to be some browser setting, something weird on your compoota, or (Dare I say it...)


Chalky

I'm just in from work, and thank you K@ - at least we've narrowed down the problem to me ;)

I still don't know what to do to fix it though.....

kat

Could it, perhaps, be some security software that you're suing?

I'm merely fishing, here, for obvious reasons.

What extensions do you use? That kinda thing.

Maybe the cache settings are weird, somehow?

Maybe this'll help?

https://addons.mozilla.org/en-US/firefox/addon/lazarus-form-recovery/

kat

Aha!

Do you have the WYSIWYG editor enabled?

According to a page at Mozilla I just read, that can cause this hassle.

You also need to ensure that javascript's enabled.

Chalky

Hmm... ok, I have WYSIWYG enabled, but I don't use it - should I disable it?  Javascript is very much enabled ;)

I'm running ZoneAlarm and AVG.

I tried that Lazarus thing on my Pale Moon, but nada.

Okeydoke, I'll try disabling WYSIWYG and see what that does...

Chalky

K@ you are an absolute bloody genius!!!!  With wysiwyg disabled my text is remembered on both PM and FF!!!  Thank you, I could kiss your little face off

I still don't know why it worked before for you and not for me,  but who gives a damn, it works this way!


MrPhil

Quote from: Sabrinova on May 02, 2012, 01:40:03 PM
I could kiss your little face off

Have you ever seen a K@ lick itself clean?   :o

Anyway, I hope that works well for you...

kat

She can kiss any part of me that she likes!

Glad we got there in the end! :)

Chalky


kat

Pleasure!

Now... about that cheap holiday on Tenerife.... ;)

Chalky

If you can coincide with my holidays (September or Christmas), I know a one-bedroom apartment you can stay in for free!  On the edge of a small town on the bus route, close to all amenities, stunning sea views, five minutes walk from the beach and two minutes from the seafront bars and restaurants.....  All you have to do is look after the two resident pinny gigs ;)

kat

I adore Pinny gigs! Especially ruffly ones. ;)

You may have a deal... :)

Chalky


Advertisement: