Advertisement:

Author Topic: Trouble upgrading from 1.1.10 to latest  (Read 2107 times)

jleagle

  • Guest
Trouble upgrading from 1.1.10 to latest
« on: January 17, 2013, 08:38:35 AM »
I have inherited a version 1.1.10 SMF forum and trying to upgrade it locally. I have downloaded the files and database, but cant seem to get the files to connect to the database.

I have changed al the values in the settings table and changed everything in settings.php, but when i run upgrade.php i just get:

Quote
The upgrader was unable to find some crucial files.
Please make sure you uploaded all of the files included in the package, including the Themes, Sources, and other directories.

Is there a standalone script anywhere that i can upgrade my database with to the latest version and then i can just download the files for the latest version and link them up?

Thanks.


jleagle

  • Guest
Re: Trouble upgrading from 1.1.10 to latest
« Reply #2 on: January 17, 2013, 10:50:14 AM »
Thanks, i got it working in the end, not sure what it was, maybe some values were cached?

I am looking to remove all mods and use the default look, So i installed a fresh SMF. Can i just copy the data from my previous database over to the new one? Will passwords and things still work?

Thanks.

kat

  • Guest
Re: Trouble upgrading from 1.1.10 to latest
« Reply #3 on: January 17, 2013, 11:06:01 AM »
Nope. A v1 database simply won't work on a v2 installation, I'm afraid. I believe that there IS a way to do it. But, it's messssssssy, to put it mildly.

What you could do, is install a fresh copy of v1.1.10 http://download.simplemachines.org/index.php?thanks;filename=smf_1-1-10_install.zip and import the database into that, then upgrade, perhaps?

You might want to just upload the files, overwriting what you have. But, make sure you don't overwrite the existing Settings.php and you won't want install.php, either.

jleagle

  • Guest
Re: Trouble upgrading from 1.1.10 to latest
« Reply #4 on: January 23, 2013, 12:16:13 PM »
Thanks for your help, I managed to upgrade the database and link it to a fresh v2. One issue is none of the previous attachments work, new ones work fine. Is this a known issue? I just get '404 - Attachment Not Found'
« Last Edit: January 23, 2013, 12:40:20 PM by jleagle »