Advertisement:

Author Topic: Не устанавливаются/удаляются пакеты модификаций  (Read 8197 times)

Offline Айронсофт

  • Semi-Newbie
  • *
  • Posts: 19
  • Gender: Male
    • Айрон Софт on Facebook
    • Арадрон
Здравствуйте.
У меня на форуме вдруг перестали устанавливаться и удаляться пакеты модификаций, хотя я по-прежнему могу их загружать. При попытке установки или удаления отображается пустая белая страница. В чём проблема и как её решить?
И, если можете, выложите в теме "здоровые" файлы, отвечающие за установку и удаление пакетов модификаций.
Мы рождены, чтоб сказку сделать былью!

Offline maestrosite.ru

  • Semi-Newbie
  • *
  • Posts: 89
    • Сопровождение и модификация форумов SMF
Смотрите логи ошибок сервера. Ключевые слова fatal и error
First of all, sorry for my english. По-русски у меня получается значительно лучше.

Проблема на форуме? Сначала посмотрите лог ошибок вашего форума и лог ошибок сайта (error_log)

You can try other modifications - see demo

Offline Айронсофт

  • Semi-Newbie
  • *
  • Posts: 19
  • Gender: Male
    • Айрон Софт on Facebook
    • Арадрон
Смотрел. Пишет "Записей не найдено".
Мы рождены, чтоб сказку сделать былью!

Offline maestrosite.ru

  • Semi-Newbie
  • *
  • Posts: 89
    • Сопровождение и модификация форумов SMF
Смотрел. Пишет "Записей не найдено".
возможно:
1. Стало быть имеет место волшебство.

но более вероятно:
2. Такая надпись имеет место быть в админке форума. А надо смотреть логи сервера, то есть apache. Часто именуется error_log
First of all, sorry for my english. По-русски у меня получается значительно лучше.

Проблема на форуме? Сначала посмотрите лог ошибок вашего форума и лог ошибок сайта (error_log)

You can try other modifications - see demo

Offline Айронсофт

  • Semi-Newbie
  • *
  • Posts: 19
  • Gender: Male
    • Айрон Софт on Facebook
    • Арадрон
Решение
« Reply #4 on: June 10, 2012, 05:17:37 AM »
Заменил в папке Source следующие файлы на те же самые файлы из установочного пакета: PackageGet.php, Packages.php и Subs-Package.php. Теперь всё работает.
Мы рождены, чтоб сказку сделать былью!

Offline deminua

  • Newbie
  • *
  • Posts: 2
Такая же проблема и у меня, не знаю что делать и файлы менял - не помогло.

Грешу на open_basedir

Local есть
Master no value

Offline igod

  • Newbie
  • *
  • Posts: 8
И у меня появился данный глюк.
Токо при всем при этом еще когда заходиш в Менеджер пакетов тоже бросает белый экран.
Докопался что затык появляется на коде
Code: [Select]
// Get the package info...
$packageInfo = getPackageInfo($context['filename']);
в файле Packages.php, а именно когда идет вызов из Subs-Package.php
Code: [Select]
// Parse package-info.xml into an xmlArray.
loadClassFile('Class-Package.php');
$packageInfo = new xmlArray($packageInfo);
я так понимаю здесь происходит парсинг xml, но почему раньше все работало, а сейчас глючит незнаю, никаких обновлений не ставил.  :-\

Offline Chip.and.Dale

  • Newbie
  • *
  • Posts: 1
Аналогичная проблема:(((Мод загружается, но потом белая страница и все. Ничего не помагает.

Offline inter

  • Jr. Member
  • **
  • Posts: 290
  • Gender: Male
    • interlab on GitHub
если белая страница, то смотрите лог ошибок апача
Sorry for my English