News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

cannot upload files to smf (themes and packages)

Started by Hirsidor, June 21, 2012, 07:38:38 AM

Previous topic - Next topic

Hirsidor

Hey all,

My problem is uploading files on the forum. The first time i installed smf everything worked fine. I could click upload package and theme and then the theme or package was uploaded to smf. After i installed smf gallery i got an error when i tried to upload a picture. I just got a blank-page and the server crashes. (this is bad:() when i restart the server i get no error in the smf error log. I don't even get an error in my error.log files of my web-server.

I use Hiawatha and the strange thing is that i can upload files on my phpmyadmin folder so it is something with smf:(. I cleared the map where smf was located in and cleared the mysql database and reinstalled smf. This was my hope of fixing the problem. But it is still giving me an error when i try to upload something. I work with linux and the map permissions are 777 so that should be no problem?(maybe it is?)

This here is my last hope getting little frustrated that i cannot fix the problem, i am working on it for some days now:( i also looked in the php.ini file and i got all the settings on that need to be on. (is standing on somewhere on support page).

When you think you can help me, your answer would be great:D
Thank you for reading.

Greetz Hirsidor

I also got an acces.log where you can find some information. if you need pm/respond to me.
using latest smf 2.0.2 and
Hiawatha v7.5
MySQL client version: 5.5.15
when you need more call me;)

kat

As this started going all weird, after you installed th Gallery mod, might I suggest that you post in the mod's support topic, Hirsidor? Have a read through it, first, though, coz it may have already been spoken about. ;)

Hirsidor

I did some research and i think it got something to do with my site configuratie for php and upload setting. Because now i can upload small files and no big files. Above 500 kb what settings are responsible for this?

Storman™

QuoteI did some research and i think it got something to do with my site configuratie for php and upload setting.

Increase the the size of the value for:

upload_max_filesize

in php.ini

Whilst you are there it would probably be good to make the value against "post_max_size" the same value. Once changed restart your webserver (probably apache).

Colin

You may also want to change max_execution_time
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Hirsidor

Thankyou for all the reply i look around. thanks. I do not use apache but hiawatha.


Colin

Sure, but it you are still using PHP regardless.
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Hirsidor

I am, ty! are those the only things that are smart to change? or are there more features to edit?
Thank you all fot great support!:D

Colin

Make those changes and see if it works. If not we can troubleshoot further.
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Hirsidor

I got some info about uploading from here, http://www.hiawatha-webserver.org/forum/topic/867 [nofollow]

so i think the problem is my server.

I try this. Really thankfull of your help. ty! i call if it goes wrong:P

Advertisement: