• Welcome to Simple Machines Community Forum. Please login or sign up.
December 02, 2021, 07:56:04 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Aiuto... un fatto strano

Started by pierpis, July 14, 2012, 04:50:17 AM

Previous topic - Next topic

pierpis

July 14, 2012, 04:50:17 AM Last Edit: July 14, 2012, 05:05:44 AM by pierpis
Oggi mi è capitato una strana situazione..... ho fatto un po di manutenzione al forum,  eliminato registri non importanti.... svuotato la cache, fatto una conversione del liguaggio in caratteri uft-8, se non ricordo male ho anche ottimizzato le tabelle...... mi si sono "tagliati" moltissimi post degli utenti.... cosa è successo? si possono recuperare?
Grazie

emanuele

Quote from: pierpis on July 14, 2012, 04:50:17 AM
fatto una conversione del liguaggio in caratteri uft-8,
Here it is.

Hai anche installato il pacchetto del linguaggio UTF8?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

No nelle Mod non c'è il pacchetto...... non sò dove buttare le mani per ripristinare il tutto.... non dovevo ottimizzare il forum  :'( andava bene cosi.

emanuele

I pacchi delle lingue non sono mod.
SMF 2.0 o 1.1?
Nel primo caso vai in admin > configurazione > lingua > aggiungi lingua quindi scrivi "italian", cerca e scegli l'italiano UTF8.
Il problema viene dopo perché dovrai impostare a tutti gli utenti il nuovo linguaggio, quindi vai in phpmyadmin, entra nella tabella smf_members, quindi clicca in alto dove c'è scritto "SQL" e nel box che apparirà scrivi:
UPDATE smf_members
SET lngfile = 'italian-utf8'
WHERE lngfile = 'italian'

ed esegui (c'è un pulsante "vai" in basso a destra).

Intanto che ci sei, installa anche l'inglese UTF8 nello stesso modo (male non fa), e usa questa query nello stesso modo della precedente:
UPDATE smf_members
SET lngfile = 'english-utf8'
WHERE lngfile = 'english'


Non garantisco che risolva, ma è da fare sicuramente.

Se dopo aver fatto questo ancora hai i post troncati, apri Settings.php e verifica che in fondo ci sia la riga:
$db_character_set = 'utf8';


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Ci provo....non ho scelta, ma devo dirti che se apro admin >traduzioni>impostazioni.... è già settato in Italian (UTF-8)  premetto che ho la versione 2.02

emanuele

Quindi in precedenza avevi il language pack UTF8 e il forum impostato in non-UTF8?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Devo dire che non ho mai pensato di scoprirlo, anche perchè il funzionamento era ottimo fino a che non ho voluto ottimizzare. Ma centra qualcosa che riguarda le tabelle?

pierpis

Ho notato una cosa nei post..... si interrompono prima di una "è" oppure prima di una "à" o qualcosa di accentato.
Nelle tabelle del DB purtroppo sono spezzate anche li, quindi presumo di aver perso tutto  :-X :-X :-[

emanuele

Si interrompono in corrispondenza delle lettere accentate perché, come ti ho scritto nel primo post che ho fatto, il problema è stato la conversione a UTF8, non l'ottimizzazione.

Sì, se nel database è troncato, a meno che tu non abbia un backup è tutto andato...vero che hai un backup? (anche non recentissimo potrebbe aiutare almeno a salvare qualcosa...)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Si, ho un backup del fine settimana scorsa (meglio che niente) adesso lo ripristino e ti dico come è andata... intanto grazie per il tuo interessamento.

pierpis

Recuperato quasi tutto.... escluso l'ultima settimana.... ma meglio che niente. Però ora mi sono accorto che i caratteri accentati.... sono stati sostituiti da (?) punto interrogativo.... come potrei risolvere?

emanuele

1) eliminando la traduzione utf8 e mettendo quella "ISO" (e ripristinando la scelta corretta ai tuoi utenti)
2) eliminando (se esiste) la stringa $db_character_set = 'utf8'; da Settings.php.
Questo dovrebbe risolvere il problema...

La prossima volta che vuoi fare un'operazione che riguarda il database backup!! Di tutto, database e file.
E se usi filezilla leggi questi:
http://www.simplemachines.org/community/index.php?topic=481197.msg3370206#msg3370206
http://www.simplemachines.org/community/index.php?topic=481477.msg3371347#msg3371347


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Scusa Emanuele..... :-[ dove trovo la traduzione utf8 per sostituirla con quella "ISO"?

emanuele

I file delle traduzioni sono in /Themes/default/languages purtroppo sono tutti "mischiati" e per rimuovere la traduzione devi cercare tutti i file che si chiamano "{qualcosa}.italian-utf8.php" (ovviamente il "{qualcosa}" sono tutti i vari nomi: admin, index. ecc.).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Trovati..... ece ne sono tanti,  ma la sostituzione con iso, come avviene..... cancello -uft8 e ci scrivo iso?...... ho detto cazzate??


emanuele

E dammi il tempo di pranzare...lo so che hai fatto un casino e vuoi rimettere tutto a posto, ma abbi un po' di pazienza: è domenica mattina in fin dei conti.
Altrimenti se hai così tanta fretta ti serve un servizio di assistenza immediata 24/24 (ma sai benissimo che una cosa del genere costicchierebbe un po'...).

Devi cancellare i file che ora hai e scaricare la traduzione "non-utf8", se lo fai dal pannello di admin vedrai le due opzioni: utf8 sì e no, prendi quella "no".
Ma prima devi cancellare tutti i file che contengono italian-utf8.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Hai ragione Emanuele.... sono stato un po egoista, ti chiedo scusa..... proprio non ho pensato alla domenica, visto il maestrale son rimasto a casa.
Intendi pannello di admin (cPanel) o dal forum stesso?

emanuele

Forum stesso (se hai SMF 2.0): admin > configurazione > lingua > aggiungi lingua cerchi "italian" e ti vengono elencate le due possibilità. Scegli quella in cui nella colonna UTF8 c'è scritto "no".


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: