News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

upgrade non funzia

Started by ienadose, July 20, 2012, 06:59:41 PM

Previous topic - Next topic

ienadose

ciao, ho provato a fare il large update (quindi dalla 1.1.15 all'ultima versione) ma non funzia.

finito l'upload via ftp sulla pagina del foro mi appare "Unknown column 'add_deny' in 'field list'"
e sulla pagina foro/upgrade


Updating Your SMF Install!
The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

qualche idea?

emanuele

Certo, non hai eseguito l'upgrade, hai solo caricato i file.
Ora quello che devi fare è andare a http://www.tuosito.it/forum/upgrade.php e seguire i le istruzioni.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

ci sono andato e mi dice:

Updating Your SMF Install!
The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.





emanuele

mmm...sto iniziando ad odiare gli upgrade.

Per sicurezza, riscarica il large upgrade (non lo small update, mi raccomando) da qui, decomprimilo e ricaricalo sul server (andando a sovrascrivere tutti i file, quindi riprova con upgrade.php.

Ovviamente: BACKUP!! ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

riproverò per la TERZA volta! ok

intanto che ci sono... vista la mia penosa connessione è possibile caricare sul server il file compresso e sucessivamente decomprimerlo li? utilizzo filezilla, ma potrei cercare e provare anche altri programmi se con filezilla non è possibile

emanuele

Se usi filezilla ATTENZIONE AI BACKUP!!!

Filezilla ha di default una stipudissima opzione attiva che trasferisce (durante il download) tutti i file senza estensione come se fossero file dei file di testo, questo li corrompe e li rende inutilizzabili come backup!!
Leggiti questo topic ed i link che trovi al suo interno!!


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

niente da fare, riprovato altre 2 volte ma l'errore è sempre quello.

qualche idea? potrebbe essere un'incompatibilità di lingua?

emanuele

mmm...l'unica che mi viene in mente è prima di caricare i file dell'upgrade, cancella:
* Sources (directory)
* Themes (directory)
* index.php
* SSI.php
* ssi_examples.php
* ssi_examples.shtml
alcune volte è possibile che il sovrascrivere non porti al risultato desiderato.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

niente da fare.

mi pare aver letto su un qualche forum, però c'era scritto in inglese quindi non ci giurerei, che fosse un errore, irrisolvibile, del database...

che pacco!

emanuele

L'unico posto in cui quell'errore è generato è qua:
// Do a quick version spot check.
$temp = substr(@implode('', @file($boarddir . '/index.php')), 0, 4096);
preg_match('~\*\s@version\s+(.+)[\s]{2}~i', $temp, $match);
if (empty($match[1]) || $match[1] != SMF_VERSION)
return throw_error('The upgrader found some old or outdated files.<br /><br />Please make certain you uploaded the new versions of all the files included in the package.');

L'unica cosa che fa questo pezzo di codice è prendere "index.php" (quello nella directory principale del forum) leggerlo e vedere se il file è quello corretto.

Quindi ripeto: controlla di aver caricato *tutti* i file correttamente, incluso index.php e gli altri file che stanno nella directory principale del forum, che sono:
* index.php
* SSI.php
* ssi_examples.php
* ssi_examples.shtml


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

mh... è normale che abbia un "index.php~"?

emanuele

Hai applicato mod che hanno apportato modifiche a index.php, quella è l'ultima versione prima che il mod fosse stato applicato/rimosso.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

non funzionano i pulsanti "reply" ecc si visualizzano correttamente ma non aprono nessun link

emanuele

Adesso onestamente sono un po' perso: che cosa stai cercando di fare ora?
Tornare a 1.1 o passare a 2.0?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

ultimamento ho avuto 0 tempo, il passaggio alla 2 lo post-pongo ancora  :(
sto cercando di toppare questa falla dei pulsanti che non vanno. potrebbere esser dovuto a qualche trasferimento ftp venuto male?

emanuele

Link ed un account (utente normale va bene) così posso vedere?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

#16
ok tieni. http://www.anarchaos.org/forum/ [nofollow] nome: nuovo pass: proprionuovo

emanuele

Sicuro che l'url sia giusta? Non mi da alcun sito... ???


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

ienadose

ho correntto l'url. scusa
tra i tasti che non si cliccano ci sono anche  il tasto del grassetto corsivo e tutti quelli delle formattazioni dei messaggi

emanuele

http://www.anarchaos.org/forum/Themes/default/script.js?fin11 <= 404 file not found.
Questo è il problema.
Ripristina quel file (ed intanto controlla non ne manchino altri) e quello tornerà a funzionare.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: