Advertisement:

Author Topic: Thank-o-matic errore e post troncati  (Read 6983 times)

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Thank-o-matic errore e post troncati
« on: September 14, 2012, 12:27:35 PM »
Sono ritornato, dopo l'esperienza di questi giorni che non si e' risolto per niente in quanto ho dovuto reinstallare tutto di nuovo
vedi topic

http://www.simplemachines.org/community/index.php?topic=486295.0

Adesso ho ancora dei problemi

1) Mod Thank-o-matic mi da questo errore

Wrong value type sent to the database. Integer expected. (p_thank_you_post_became)

ho provato a disinstallarlo ma il problema e che poi non mi fa accedere ai topic  >:(

2) Dopo la reinstallazione del forum dall'inizio (in quanto mi dava problemi) mi sono ritrovato la sorpresa dei post troncati in cui mancano parti di testo,  cosa e' successo ?

Grazie  per l'aiuto, ultimamente Simple Machines mi sta' dando molti problemi  :(


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #1 on: September 14, 2012, 12:58:06 PM »
1) Mod Thank-o-matic mi da questo errore

Wrong value type sent to the database. Integer expected. (p_thank_you_post_became)

ho provato a disinstallarlo ma il problema e che poi non mi fa accedere ai topic  >:(
Non è che per caso mentre lo installavi ti è apparso un messaggio rosso a caratteri cubitali che ti diceva che c'era un errore e che era meglio non procedere?
O meglio ancora, l'hai installato solo sul tema di default e non su quello che stai usando ora?
Prova col tema di default, se il problema persiste c'è stato un errore durante l'installazione, se sparisce non l'hai installato nel tema custom.

2) Dopo la reinstallazione del forum dall'inizio (in quanto mi dava problemi) mi sono ritrovato la sorpresa dei post troncati in cui mancano parti di testo,  cosa e' successo ?
Non è che ti vengono troncati dopo le lettere accentate?
Probabilmente è un problema di codifica: il tuo forum è UTF8 o no? La lingua che stai usando è UTF8 o no? (e rispondere a questa domanda può non essere facile...controlla sul server in Themes/default/languages se hai solo file tipo "admin.italian.php" oppure se hai anche "admin.italia-utf8.php", se li hai entrambi uno dei due non serve e bisogna vedere qual'è).


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #2 on: September 14, 2012, 01:21:25 PM »
1) Ho installato il mod Thank-o-matic su Tema predefinito - Curve, si mi e' uscito un messaggio rosso ma non ci ho fatto caso perche' prima del crash di ieri funzionava benissimo sul forum, adesso ci sono i thank you azzerati ed esce il messaggio d'errore se vado a cambiare il profilo ad un utente, inoltre se lo disinstallo mi esce un altro errore e non mi fa' accedere ai topic

2) il forum e' UTF8 ? onestamente non lo so', penso di si perche' prima andava bene con lettere accentate e altro linguaggio
ho controllato nel server e c'e' solo

Admin.italian-utf8.php


Grazie Emanuele per la veloce risposta, speriamo di risolvere
« Last Edit: September 14, 2012, 01:56:40 PM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #3 on: September 14, 2012, 03:19:10 PM »
1) Ho installato il mod Thank-o-matic su Tema predefinito - Curve, si mi e' uscito un messaggio rosso ma non ci ho fatto caso perche' prima del crash di ieri funzionava benissimo sul forum, adesso ci sono i thank you azzerati ed esce il messaggio d'errore se vado a cambiare il profilo ad un utente, inoltre se lo disinstallo mi esce un altro errore e non mi fa' accedere ai topic
ehhh....leggere fa sempre bene...
Se c'è un messaggio rosso significa che c'è qualcosa che non va...
Siccome molti dei mod di SMF effettuano delle vere e proprio modifiche ai file cercando e rimpiazzando (o aggiungendo) pezzi di codice c'è il problema che la corretta installazione automatica di più mod può dipendere anche sequenza con cui vengono installati.
Esempio pratico.
Immaginiamo di avere il seguente codice:
Code: [Select]
if ($a == 0)
{
  $b = 1;
  $c = 'abc';
}
Un ipotetico mod potrebbe avere tra le sue istruzioni: trova il seguente codice
Code: [Select]
if ($a == 1)
{
  $b = 1;
ed aggiungi prima di esso
Code: [Select]
if ($a == 0)
  $d = 10;
adesso immaginiamo un secondo ipotetico mod le cui istruzioni d'installazione sono: trova
Code: [Select]
if ($a == 1)
{
  $b = 1;
e sostituiscilo con
Code: [Select]
if ($a == 1)
{
  $b = 2;

Fatto. Se tu installi il primo e poi il secondo tutto funziona, se invece installi il secondo e poi il primo avrai un messaggio d'errore e se procederai la modifica non sarà effettuata. Cosa che può portare a simili problemi.

Ora, venendo al tuo problema specifico, ti sei scelto un mod che ha una quantità notevole di modifiche per avere problemi...
http://custom.simplemachines.org/mods/index.php?action=parse;mod=710;attach=195523;smf_version=2.0.2
L'unica cosa che puoi fare al momento è prendere pazienza e controllare i file che ti danno problemi e verificare dove le modifiche non sono state fatte...

2) il forum e' UTF8 ? onestamente non lo so', penso di si perche' prima andava bene con lettere accentate e altro linguaggio
ho controllato nel server e c'e' solo

Admin.italian-utf8.php
mmm...prova a verificare se l'ipotesi è corretta (quindi che i post vengono troncati in corrispondenza dei i caratteri accentati).
Se questo è il problema allora vediamo cosa si può fare (sicuramente si risolve, bisogna giocare un po', ma si risolve).


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #4 on: September 14, 2012, 05:18:33 PM »
1) se vado in UTENTE/MODIFICA PROFILO/PROFILO FORUM  e cerco di modificare un profilo mi esce questo messaggio

"Si è verificato un errore!
Wrong value type sent to the database. Integer expected. (p_thank_you_post_became)"

sotto il profilo forum c'e' un menu per Thank-o-matic che e' azzerato

Thank You Posts Thanks given by you:
Thank You Posts Thanks taken by you:


o provato a mettere 0 in tutte e due menu e non mi ha dato errori quando salvo

Thank You Posts Thanks given by you:  0
Thank You Posts Thanks taken by you:  0


come procedo adesso?, i post degli utenti sono tutti azzerati, se do' un Thank You a un utente rimane vuoto vicino al profilo post


2) i post vengono troncati in corrispondenza dei i caratteri accentati, ho verificato ed e' cosi.  :(

possiamo ripristinare i post?  ::)

Ti ringrazio Emanuele sei il mio guru,

quasi quasi ti faccio entrare nel mio forum e ti nomino mod  :D

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #5 on: September 14, 2012, 05:29:28 PM »
1) se vado in UTENTE/MODIFICA PROFILO/PROFILO FORUM  e cerco di modificare un profilo mi esce questo messaggio
[...]
come procedo adesso?, i post degli utenti sono tutti azzerati, se do' un Thank You a un utente rimane vuoto vicino al profilo post
Purtroppo thank-o-matic non lo conosco minimamente...ed al momento mi sta venendo mal di testa dopo aver litigato tutto il giorno con una modifica ad un mod che non riuscivo a capire come funzionava...domani.


2) i post vengono troncati in corrispondenza dei i caratteri accentati, ho verificato ed e' cosi.  :(
Ok...ora mi piacerebbe capire perché prima funzionava ed ora no...

possiamo ripristinare i post?  ::)
Calma e gesso.
Dato il mal di testa di cui dicevo sono un po' rintronato....
Quelli che non si vedono sono i post nuovi o i post vecchi?
Cioè: quando crei un nuovo post questo viene troncato oppure tutti i post "vecchi" sono troncati?
Durante il casino dell'altro giorno hai per caso ripristinato anche un backup del database oltre che dei file?

quasi quasi ti faccio entrare nel mio forum e ti nomino mod  :D
Lascia stare, nonostante il mio forum è minuscolo non riesco già a star dietro a quello... ::)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #6 on: September 14, 2012, 05:43:59 PM »
oops, hai ragione devo essere specifico  ;)

1) i post che tronca sono quelli precedenti prima dell'installazione nuova del forum,
2 ) il database era il backup che ho fatto prima del ripristino (vuoi veder che e'/era corrotto?)

per il tuo mal di testa ti consiglio un'aspirina e una bella dormita

a domani (vado a dormire perche' dove sono io e' gia' tarda notte)

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #7 on: September 15, 2012, 03:52:44 AM »
(vuoi veder che e'/era corrotto?)
Esattamente la mia paura...
Prendi un messaggio che appare troncato, segnati il suo ID e vai a controllare nel database se è integro.
Per trovare l'ID passa col mouse sull'oggetto del messaggio, tasto di destra "copia collegamento" o qualcosa del genere e in un notepad of da qualche parte incolla, vedrai qualcosa tipo:
Code: [Select]
http://www.simplemachines.org/community/index.php?topic=486393.msg3406129#msg3406129la parte numerica di "msg3406129" è l'id del messaggio.

Nella tabella smf_messages, cerca quell'id e controlla il testo del messaggio, siccome il testo potrebbe essere lungo ti consiglio di cliccare sul pulsante di modifica del campo (basta poi non salvare), in questo modo ti apparirà il testo completo.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #8 on: September 15, 2012, 04:59:46 AM »
Buongiorno a questo splendido forum

Emanuele ho fatto come hai detto

1) Copia ID messaggio

2) phpMyAdmin/smf_messages/id_msg (con il valore id inserito)/Cerca

risultato:

il messaggio appare pure li troncato   :o

Soluzione?  :(

posso testarlo in locale sul mio computer il database?

che tool devo usare ?

Grazie Emanuele

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #9 on: September 15, 2012, 06:13:37 AM »
il messaggio appare pure li troncato   :o
Hai provato anche a cliccare la piccola icona di modifica?
Chiedo perché i campi lunghi in phpmyadmin vengono troncati in visualizzazione con i tre puntini di sospensione alla fine ed il vero valore del campo si vede solo andando a modificarlo.

Se nel database il messaggio è troncato, mi spiace ma ci sono buone probabilità che i messaggi siano andati... :(

Come hai fatto a fare il backup?

Prova così: scaricati ed installa notepad++ http://notepad-plus-plus.org/
Usa notepad++ per aprire il backup (se l'hai scaricato come zip decomprimilo prima, devi ottenere un file con estensione "sql"). Quando l'hai aperto prova a cercare l'id del messaggio ancora.
Qui dovrai cercare un po', ad un certo punto ti troverai di fronte ad una riga che dovrebbe essere più o meno:
Code: [Select]
(id_del_messaggio, id_del_topic, id_della_board, 12345678, id_utente, 0, soggetto, nick, email, IP, 1, 0, '', CORPO DEL MESSAGGIO, ecc.),id_del_messaggio, id_del_topic, id_della_board, id_utente saranno tutti numeri.
Controlla in questa riga se il messaggio è corretto oppure no.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #10 on: September 15, 2012, 06:37:30 AM »
1) phpmyadmin non mi fa' vedere altro, i post sono troncati anche cliccando sull'icona "modifica  (database del forum)

2) Aprendo con Notepad++ il database in locale nel mio computer, sorpresa, esce il post per intero

Cosa e' successo ?

il backup lo fatto dal forum stesso

Amministra/Manutenzione del forum/Database/Backup del database/Download


Si puo' risolverere ?

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #11 on: September 15, 2012, 06:49:37 AM »
Yuppi!
Almeno abbiamo un backup funzionante...
Fintanto che i dati ci sono tutto in un modo o nell'altro si può risolvere.

Per darti istruzioni precise devo accendere l'altro computer...ma ora è ora di pranzo, quindi mi sa che salta a tra un paio d'orette la risposta su cosa fare ora... ;)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #12 on: September 15, 2012, 07:04:43 AM »
Va beh, ritardo nel pranzo.

Quando apri il database in np++, nel menu "encoding", cos'è selezionato?
In phpmyadmin, quando fai l'import che "charset" c'è selezionato?
In phpmyadmin, le tabelle che "collation" hanno? (lo vedi nella pagina in cui sono elencate tutte le tabelle del database)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #13 on: September 15, 2012, 07:28:03 AM »
Va beh, ritardo nel pranzo.

Quando apri il database in np++, nel menu "encoding", cos'è selezionato?
In phpmyadmin, quando fai l'import che "charset" c'è selezionato?
In phpmyadmin, le tabelle che "collation" hanno? (lo vedi nella pagina in cui sono elencate tutte le tabelle del database)

1) quando apro il database in locale con Notepad++ in "Formato" c'e' scritto "Codifica UTF-8 (senza Bom)

2) Phpmyadmin "charset" utf-8

3) Phpmyadmin le tabelle hanno "collation"  "latin1_swedish_ci"

smf_messages                  utf8_bin
smf_sp_functions              utf8_general_ci
smf_thank_you_post        utf8_general_ci

e' servito ha qualcosa ?

Emanuele fai con calma, vai a mangiare e buon appetito

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #14 on: September 15, 2012, 08:31:02 AM »
Mi sembrava di averlo già chiesto, ma riguardando la discussione non lo ritrovo: come hai fatto il backup? Da phpmyadmin o dal pannello di admin di SMF?


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #15 on: September 15, 2012, 08:34:49 AM »
1) phpmyadmin non mi fa' vedere altro, i post sono troncati anche cliccando sull'icona "modifica  (database del forum)

2) Aprendo con Notepad++ il database in locale nel mio computer, sorpresa, esce il post per intero

Cosa e' successo ?

il backup lo fatto dal forum stesso

Amministra/Manutenzione del forum/Database/Backup del database/Download


Si puo' risolverere ?

lo avevo gia; scritto  ;D

Code: [Select]
il backup lo fatto dal forum stesso

Amministra/Manutenzione del forum/Database/Backup del database/Download

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #16 on: September 15, 2012, 09:03:17 AM »
Ecco, mi sembrava!! lol
* emanuele deve dormire di più... ::)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #17 on: September 15, 2012, 09:29:30 AM »
Fatti una bella dormita e poi riprendi  ;D

ho chiuso il forum in attesa di ulteriori sviluppi  ;)
« Last Edit: September 15, 2012, 10:55:35 AM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #18 on: September 15, 2012, 12:37:13 PM »
Hai un secondo database a disposizione sul tuo host?
Se sì, puoi importare il backup in questo secondo database e verificare (va bene sempre lo stesso messaggio) se sono ancora troncati o no?


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #19 on: September 15, 2012, 12:48:56 PM »
no,purtroppo nel mio host non ho un secondo database disponibile  ;)  :(

potrei installare simple machines in locale e provarlo

mi suggerisci qualche tool per non impazzire  ::)

o conosci altre soluzioni ?

devo risolvere questo problema perche' ho il forum bloccato per capire cosa e' successo e non ripetere l'errore in futuro

Grazie ancora per il tuo aiuto  :)

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #20 on: September 15, 2012, 01:11:54 PM »
Yep, in locale va bene uguale (anche se potenzialmente le condizioni potrebbero essere diverse rispetto al tuo host e quindi potresti non incorrere nel problema).
Puoi anche spianare il database che hai on-line e ricaricarlo là.

Per il locale...xampp, easyphp, Wampserver o VertrigoServ. Uno di questi dovrebbe andare.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #21 on: September 15, 2012, 03:14:57 PM »
niente, non riesco a caricare il database in locale  :( mi esce questo errore

"Stai probabilmente cercando di caricare sul server un file troppo grande" (Dimensione massima: 2,048KiB)

il database e' di 21 mb, sto usando Wampserver

bisogna intervenire allora sull'hosting e trovare una soluzione li, se non si puo'fare niente dimmelo Emanuele che lascio perdere

Grazie
« Last Edit: September 15, 2012, 03:26:46 PM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #22 on: September 15, 2012, 04:04:36 PM »


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #23 on: September 15, 2012, 04:07:12 PM »
finalmente sono riuscito ad aggirare il limite di phpmyadmin dei 2 mb con questa guida (uso Wampserver in locale)

eccola, la posto che puo'essere utile

Increase Size of import File in phpmyadmin

Try these different settings in C:\wamp\bin\apache\apache2.2.8\bin\php.ini

Find:
post_max_size = 8M
upload_max_filesize = 2M
max_execution_time = 30
max_input_time = 60
memory_limit = 8M

Change to:
post_max_size = 750M
upload_max_filesize = 750M
max_execution_time = 5000
max_input_time = 5000
memory_limit = 1000M

Then restart wamp to take effect



dopo aver importato il database ho cercato un post con messaggi troncati e li sono apparsi integrali senza tagli

adesso cosa bisogna fare?

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #24 on: September 15, 2012, 04:14:33 PM »
meh...quello che sospettavo.
Ehhh...niente, il database on-line è troncato, quindi mal che vada non perdi niente.
Svuotalo e reimporta il database. Poi, prima di fare qualunque cosa controlla se il messaggio è troncato o no.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #25 on: September 15, 2012, 05:09:44 PM »
ho fatto la soluzione piu' veloce, cancellato il database e l'intero forum

domani lo reinstallo e importo il database

in PhpMyAdmin cosa devo impostare ?

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #26 on: September 15, 2012, 05:21:06 PM »
lol
Sempre estremo...cancellare indiscriminatamente non aiuta mai, avresti già dovuto impararlo. ;)
Anche perché tanto, una volta che vai ad importare devi spianare comunque il database, quindi quello che ti resta in termini di file è sostanzialmente quello che già avevi. Comunque fa niente, magari ti va bene e questa volta si importa pulito.

In teoria in phpmyadmin non devi impostare niente.
Comunque: fai il più possibile simile a quando hai installato la primissima volta. Avevi installato "ISO" e poi convertito UTF8 o avevi già installato UTF8? Se ti ricordi, ripeti la stessa procedura.
Quando hai finito di installare, e prima di importare controlla che ls collation per tutte le tabelle sia utf8_general_ci (non ricordo più se il "_ci" sia importante o meno)

Quando hai finito l'import controlla se quel messaggio è tronco oppure no.

Credo sia tutto...


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #27 on: September 15, 2012, 05:35:02 PM »
ok ricevuto, ho ripulito perche' c'erano i mod dentro e possibile mi davano problemi
quando non funziona una cosa dall'inizio meglio ripetere la procedura cosi si scopre dove sta lo sbaglio  ;)

domani mi aspetta un po di lavoro, dopo ti tengo informato  :(

Buonanotte, vado a dormire (qui sono quasi le 2)

Grazie tante Emanuele.
« Last Edit: September 16, 2012, 04:06:02 AM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #28 on: September 15, 2012, 05:42:19 PM »
Buona notte! (...mmm...zona interessante... :P)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #29 on: September 16, 2012, 04:14:57 AM »
lol
Sempre estremo...cancellare indiscriminatamente non aiuta mai, avresti già dovuto impararlo. ;)
Anche perché tanto, una volta che vai ad importare devi spianare comunque il database, quindi quello che ti resta in termini di file è sostanzialmente quello che già avevi. Comunque fa niente, magari ti va bene e questa volta si importa pulito.

In teoria in phpmyadmin non devi impostare niente.
Comunque: fai il più possibile simile a quando hai installato la primissima volta. Avevi installato "ISO" e poi convertito UTF8 o avevi già installato UTF8? Se ti ricordi, ripeti la stessa procedura.
Quando hai finito di installare, e prima di importare controlla che ls collation per tutte le tabelle sia utf8_general_ci (non ricordo più se il "_ci" sia importante o meno)

Quando hai finito l'import controlla se quel messaggio è tronco oppure no.

Credo sia tutto...

buongiorno Emanuele.

ho installato il forum dall'inizio e importato il database con le impostazioni in phpmyadmin "utf8_general_ci"
dopo l'importazione in collation mi esce "latin1_swedish_ci" :o

nel forum i post che prima erano troncati adesso risultano scomparsi ? ( in locale pero' erano visibili)

non capisco piu' niente ?  :o  :(


   
« Last Edit: September 16, 2012, 05:18:51 AM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #30 on: September 16, 2012, 06:00:24 AM »
Prova ad aprire Settings.php, verso il fondo ci potrebbe essere questa linea:
Code: [Select]
$db_character_set = 'utf8';se c'è prova a toglierla, se non c'è prova ad aggiungerla...

Sono molto vicino al punto in cui ti dico passami i dati di accesso che provo ad aggiustartelo io... :P


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #31 on: September 16, 2012, 06:28:17 AM »
Prova ad aprire Settings.php, verso il fondo ci potrebbe essere questa linea:
Code: [Select]
$db_character_set = 'utf8';se c'è prova a toglierla, se non c'è prova ad aggiungerla...

Sono molto vicino al punto in cui ti dico passami i dati di accesso che provo ad aggiustartelo io... :P

Finalmente c'e lo fatta  ;D con l'aggiunta di questo
Code: [Select]
$db_character_set = 'utf8'; in Settings.php (prima non c'era) adesso i post non sono troncati

Resta il problema che in phpmyadmin mi visualizza le tabelle con Collation "latin1_swedish_ci", e'normale questo ?


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #32 on: September 16, 2012, 07:17:49 AM »
???
Okay, apparentemente ho imparato qualcosa di nuovo...

La collation latin non è "normale", ma...se funziona meglio non sfidare la sorte... :P


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #33 on: September 16, 2012, 07:25:50 AM »
???
Okay, apparentemente ho imparato qualcosa di nuovo...

La collation latin non è "normale", ma...se funziona meglio non sfidare la sorte... :P

dici che non e' normale, non doveva essere UTF-8, non sarebbe meglio la conversione da latin1_swedish_ci in utf8 ?  :o

quanti dubbi mi assalgono adesso  ::)

qui una guida su character set

http://www.html.it/pag/32146/i-set-di-caratteri/


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #34 on: September 16, 2012, 08:13:19 AM »
Come ho detto se tutto funziona io non sfiderei la sorte...
Comunque, in teoria se stai usando utf8 sarebbe meglio se tutto fosse utf8. Il problema è che cambiando la collation non son sicuro dei risvolti... ::)

Quel che ti posso dire è: se ti senti fortunato prova...


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #35 on: September 16, 2012, 08:31:11 AM »
come si dice, ho fatto 30..facciamo 31  ;)

come si cambia la collation in UTF-8 ?

se va' male cancello il database e lo ricarico un'altra volta (tanto il forum e' chiuso)

Grazie

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #36 on: September 16, 2012, 08:48:56 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #37 on: September 16, 2012, 08:56:14 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)

una per una  :o mi aspetta un bel lavoro (magari vano)  ;D

va beh,  ;) mi metto subito al lavoro

Grazie, poi ti faccio sapere gli sviluppi della conversione

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #38 on: September 16, 2012, 09:01:30 AM »
Ti consiglio ovviamente di partire da smf_messages, così sai subito se funziona o no! ;D


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #39 on: September 16, 2012, 10:19:27 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)

lavoro finito  :D ho fatto la collation come hai descritto sopra (e sotto)

Code: [Select]
"operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci.
1) non mi e'chiaro se devo cambiare la collation ad alcune tabelle con sotto-tabelle, sono ancora "latin1_swedish_ci"? (comunque ho messo uno screen per capire) ?

2) il forum visualizza i post senza troncamenti (finalmente)

3) in phpMyAdmin o impostato nel menu "Operazioni" come Collation "utf8_general_ci" di default (prima era latin1_swedish_ci)


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #40 on: September 16, 2012, 10:24:53 AM »
Non si tratta di "sotto tabelle", ma di colonne. ;)
In teoria anche loro dovrebbero essere in utf8. Controlla smf_messages la colonna body che è la più importante.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #41 on: September 16, 2012, 10:33:03 AM »
Non si tratta di "sotto tabelle", ma di colonne. ;)
In teoria anche loro dovrebbero essere in utf8. Controlla smf_messages la colonna body che è la più importante.

oops "colonne"  ::) , scusa cosa devo controllare in body ?

sto fondendo con questo forum  ;D

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #42 on: September 16, 2012, 10:42:50 AM »


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #43 on: September 16, 2012, 10:49:39 AM »
nella colonna body ci sono i post del forum, se vado a sinistra e clicco sull'icona modifica visualizzo il post per intero  :)

le colonne con codifica "latin1_swedish_ci" li converto o li lascio cosi? ::)

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #44 on: September 16, 2012, 11:40:18 AM »
Intendo: la colonna body è latin_swedish or utf8_general?


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #45 on: September 16, 2012, 11:49:50 AM »
Intendo: la colonna body è latin_swedish or utf8_general?

non riuscivo a trovare dove stava la codifica "body", poi ho capito, si deve fare cosi  ;D

smf_messages/Struttura

e si vede la codifica, in questo caso e' "latin1_swedish_ci:o

ma non l'avevo cambiato? :o

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #46 on: September 16, 2012, 11:54:13 AM »
Tu hai cambiato la collation delle tabelle, non quella delle colonne. ;)

And again: prova, magari, prima di cambiare la collation, crea una copia della tabella (sempre da operazioni), così nel caso vada male semplicemente cancelli la tabella e rinomini la copia "smf_messages". ;)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #47 on: September 16, 2012, 02:43:45 PM »
Lavoro finito, convertito tabelle e colonne in "utf8_general_ci"  ;D, ritornato sul forum e i post sono ancora interi e non troncati.

Penso che si puo' chiudere questo topic, ringrazio tanto Emmanuele per il suo aiuto (e la sua pazienza), senza di lui non saprei cosa fare.  :)


Alla prossima e buona serata a tutti

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #48 on: September 16, 2012, 02:45:55 PM »
Great! ;D


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #49 on: September 16, 2012, 02:47:40 PM »
ritorno per dire che almeno ho imparato qualcosa sui database  ;D