Advertisement:

Author Topic: Thank-o-matic errore e post troncati  (Read 7094 times)

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #20 on: September 15, 2012, 01:11:54 PM »
Yep, in locale va bene uguale (anche se potenzialmente le condizioni potrebbero essere diverse rispetto al tuo host e quindi potresti non incorrere nel problema).
Puoi anche spianare il database che hai on-line e ricaricarlo là.

Per il locale...xampp, easyphp, Wampserver o VertrigoServ. Uno di questi dovrebbe andare.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #21 on: September 15, 2012, 03:14:57 PM »
niente, non riesco a caricare il database in locale  :( mi esce questo errore

"Stai probabilmente cercando di caricare sul server un file troppo grande" (Dimensione massima: 2,048KiB)

il database e' di 21 mb, sto usando Wampserver

bisogna intervenire allora sull'hosting e trovare una soluzione li, se non si puo'fare niente dimmelo Emanuele che lascio perdere

Grazie
« Last Edit: September 15, 2012, 03:26:46 PM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #22 on: September 15, 2012, 04:04:36 PM »


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #23 on: September 15, 2012, 04:07:12 PM »
finalmente sono riuscito ad aggirare il limite di phpmyadmin dei 2 mb con questa guida (uso Wampserver in locale)

eccola, la posto che puo'essere utile

Increase Size of import File in phpmyadmin

Try these different settings in C:\wamp\bin\apache\apache2.2.8\bin\php.ini

Find:
post_max_size = 8M
upload_max_filesize = 2M
max_execution_time = 30
max_input_time = 60
memory_limit = 8M

Change to:
post_max_size = 750M
upload_max_filesize = 750M
max_execution_time = 5000
max_input_time = 5000
memory_limit = 1000M

Then restart wamp to take effect



dopo aver importato il database ho cercato un post con messaggi troncati e li sono apparsi integrali senza tagli

adesso cosa bisogna fare?

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #24 on: September 15, 2012, 04:14:33 PM »
meh...quello che sospettavo.
Ehhh...niente, il database on-line è troncato, quindi mal che vada non perdi niente.
Svuotalo e reimporta il database. Poi, prima di fare qualunque cosa controlla se il messaggio è troncato o no.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #25 on: September 15, 2012, 05:09:44 PM »
ho fatto la soluzione piu' veloce, cancellato il database e l'intero forum

domani lo reinstallo e importo il database

in PhpMyAdmin cosa devo impostare ?

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #26 on: September 15, 2012, 05:21:06 PM »
lol
Sempre estremo...cancellare indiscriminatamente non aiuta mai, avresti già dovuto impararlo. ;)
Anche perché tanto, una volta che vai ad importare devi spianare comunque il database, quindi quello che ti resta in termini di file è sostanzialmente quello che già avevi. Comunque fa niente, magari ti va bene e questa volta si importa pulito.

In teoria in phpmyadmin non devi impostare niente.
Comunque: fai il più possibile simile a quando hai installato la primissima volta. Avevi installato "ISO" e poi convertito UTF8 o avevi già installato UTF8? Se ti ricordi, ripeti la stessa procedura.
Quando hai finito di installare, e prima di importare controlla che ls collation per tutte le tabelle sia utf8_general_ci (non ricordo più se il "_ci" sia importante o meno)

Quando hai finito l'import controlla se quel messaggio è tronco oppure no.

Credo sia tutto...


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #27 on: September 15, 2012, 05:35:02 PM »
ok ricevuto, ho ripulito perche' c'erano i mod dentro e possibile mi davano problemi
quando non funziona una cosa dall'inizio meglio ripetere la procedura cosi si scopre dove sta lo sbaglio  ;)

domani mi aspetta un po di lavoro, dopo ti tengo informato  :(

Buonanotte, vado a dormire (qui sono quasi le 2)

Grazie tante Emanuele.
« Last Edit: September 16, 2012, 04:06:02 AM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #28 on: September 15, 2012, 05:42:19 PM »
Buona notte! (...mmm...zona interessante... :P)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #29 on: September 16, 2012, 04:14:57 AM »
lol
Sempre estremo...cancellare indiscriminatamente non aiuta mai, avresti già dovuto impararlo. ;)
Anche perché tanto, una volta che vai ad importare devi spianare comunque il database, quindi quello che ti resta in termini di file è sostanzialmente quello che già avevi. Comunque fa niente, magari ti va bene e questa volta si importa pulito.

In teoria in phpmyadmin non devi impostare niente.
Comunque: fai il più possibile simile a quando hai installato la primissima volta. Avevi installato "ISO" e poi convertito UTF8 o avevi già installato UTF8? Se ti ricordi, ripeti la stessa procedura.
Quando hai finito di installare, e prima di importare controlla che ls collation per tutte le tabelle sia utf8_general_ci (non ricordo più se il "_ci" sia importante o meno)

Quando hai finito l'import controlla se quel messaggio è tronco oppure no.

Credo sia tutto...

buongiorno Emanuele.

ho installato il forum dall'inizio e importato il database con le impostazioni in phpmyadmin "utf8_general_ci"
dopo l'importazione in collation mi esce "latin1_swedish_ci" :o

nel forum i post che prima erano troncati adesso risultano scomparsi ? ( in locale pero' erano visibili)

non capisco piu' niente ?  :o  :(


   
« Last Edit: September 16, 2012, 05:18:51 AM by Franco68 »

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #30 on: September 16, 2012, 06:00:24 AM »
Prova ad aprire Settings.php, verso il fondo ci potrebbe essere questa linea:
Code: [Select]
$db_character_set = 'utf8';se c'è prova a toglierla, se non c'è prova ad aggiungerla...

Sono molto vicino al punto in cui ti dico passami i dati di accesso che provo ad aggiustartelo io... :P


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #31 on: September 16, 2012, 06:28:17 AM »
Prova ad aprire Settings.php, verso il fondo ci potrebbe essere questa linea:
Code: [Select]
$db_character_set = 'utf8';se c'è prova a toglierla, se non c'è prova ad aggiungerla...

Sono molto vicino al punto in cui ti dico passami i dati di accesso che provo ad aggiustartelo io... :P

Finalmente c'e lo fatta  ;D con l'aggiunta di questo
Code: [Select]
$db_character_set = 'utf8'; in Settings.php (prima non c'era) adesso i post non sono troncati

Resta il problema che in phpmyadmin mi visualizza le tabelle con Collation "latin1_swedish_ci", e'normale questo ?


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #32 on: September 16, 2012, 07:17:49 AM »
???
Okay, apparentemente ho imparato qualcosa di nuovo...

La collation latin non è "normale", ma...se funziona meglio non sfidare la sorte... :P


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #33 on: September 16, 2012, 07:25:50 AM »
???
Okay, apparentemente ho imparato qualcosa di nuovo...

La collation latin non è "normale", ma...se funziona meglio non sfidare la sorte... :P

dici che non e' normale, non doveva essere UTF-8, non sarebbe meglio la conversione da latin1_swedish_ci in utf8 ?  :o

quanti dubbi mi assalgono adesso  ::)

qui una guida su character set

http://www.html.it/pag/32146/i-set-di-caratteri/


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #34 on: September 16, 2012, 08:13:19 AM »
Come ho detto se tutto funziona io non sfiderei la sorte...
Comunque, in teoria se stai usando utf8 sarebbe meglio se tutto fosse utf8. Il problema è che cambiando la collation non son sicuro dei risvolti... ::)

Quel che ti posso dire è: se ti senti fortunato prova...


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #35 on: September 16, 2012, 08:31:11 AM »
come si dice, ho fatto 30..facciamo 31  ;)

come si cambia la collation in UTF-8 ?

se va' male cancello il database e lo ricarico un'altra volta (tanto il forum e' chiuso)

Grazie

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #36 on: September 16, 2012, 08:48:56 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #37 on: September 16, 2012, 08:56:14 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)

una per una  :o mi aspetta un bel lavoro (magari vano)  ;D

va beh,  ;) mi metto subito al lavoro

Grazie, poi ti faccio sapere gli sviluppi della conversione

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,156
  • Gender: Male
  • THERE'S JUST ME
Re: Thank-o-matic errore e post troncati
« Reply #38 on: September 16, 2012, 09:01:30 AM »
Ti consiglio ovviamente di partire da smf_messages, così sai subito se funziona o no! ;D


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline Franco68

  • Jr. Member
  • **
  • Posts: 135
Re: Thank-o-matic errore e post troncati
« Reply #39 on: September 16, 2012, 10:19:27 AM »
Allora, prima di cambiare collation alle tabelle, prima entra almeno nella tabella messages e controlla che la collation dei campi (ad esempio body) sia utf8_general_ci.
Per cambiare la collation alle tabelle devi farlo una per una andando dentro alla tabella, quindi in alto a destra "operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci...pretty boring... ::)

lavoro finito  :D ho fatto la collation come hai descritto sopra (e sotto)

Code: [Select]
"operazioni" e nel blocck "opzioni tabella" dove c'è "collation" cambi in utf8_general_ci.
1) non mi e'chiaro se devo cambiare la collation ad alcune tabelle con sotto-tabelle, sono ancora "latin1_swedish_ci"? (comunque ho messo uno screen per capire) ?

2) il forum visualizza i post senza troncamenti (finalmente)

3) in phpMyAdmin o impostato nel menu "Operazioni" come Collation "utf8_general_ci" di default (prima era latin1_swedish_ci)