• Welcome to Simple Machines Community Forum. Please login or sign up.

Thank-o-matic errore e post troncati

Started by Franco68, September 14, 2012, 12:27:35 PM

Previous topic - Next topic

emanuele

Non si tratta di "sotto tabelle", ma di colonne. ;)
In teoria anche loro dovrebbero essere in utf8. Controlla smf_messages la colonna body che è la più importante.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Franco68

Quote from: emanuele on September 16, 2012, 10:24:53 AM
Non si tratta di "sotto tabelle", ma di colonne. ;)
In teoria anche loro dovrebbero essere in utf8. Controlla smf_messages la colonna body che è la più importante.

oops "colonne"  ::) , scusa cosa devo controllare in body ?

sto fondendo con questo forum  ;D

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Franco68

nella colonna body ci sono i post del forum, se vado a sinistra e clicco sull'icona modifica visualizzo il post per intero  :)

le colonne con codifica "latin1_swedish_ci" li converto o li lascio cosi? ::)

emanuele

Intendo: la colonna body è latin_swedish or utf8_general?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Franco68

Quote from: emanuele on September 16, 2012, 11:40:18 AM
Intendo: la colonna body è latin_swedish or utf8_general?

non riuscivo a trovare dove stava la codifica "body", poi ho capito, si deve fare cosi  ;D

smf_messages/Struttura

e si vede la codifica, in questo caso e' "latin1_swedish_ci:o

ma non l'avevo cambiato? :o

emanuele

Tu hai cambiato la collation delle tabelle, non quella delle colonne. ;)

And again: prova, magari, prima di cambiare la collation, crea una copia della tabella (sempre da operazioni), così nel caso vada male semplicemente cancelli la tabella e rinomini la copia "smf_messages". ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Franco68

Lavoro finito, convertito tabelle e colonne in "utf8_general_ci"  ;D, ritornato sul forum e i post sono ancora interi e non troncati.

Penso che si puo' chiudere questo topic, ringrazio tanto Emmanuele per il suo aiuto (e la sua pazienza), senza di lui non saprei cosa fare.  :)


Alla prossima e buona serata a tutti

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Franco68

ritorno per dire che almeno ho imparato qualcosa sui database  ;D

Advertisement: