Advertisement:

Author Topic: Similar Topics  (Read 77359 times)

Offline DEEPSNUYB

  • Jr. Member
  • **
  • Posts: 193
Re: Similar Topics
« Reply #140 on: June 02, 2013, 04:35:20 AM »
So what is the answer.  We're not as all smart as you.

Offline johnpaul2k2

  • Sr. Member
  • ****
  • Posts: 738
  • Gender: Male
  • Okija amaka
    • Mgbenka
Re: Similar Topics
« Reply #141 on: June 21, 2013, 03:03:13 AM »
how can i get similar post working on my wap2?

Offline wolfetundra

  • Semi-Newbie
  • *
  • Posts: 40
Re: Similar Topics
« Reply #142 on: August 14, 2013, 04:37:58 PM »
I really like this MOD but I cannot get it to work on my custom theme (Bad Company 3). It loads just fine on Curve. I'm running 2.0.4 with the following mods;

Mod Name   Version   
1.   Similar Topics   0.6
2.   Ad Managment   3.1a
3.   Signature Option Post   1.1.1
4.   Send Pm On X Posts   1.0
5.   Send Pm When Rank Change   1.0
6.   Referrals System   3.1
7.   Reason For Delete   1.0
8.   Rank Image Drop Down   1.0
9.   Month User By Smfsimple.com   V1
10.   Posting_Announcement   2.0
11.   SA Chat   RC3 Rev63
12.   Tapatalk SMF 2.0 RC5/Final Plugin   3.7.2
13.   Treasury   2.12
14.   Post Unapproval   1.1.4
15.   Alert   v.1.0   
16.   Admin Notepad   2.0.2
17.   Bad Behavior mod   1.5.17
18.   Downloads System   2.0a   
19.   Default_Membergroup   2.0

When I load it up I see
Similar topics
Loading...

Regardless of what I put in the subject or the body, nothing loads. It works perfectly on Core or Curve.

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #143 on: August 20, 2013, 01:18:19 AM »
Open /your_theme_folder/index.template.php, find and remove this line:
Code: [Select]
<script type="text/javascript" src="', $settings['theme_url'], '/scripts/jquery-1.4.2.min.js"></script>

Offline wolfetundra

  • Semi-Newbie
  • *
  • Posts: 40
Re: Similar Topics
« Reply #144 on: August 21, 2013, 02:36:39 PM »
Thank you! Wonderful!!

Offline ScrumpyJack

  • Semi-Newbie
  • *
  • Posts: 74
Re: Similar Topics
« Reply #145 on: September 08, 2013, 05:21:28 AM »
Open /your_theme_folder/index.template.php, find and remove this line:
Code: [Select]
<script type="text/javascript" src="', $settings['theme_url'], '/scripts/jquery-1.4.2.min.js"></script>

Hi Bugo,

I'm also having the 'loading' issue with the mod.

I am using the Firox multicolor theme, but can't find this line of code in my index.template.php.

Do you have any idea why it might not be working for me please?

I do have quite a lot of custom mods installed, so perhaps there are some jquery conflicts somewhere.

Thanks

:)

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #146 on: September 08, 2013, 11:27:27 PM »
so perhaps there are some jquery conflicts somewhere.

Offline JohnJohnson

  • Newbie
  • *
  • Posts: 3
Re: Similar Topics
« Reply #147 on: September 18, 2013, 10:43:37 AM »
Hello Bugo!

Your mods are great!
But I have same problem with Similar Topics as above.
I can see similar ones when creating new topic, but nothing is seen below "quick reply" on a topic page.
My existing forum uses only 4 mods:
Similar Topics
Optimus Brave
WYSIWYGQuickReply
SimpleAds

I also thought about jquery problem, but then I installed fresh smf 2.0.5 on denwer, installer russian utf-8 language and Similar Topics.
Then I started to create topics "Test 1", "Test 2", "Test 3"...
Nothing. I can see them while creating, but nothing below "quick reply" field.

Then I created search indexes (I thought it could make problem, no indexes), but still nothing.
So, again, fresh SMF 2.0.5 with Curve, only Similar Topics installed.
Topics can be seen on creating new topic page, but not below "quick reply" page.

Will appreciate any ideas.

P.s. Tried Firefox, Chrome, IE on Win 7.

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #148 on: September 18, 2013, 11:56:57 PM »
Screenshot of mod's settings, please.

Offline JohnJohnson

  • Newbie
  • *
  • Posts: 3
Re: Similar Topics
« Reply #149 on: September 19, 2013, 01:52:32 AM »
Here it is. Two from working forum, one from fresh test installation.

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #150 on: September 19, 2013, 04:24:54 AM »
Очистите папку cache и попробуйте Интервал обновления кэша установить в 0. А затем создать еще несколько похожих тем.
А если настроить вывод списка в верхней части — работает?

Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,145
  • Gender: Male
    • i30 Owners Club
Re: Similar Topics
« Reply #151 on: September 19, 2013, 04:58:38 AM »
Очистите папку cache и попробуйте Интервал обновления кэша установить в 0. А затем создать еще несколько похожих тем.
А если настроить вывод списка в верхней части — работает?

That's a little unfair on those of us following this topic, who don't speak the lingo  :-\

Offline JohnJohnson

  • Newbie
  • *
  • Posts: 3
Re: Similar Topics
« Reply #152 on: September 19, 2013, 05:25:22 AM »
It worked! Thanks Bugo!
I did it on local wamp, not on production site yet.
But it worked here, so should work there too.

Don't worry guys, I will translate. I think it can solve problems of many people here.
Quote
Clear cache and try to change cache interval to 0 (means in mod's settings). Then create some topics with similar titles again. Does it work if switch to "above topic" display?

I did not switch to "above topic", but this Bugo's instruction helped on local wamp server.

Neo_TE

  • Guest
Re: Similar Topics
« Reply #153 on: October 26, 2013, 01:14:10 AM »
I opened a thread in SMF 2.x support board, http://www.simplemachines.org/community/index.php?topic=513234, for the following error and it looks like that the database version error can be ignored as posted by the SMF devs. And I think similar topic mod was throwing this error and thought of posting it here. Thanks.




Quote
So I tried to add a new membergroup and got this error.

Quote
Database Error

Duplicate entry '11-auto_simtopics' for key 'PRIMARY'
File: Sources/ManageMembergroups.php
Line: 447

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.6, while your database is at version 2.0.4. The above error might possibly go away if you execute the latest version of upgrade.php.


SMF version is 2.0.6!

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #154 on: October 27, 2013, 08:41:17 AM »
Is there any indexes in your {prefix}messages table?

Offline Arkino

  • Semi-Newbie
  • *
  • Posts: 78
Re: Similar Topics
« Reply #155 on: November 01, 2013, 04:34:26 PM »
Hello there.

Thanks for this amazing mod but I have problems with showing similar topics on above and below topic. It does NOT show.

1. I changed "Cache update interval" to "0"
2. I went to "Empty the file cache"
3. I created 3 topics with similar titles and it did not work

And also I have done this too:

1. I have changed above to below topic and it did not work

I leave a screen shot of my set up. Please any help wpuld be great. Thanks

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #156 on: November 01, 2013, 04:50:58 PM »
Any links to these topics?

Offline Arkino

  • Semi-Newbie
  • *
  • Posts: 78
Re: Similar Topics
« Reply #157 on: November 01, 2013, 05:01:20 PM »
Any links to these topics?

Here you are:

http://edited.com

I have changed to default theme, I was hoping that it may work on the default theme but it did not.

My mods:

1.    Additional Instant Messengers
2.    More Spiders    1.2
3.    Member Color Link
4.    reCAPTCHA for SMF
5.    Auto Merge Double Post    
6.    New Topic Button
7.    Tidy Child Boards
8.    Ad Managment
9.    Enhanced Dropdown
10.    Spoiler Tag
11.    nCode Image Resizer
12.    Users Online Today
13.    Related Topics
14.    Spiders Don't Increase Topic Views
15.    Pretty URLs
16.    cbi 1.0
17.    Similar Topics    0.6

and also i will leave my current set up.

Please, any help would be great. I want this mod to show up after "Quick Reply"
« Last Edit: November 04, 2013, 06:28:48 PM by Arkino »

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,533
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #158 on: November 01, 2013, 11:09:09 PM »
Did you try to reinstall the mod?
Also, I would be happy to receive a test account on your forum.

Offline Arkino

  • Semi-Newbie
  • *
  • Posts: 78
Re: Similar Topics
« Reply #159 on: November 01, 2013, 11:11:21 PM »
Did you try to reinstall the mod?
Also, I would be happy to receive a test account on your forum.


Hi, thanks for replying.

I already re-install the mod and it did not work.

Do you want me to send the information for PM (test user)? and also i can give you TeamViewer if you want.