• Welcome to Simple Machines Community Forum. Please login or sign up.

Add Facebook Like, Tweet, and Google +1

Started by PokémonS, January 02, 2013, 01:42:20 PM

Previous topic - Next topic

tsis_k

August 09, 2013, 10:08:40 AM #80 Last Edit: August 09, 2013, 11:39:24 AM by tsis_k
Hello everyone,

I am having the same problem as many of you do. The facebook like only appear in my activity log, however, I noticed that I can manually publish each like from my activity log to my timeline. Having to manually publish each like from the activity log to the timeline really sucks and time consuming.

I want my facebook likes to appear automatically to my timeline. I'm sure this is a facebook privacy setting but I can't find how to enable facebook likes to post to the timeline automatically.  If anyone found a solution, please share.

I also would like to know if/how I change the facebook like icon to facebook recommend icon instead. It's more fitting to forum post, IMO.

Thanks.

AllanD

It is possible to have this show on every post not just the top one?
Check out this great sites.
KnD Hosting

HackAl

Hello.

I love this mod and hope I can get it to work.  I tried installing at www.hackensacknow.com.  I enabled everything in Modification Settings but I don't see the FB/Tweet/Google buttons in my topics. 

No error messages.  I'm wondering what I missed. 

Thanks in advance.
++++++++++++++++++++++=
Figured it out.  Sorry. Thanks.

AllanD

It display on the first post at the bottom.   I checked and I see it displayed on your posts.
Check out this great sites.
KnD Hosting

ardvark

Anyone having any luck with this on 2.06?  I am having the same issue as others with the Facebook button not actually having any effect on Facebook. Pokémon, the mod works amazingly well on your personal site and I would love that functionality as well!  Thanks for the mod.

sparky33

Mod works a treat, but is there any way to apply it to every post?
www.dublinforums.org

www.renaultforums.co

Arantor

Fairly sure that's not possible because those things all rely on the URL of the page in question, not a part of a page.
No good deed goes unpunished
All helpful urges should be circumvented

amadeos

This mod is exactly what I've been looking for)
Thanks

mrkid

I can't get the any of the buttons to show. Everything is checked in the settings. I thought it was my adblocker, but turned that off and still nothing. I'm running 2.06.
Another interesting part to this is when I tried to uninstall. It tries to remove the same code from two different files. Only one of which contains the code according to the parse list.

mrkid

I'm thouroughly confused now. I just checked two of the sites in this thread that people say the buttons are working fine, and I can't see them. Can someone please check if they can see them on my site? http://www.hauntersnation.com/forum/index.php?action=forum

I'm wondering if something is blocking them on my computer?

Arantor

Well, in your theme's code I see:
<center><script language="JavaScript" type="text/javascript">
top();
</script></center>


but top() is not declared and so the browser reports a JavaScript error - and this disables all other code after it.
No good deed goes unpunished
All helpful urges should be circumvented

mrkid

That's strange. I see that in the index.template.php, but when I try anything to change it, I get the white screen of death. It's actually the original code from the Black Rain V2 theme.

mrkid

So I straightened out that rogue script. It was leftover from another mod I removed. Still have no buttons showing. I've tried just about every mod to get e google + button in the first post (or any post) and they just never work. Any ideas? ???

mrkid

It's all fixed now. After noticing everything worked on my mobile page, I checked IE and Chrome. Both were showing the all of the buttons(though IE had them out of line)
I went and reset Firefox by going to Firefox>Help>Troubleshooting information then hit Reset Firefox. It saved all my info, and fixed some things that got botched in the latest upgrade. Hopefully this will help other people fix some "unsolvable" issues.

HRM

December 28, 2013, 04:38:09 PM #94 Last Edit: December 28, 2013, 04:53:01 PM by HRM
Great MOD . I did the manual install for SMF 2.0.6 and looks fine with the default theme.
Now only with my own theme the buttons dont show.
I use a variation of the BlackrainV2 Theme (the same only different color).
further no errors.
Same issue in all browsers.
Any idea?

To install something for the cat's 'cut' is never nice..... (old dutch saying) :D

Colin

Were there any errors reported on installation, with the custom theme checked?
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

HRM

No errrors cause I did the manual installation (package manager currently doesnt work for me). further it just worked straight ahead.
To install something for the cat's 'cut' is never nice..... (old dutch saying) :D

HRM

December 29, 2013, 04:22:42 AM #97 Last Edit: December 29, 2013, 04:37:48 AM by HRM
 :o
It's working!  8)
I had just forgotten to add the corresponding code to Display.template.php of my own Theme (and all other then default).
My bad.
Must have been very tired yesterday  :laugh:

Thanks anyway Colin
To install something for the cat's 'cut' is never nice..... (old dutch saying) :D

HRM

Quote from: NightzKung on February 16, 2013, 04:42:21 AM
add Facebook Like+share

// Show Facebook Like icon in the first post
if (!empty($modSettings['facebook_like'])) {
echo '
<div id="fb-root"></div>
<div style="margin-left:auto;margin-right:2em;text-align:center;padding-right:12px" class="fb-like" data-href="', $scripturl, '?topic=', $context['current_topic'], '" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-font="verdana"></div>';


../../index.template.php
find
// Here comes the JavaScript bits!
echo '


add after
<script type="text/javascript" src="https://connect.facebook.net/en_US/all.js#xfbml=1"></script>

Thanks a lot for this addition !
Right what I was lookin for. Now it has the share/like thingy from Fb, like the twitter and google button. This makes this mod almost perfect! . :D
I'd like to advise to Pokemons to add this one to next time.

To install something for the cat's 'cut' is never nice..... (old dutch saying) :D

Colin

Quote from: HRM on December 29, 2013, 04:22:42 AM
:o
It's working!  8)
I had just forgotten to add the corresponding code to Display.template.php of my own Theme (and all other then default).
My bad.
Must have been very tired yesterday  :laugh:

Thanks anyway Colin

Fantastic :)
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Advertisement: