• Welcome to Simple Machines Community Forum. Please login or sign up.

Problema con il database dopo aggiornamento alla versione 2.0.3.

Started by cluaudiuzz, January 08, 2013, 05:12:28 AM

Previous topic - Next topic

cluaudiuzz

Salve a tutti,
Io quando cerco di caricare alcune mod ho il seguente errore:

Incorrect table name 'mionome.smf_topics'
File: /home/mionome/public_html/Packages/temp/install_db.php
Riga: 48

Nota: Sembra che il tuo database debba essere aggiornato. I file del forum risultano attualmente alla versione SMF 2.0.3, mentre il database corrisponde alla versione 2.0.2. Il problema potrebbe essere risolto eseguendo l'ultima versione del file upgrade.php.


Qualcuno sa come aiutarmi?

emanuele

Magari per prima cosa sarebbe carino avere qualche esempio di mod che ti danno questo problema...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz

L'ultima mod che mi ha mostrato l'errore in questione è la seguente:
SMFSIMPLE Bookmarks   http://custom.simplemachines.org/mods/index.php?mod=3447

Anche questa : Add Facebook Like, Tweet, and Google +1 http://custom.simplemachines.org/mods/index.php?mod=3559
Ho la versione 2.0.3 e l'ultima mod linkata è compatibile con questa versione ( almeno così c'è scritto)

Le altre mod non le ricordo perchè le ho cancellate.

Grazie

emanuele

...mmm...mmm...mmm...

Non vedo niente di sbagliato...
Per scrupolo controlla via phpmyadmin se esiste la tabella smf_topics...ma se non esistesse sarebbe abbastanza evidente...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz

La tabella .smf_topics esiste
Se vado a controllare il File: /home/mionome/public_html/Packages/temp/install_db.php

La riga 48 è vuota ovvero spazio bianco. Roporto la riga 47 e 49

//Call db_extend

   db_extend('packages');

Non so di cosa si tratta...

emanuele

Il messaggio è sempre relativo alla tabella topics, oppure anche ad altre?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz


emanuele

Ma te qualcosa di semplice no? :P

Non ne ho assolutamente idea: il codice d'installazione del mod è corretto.
La tabella c'è.
Fantasmi?...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz

eh Emanuele, oggi ho contattato un esorcista per il mio forum credo sia posseduto , non c'è altra spiegazione  ;D ;D

emanuele

Prova così, giusto per curiosità: scarica il mod, decomprimilo, carica il file install_db.php nalla directory del forum e raggiungilo dal browser e vedi cosa ti dice.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz

Ciao Emanuele il problema era dovuto al prefix delle tabelle del mio database . il mio hosting mi impone l'utilizzo del mio nome utente prima del nome del mio database e probabilmente le tabelle avevano subito il medesimo procedimento. ho caricato repair_setting e ho cambiato il prefix  delle tabelle e tutto sembra risolto. Sono riuscito a caricare le mod che prima non riuscivo ad installare...

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

cluaudiuzz

 
Quote from: emanuele on January 10, 2013, 04:28:27 AM
E come diavolo faceva il resto del forum a funzionare? ???

te l'ho detto che ho chiamato un esorcista perché secondo me il forum e' posseduto.... :) :)

Advertisement: