• Welcome to Simple Machines Community Forum. Please login or sign up.
January 19, 2022, 10:09:31 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


SMF 2.0.4 and 1.1.18 critical security patches released

Started by emanuele, February 01, 2013, 05:26:51 PM

Previous topic - Next topic

jafonseca


LiroyvH

Quote from: jafonseca on February 04, 2013, 11:28:27 AM
Is possible to update from 2.0.1 to 2.0.4?

Yes, with the large upgrade package that you can find on our download page.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

beast44



  I've updated to from 2.0.3 to 2.0.4 Do I now have to uninstall 2.0.3?

;D

Don't have one, Don't want one, Not gona get one

Kindred

jafonseca, you can do it in one swoop with the large upgrade... but that will require a rienstallation of mods, etc. Or you can do it provgressively 2.0.1 -> 2.0.2 -> 2.0.3 -> 2.0.4 using the patch packages in the package manager.

beast44, no.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Argonaut

Quote from: Kindred on February 04, 2013, 07:51:28 AMthis topic is not for support.  Please raise your issues in a topic in the support board.
...

Yes, I know.
Quote from: Argonaut on February 04, 2013, 07:39:00 AM
...
Well, this is not a support question, it's only a statement.
...

I've started a new thread

www.simplemachines.org/community/index.php?topic=496641.0

beast44



  I thank you very much. As always, all of you do a very good job

;D

Don't have one, Don't want one, Not gona get one

Mstcool

That was pretty fast. I never even noticed. I saw the "alert box" mod and it says compatible with 2.0.4. And I'm just like what the heck? And then a couple of other mods had the same thing. LAWL!!! LOL!!! XD!!!

Colin

Quote from: Mstcool on February 04, 2013, 11:29:36 PM
That was pretty fast. I never even noticed. I saw the "alert box" mod and it says compatible with 2.0.4. And I'm just like what the heck? And then a couple of other mods had the same thing. LAWL!!! LOL!!! XD!!!
Indeed it was. Did the upgrade go alright for you?
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Gerkin

Strangest thing ever ... on a 1.1.17 server I clicked through the update link in admin, the patch said it tested fine, clicked to apply ... and although it said it applied fine it didn't.  The only reason I noticed was that the version number in the footer did not update so I investigated further.  When I manually looked at the files to verify if it applied or not it indeed did NOT apply, the changes were not made to any of the files listed in the .mod or the .xml file.  The system did say that the mod was already applied (and it wasn't possible to back it out because it had no uninstaller) when I checked to see if it showed up as installed.

I applied all the edits by hand and it seems to be working fine, but this is a bit concerning.  Is it possible that a previous update somehow broke the ability to properly run these patches in an automated way?  If I can provide more information to test this hypothesis please let me know and I'll do what I can.  This is the first time in a looooooong time that I've had to apply a patch by hand for SMF!

alchemyst

The package manager has never worked for me.  I always get an incorrect URL/file not found error on the link in the admin area, trying to download the file from the package manager gives me an error saying their was an error and the file was empty.

Why doesn't this work; it works in many other programs without a hitch.

Kindred

alchemyst, this topic is not for support.

Since it has bene installed (both through the package manager or admin link) and through the "downloaded patch" package on several thousand sites, it would seem that there is some odd configuration with your server.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

amko_sa


Mstcool


tbplayer

Updated from 2.0.3 to 2.0.4 - no issues, all mods working.

Thanks for all of your great work!   :)

Colin

"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Rambaldi

i have this error:
Error retrieving information on step: Converting "log_online" (Item 4)
i update from version 2.0.2 to 2.0.4

emanuele

How did you do the update? It seems you are using the upgrade, you may have applied the packages (patches or whatever) from the package manager instead: fir the 2.0.3 and then the 2.0.4.

ETA: also, it would be better if you open a topic in the support board and not use this topic for support. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

HsvHome

February 13, 2013, 10:06:07 PM #97 Last Edit: February 13, 2013, 11:06:19 PM by Kindred
Quote from: emanuele on February 01, 2013, 05:26:51 PM
Dear users,

Simple Machines has released a critical security patch with version numbers: SMF 1.1.18 and SMF 2.0.4.
A few critical security issues have been identified in the two maintained versions and are fixed with this update, therefore it is recommended to make sure you update your forums immediately to ensure your community is safe. For SMF 2.0.x this update includes a few other minor bugs that have been fixed.

If you are running 2.0.3, you can update your forum to 2.0.4 using the package manager. You should see the upgrade notification in the Admin panel and in the package manager, allowing you to download and install seamlessly. If you don't have a notification about the update, please run the scheduled task "Fetch Simple Machines files".
You can also download the update for 2.0.3 from the customize site (Upgrades site page): smf_patch_2.0.4.tar.gz, and install it using the package manager.

If you are running 1.1.17, you can update to 1.1.18 from the package manager, following the instructions in the notification in the Admin panel, or downloading the patch from the customize site (Upgrades site page): smf_patch_1.1.18.tar.gz, and installing it using the package manager.

If you use older versions of SMF, you can upgrade with the full upgrade packages from the downloads page.
Please find the changelog for the latest release, as usual, on the downloads page as well:
http://download.simplemachines.org/

Please find more informations on the Online Manual:
* upgrading http://wiki.simplemachines.org/smf/Upgrading
* patching http://wiki.simplemachines.org/smf/Patching

Please do not use this topic for support requests. You will get a much quicker and better response by posting in the relevant support board!

Regards,
Simple Machines Forum

Edit: the language packs are currently broken, in few hours they will be regenerated, we are sorry for the inconvenience.


How do I know what version I have?  My SMF stopped working a couple of days ago.  I haven't touched a thing and I keep getting:Connection Problems

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

What do I do at this point?  I haven't had to mess with this software in so long.  Everything has been running smooth.




link removed - Kindred

mashby

Hmm...not sure of course either. I would contact your host and ask about the status of your database server.
Always be a little kinder than necessary.
- James M. Barrie

HsvHome

February 13, 2013, 10:27:32 PM #99 Last Edit: February 13, 2013, 11:06:07 PM by Kindred
Do you mean my web hosting service?



link removed - Kindred

Advertisement: