Advertisement:

Author Topic: Thème  (Read 5455 times)

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Thème
« on: February 18, 2013, 02:05:40 AM »
Bonjour tous le monde,

Je cherche à mettre en transparent l'emplacement du Thème par défaut au niveau du logo...

En image :



Merci pour vos réponses et votre aide.

Olivier.


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #1 on: February 18, 2013, 02:45:56 AM »
Bonjour,

Première chose on ne touche pas le thème par défaut "default", c'est pour une question de fonctionnement de SMF.

Si tu veux changer l'apparence du style de ton forum à partir du thème default, il faut déjà créer un copie de ce thème.
C'est à partir de cette copie (que tu appelle comme tu veux), placée dans le FTP, que tu pourras bidouiller ton thème.

Je te conseille de regarder les thèmes fournis par SMF pour voir quels fichiers copier dans ce dossier thème. Tous les fichiers du thème "default" ne sont pas à copier.

Quand tu en seras là on pourras voir ce que tu veux faire exactement.

Voici la liste pour les thèmes SMF (attention, bien choisir sa version) : http://custom.simplemachines.org/themes/


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #2 on: February 18, 2013, 03:48:03 AM »
Merci pour ta réponse, je vais faire ce que tu me conseilles ...  ;)

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #3 on: February 18, 2013, 08:13:26 AM »
Voici à titre d'info une composition de thème de base, élaborée à partir de "default"

Les fichiers images, composants le thème , on volontairement étaient déplacés sur la droite.

Cette composition est en version french (iso).

(fichiers joints)


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #4 on: February 18, 2013, 11:15:14 AM »
La partie qui t’intéresse ce trouve dans .../Themes/default/images/theme/main_block.png.

C'est un ensemble d'images qui est utilisé et géré par index.css du thème.

Donc il va falloir y aller doucement pour modifier !

Edit:


Pour info à ce niveau, tu ne pourras pas gérer la transparence. Cette dernière deviendra blanche (main_block.png).

Il faut modifier le header du forum.

L'idéal est de te faire une maquette (image) pour définir ce que tu veux exactement. Ensuite on essayera de réaliser au mieux suivant les contraintes.

« Last Edit: February 18, 2013, 11:38:26 AM by Zuki. »


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #5 on: February 18, 2013, 11:42:02 AM »
Bien ! je vois que tu maitrises ! :)

Si tu as besoin de renseignements...  ;)


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #6 on: February 21, 2013, 11:29:37 AM »
Bonjour et merci Zuki.

De bonnes informations que tu me transmets. J'en prends note.

Merci encore pour tous.

Olivier.


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #7 on: February 23, 2013, 04:45:43 AM »
Bonjour, pas si simple que çà ...

Il ne me reste plus qu'à trouver où est le background de la partie "Centre d'informations". En effet sur certains écrans, le fond est jaune.  :-[



Si vous avez un tuyau, ce serait sympa, le thème est celui que SMF propose :

http://custom.simplemachines.org/area51/themes/index.php?lemma=2327

Bon Week-End.

Olivier.

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #8 on: February 23, 2013, 10:43:55 AM »
Bonjour,

Le background est le même partout, sur ton forum ! (firefox, chrome, ie9) (blanc cassé - beige)

De toute façon c'est le même partout - voir dans le thème  partie : images/theme

Par contre sur ie9 tu as problème d'alignement entre ton centre d'administration et le corps du forum.
A vérifier !


Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,301
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Thème
« Reply #9 on: February 23, 2013, 11:51:55 AM »
Bonjour,
 
Oui si tu veux changer le background tu dois redéfinir des classes css et les modifier dans le fichier BoardIndex.template :)
 
 
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #10 on: February 28, 2013, 01:07:04 AM »
Bonjour,

Le background est le même partout, sur ton forum ! (firefox, chrome, ie9) (blanc cassé - beige)

De toute façon c'est le même partout - voir dans le thème  partie : images/theme

Par contre sur ie9 tu as problème d'alignement entre ton centre d'administration et le corps du forum.
A vérifier !

Bonjour,

Merci pour toutes ces informations, tu as raison dis donc ! même sous IE 10!  ::)

Je vois les sections quand je mets le thème Curve, mais dès que je clique sur une section elles disparaissent ! Du mieux.

Donc pas le thème je pense, ensuite je pense aux mods, j'ai installé sur un autre forum les mêmes mods avec le même thème et pas de soucis.

Qu'est ce qu'il a qu'il lui plait pas IE!

Si vous avez une idée. Encore merci je m'en serais pas rendu compte! Chrome et Firefox c'est bon l'alignement. Merci pour votre aide précieuse.

Olivier.

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #11 on: February 28, 2013, 02:34:29 AM »
Bonjour,

Pour info, ce matin, ça fonctionne correctement avec IE9  !?  :o

J'ai déjà installé le thème High_Sky20 sur un forum, sans aucun problème de fonctionnement, quelque soit le navigateur.




Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #12 on: February 28, 2013, 02:36:49 AM »
Oui exact, je viens de voir que le problème venait du mod : Simple Announcement Mod  ::)

J'ai désinstaller le thème, et suis entrain de réinstaller les mods.

Une question, nous sommes obligés de les réinstaller, au cas ou par la suite, nous changions de Thèmes ?

Merci pour votre réponse.

Olivier.

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #13 on: February 28, 2013, 03:04:06 AM »
Tu as bien pris cette version :     SimpleAnnonuncementMod202.tar.gz ??? Attention, l'autre ne marche pas pour 2.0.4 !

Pour les Mod. , désinstaller ne veut pas dire effacer !

Le lexique !  ;)

Télécharger : mise en place dans le FTP (inactif sur le forum/base de données)

Installer : mise en place dans la base de données pour fonctionner (actif sur le Forum/base de données)

Désinstaller : supprimer de la base de données (inactif sur le forum/base de données - toujours en place dans le FTP)

Effacer : supprime le Mod du FTP (à re-télécharger en cas de besoin).


Dans ton cas si tu veux garder le Mod pour plus tard, tu ne fait que "désinstaller"

Dans le panneau Admin des Paquets le voyant vert disparait, la fonction [ installer ] réapparait !


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #14 on: February 28, 2013, 03:33:29 AM »
D'accord, je comprends mieux cette philosophie !

De fait, je pense que le problème est résolu. Réinstallation du Thème, désinstallation des mods et réinstalle des mods. L'alignement semble conforme, rassure moi en me confirmant.

La partie qui t’intéresse ce trouve dans .../Themes/default/images/theme/main_block.png.

C'est un ensemble d'images qui est utilisé et géré par index.css du thème.

Donc il va falloir y aller doucement pour modifier !

Edit:


Pour info à ce niveau, tu ne pourras pas gérer la transparence. Cette dernière deviendra blanche (main_block.png).

Il faut modifier le header du forum.

L'idéal est de te faire une maquette (image) pour définir ce que tu veux exactement. Ensuite on essayera de réaliser au mieux suivant les contraintes.



Complètement raison et aussi tester sur les navigateurs les plus courants.  :-\  ;)


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #15 on: February 28, 2013, 04:30:08 AM »
Le problème réapparait sur IE9.

Décalage précité !

Tu n'as pas d'"echec" lors de l'installation du Mod (SimpleAnnonuncementMod202) ? (En rouge)

Lors de la mise en place du Mod (SimpleAnnonuncementMod202), il faut regarder dans la page si on te demande de l'appliquer au différents thèmes présents sur ton SMF ; si c'est le cas il faut cocher les cases correspondantes.

Dans le cas contraire, il te faut vérifier si le mod a une influence sur des fichiers commun aux différents thèmes (ex: index.template.php) ; là il te faudra mettre en manuel la modification des lignes de code.


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #16 on: February 28, 2013, 04:36:14 AM »
Effectivement il y a influence sur index.template.php, BoardIndex.template.php.

Si tu as modifié ces fichiers (voir présence dans le thème via FTP) ou s'ils ne sont pas pris en compte à l'installation du Mod, il te faut faire la mise en place en manuel du Mod.

Edit :

Les fichiers nécessaires pour un thème sont prépondérants sur les fichiers du thème "default".

Mais on ne retrouve dans le thème choisi que le stricte nécessaire pour la mise en place de ce dernier.

ex : index.template.php , dossier images, index.css... (il suffit de regarder le dossier du thème téléchargé  ;))


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #17 on: February 28, 2013, 05:51:58 AM »
J'en apprends beaucoup de ce que tu me dis. Je pense que j'étais entrain de modifier le thème quand tu es passé.

Je pense que maintenant, çà doit être bon.  :)


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #18 on: February 28, 2013, 06:57:45 AM »
Chez moi c'est toujours en vrac !

Pour le "calandrier" aussi.

C'est bizarre...


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #19 on: February 28, 2013, 07:11:02 AM »
Il te manque aussi des images...

(IE9)  Stat arcade - exemple : .../Themes/High_Sky20/images/gold.gif


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #20 on: February 28, 2013, 07:15:15 AM »
Vu Merci. Je vais voir avoir un autre PC pour le thème  :-\

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #21 on: February 28, 2013, 07:16:51 AM »
Internet explorer 10 c'est bon, le 9 non ...  :(

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #22 on: February 28, 2013, 07:18:30 AM »
Pour le thème vider tes caches navigateurs !  ;)

A essayer aussi : Admin/Configuration/Thèmes et disposition/Réglages des Thèmes => Bouton [ Tenter de réinitialiser tous les thèmes ]


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #23 on: February 28, 2013, 07:19:17 AM »
Je viens d'enlever le mod Simple Announcement Mod C'est bien lui le problème...

Celui que j'ai : SimpleAnnonuncementMod202

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #24 on: February 28, 2013, 07:20:15 AM »
Fait  :D

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #25 on: February 28, 2013, 07:20:42 AM »
Internet explorer 10 c'est bon, le 9 non ...  :(

Je n'ai pas encore mis le ie10, je l'ai juste récupérer mardi.

Mais le ie10 est un ie 9 amélioré , pour cause !!!  ;)


Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #26 on: February 28, 2013, 07:22:57 AM »
Je viens d'enlever le mod Simple Announcement Mod C'est bien lui le problème...

Celui que j'ai : SimpleAnnonuncementMod202

En fait, logique pour ce matin !!!

Là, je n'ai pas le temps, mais plus tard dans l'après midi, si tu veux je peux regarder sur un forum test chez moi.

Edit:

Tu peux essayer de le mettre en manuel, il n'y a pas beaucoup de modif à faire...   8)



Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #27 on: February 28, 2013, 07:25:13 AM »
Ah ce serait super Zuki.

Si c'est le mod, je pense qu'il doit en exister d'autre pour remplacer celui-ci ?

Internet Explorer 11. Tout fonctionnera IMPEC !  :P

Edit : Vu

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #28 on: February 28, 2013, 07:35:06 AM »
Je viens de le faire à la main, comme dans le bon vieux temps ...  :P

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #29 on: February 28, 2013, 07:59:58 AM »
Dans plusieurs fichiers, le code est répété, je dois m'absenter, je ferais le ménage en revenant. Je te tiens au courant.

Merci Encore.

 :D

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #30 on: February 28, 2013, 09:20:30 AM »
Je viens de tester il s'installe correctement et fonctionne.

Quote
Dans plusieurs fichiers, le code est répété

Là c'est que tu as eu plusieur install. pas bien.  >:(

Il te faut reprendre tout à la main. Remettre au propre. 





Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #31 on: February 28, 2013, 09:55:58 AM »
Réflexion à propos de  Simple Announcement Mod

Je vois que tu as un portail (SimplePortal), pourquoi ne pas utiliser un bloc à la place de Simple Announcement Mod.

Le réglage du bloc est très performant à méditer ! (Voir la partie : Afficher les options)



Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #32 on: February 28, 2013, 10:25:09 AM »
Oui exact, merci de m'y avoir fait penser. Je vais regarder de côté-ci.

 :)

Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #33 on: March 01, 2013, 02:17:52 AM »
Bonjour,

J'ai pu créer un bloc custom en HTML grâce au portail. Super idée que tu as eu.  ;)

J'ai retravaillé le blanc cassé dans les couleurs du CSS. Je pense que logiquement çà doit être bon ..

Bon week end.

Olivier.

Offline Zuki.

  • Sophist Member
  • *****
  • Posts: 1,308
  • Gender: Male
  • SMF 2.0.5
    • F T Z - Forum Train Zuki
Re: Thème
« Reply #34 on: March 01, 2013, 02:49:30 AM »
Bonjour,

On ne pense pas  toujours à tout !  ;)  Les échanges sur le forum sont faits pour cela... 8)

Une petite chose encore... Ton logo est hébergé chez imageshack, je te conseillerais de le mettre dans ton hébergement.

Personnellement le mien est dans : .../forum/Themes/default/images/mon_logo.png (Pourquoi dossier "default" : lui on n'y touche jamais et il le faut pour fonctionner).
De plus en cas de problème chez imageshack, tu peux avoir une panne ou un problème d'affichage et te retrouver sans logo ; si tout est hébergé au même endroit pas de soucis de ce côté là.

Bonne journée.


Offline TiMnZb

  • Jr. Member
  • **
  • Posts: 174
  • Gender: Male
    • REFERENCEMENT NEWSGROUPS
Re: Thème
« Reply #35 on: March 01, 2013, 07:02:53 AM »
Merci pour cette aide précieuse, j'ai suivi ton conseil pour le logo.  :D

Bon Week-End.

Olivier.