News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Where is navigate section?

Started by Mr. Pedram, March 13, 2013, 12:52:54 PM

Previous topic - Next topic

Mr. Pedram

Hi there,
can someone tell me, where "navigate_section" located? in which file?
it's a <ul> <li> that placed in up and bottom of post pages, (Display.Template.php) i couldn't find it on Display.template, sure it's hiding somewhere that i dunno! :)

i want to do some change,
Thanks in advance
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

shadow82x

What are you trying to change exactly?

It's in a few files, but if you plan on changing the style of it the file you want to edit is ../Themes/{your_theme}/css/index.css and the area to edit would look something similar to
/* The navigation list (i.e. linktree) */
.navigate_section
{
   padding: 0.5em;
   margin: 0 0 0 0;
}
.navigate_section ul
{
   display: block;
   margin: 0;
   font-size: 0.9em;
   padding: 1em 0 0.5em 0;
   border-top: 1px solid #ccc;
   overflow: hidden;
   list-style: none;
   clear: both;
   width: 100%;
}
.navigate_section ul li
{
   float: left;
   padding: 0 0.5em 0 0;
   font-size: 0.95em;
}
.navigate_section ul li a
{
   white-space: pre;
}
Colin B
Former Spammer, Customize, & Support Team Member

Sir Osis of Liver

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Mr. Pedram

No, style isn't the matter i think,
i using RTL forum, but the topic name was reversed, for eg:

QuoteTopic Name  Simple Machines Community Forum » SMF Support » SMF 2.x Support »

i found it on style sheet (RTL and Style, both), and fixed it, the problem was direction, now it is:

.navigate_section ul li
{
float: right;
direction:ltr;
padding: 0 0 0 0.5em;
}


the funny matter is, bottom navigate fixed, but upper navigate still reversed! i don't know why, it must load from a certain css class, but..
i need to take a look @ navigate in template , maybe can fix it manually. anyway, can you tell me which few files?
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

shadow82x

It's called in quite a few files especially template files, theme_linktree() , but knowing that won't change the order of how it's displayed.

It's also called in  ../Sources/Display.php
// Build the link tree.
$context['linktree'][] = array(
'url' => $scripturl . '?topic=' . $topic . '.0',
'name' => $topicinfo['subject'],
'extra_before' => $settings['linktree_inline'] ? $txt['topic'] . ': ' : ''
);


I just tried doing your css edit locally and it appears to display fine. (In reverse order, aligned to the right, both upper and lower linktree's) The only issue I see is the arrows pointing the wrong way?
Colin B
Former Spammer, Customize, & Support Team Member

Mr. Pedram

Here are screenshot of both,

Upper:



Bottom:



That bottom is correct, but upper not.

Hope can fix this via css.
Anyway, Thanks for that @Shadow82x
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

shadow82x

Can you tell me if this occurs on the default SMF curve theme? This will determine if it's a theme issue were dealing with or someone deeper. Like I said I was unable to reproduce this locally on the SMF default theme so I'm thinking its a template or css issue.
Colin B
Former Spammer, Customize, & Support Team Member

Mr. Pedram

That's right!
that was theme issue!
tired to tell issues to theme author, prev issues still not solved!
hope to solve this issue myself and hope someone guide me how.
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

shadow82x

What theme are you using? Maybe I could try taking a look, although it usually is best for the theme author to look at these issues directly.
Colin B
Former Spammer, Customize, & Support Team Member

Mr. Pedram

Quote from: Shadow82x on March 14, 2013, 02:08:06 PM
What theme are you using? Maybe I could try taking a look, although it usually is best for the theme author to look at these issues directly.

http://custom.simplemachines.org/themes/index.php?lemma=2534

I have many issue with this theme, many of them not solved yet, some solved on my own, better i say it have many issue with RTL pages, include this new problem.

Now i just noticed, author has updated the theme, maybe still i have a chance ! hope he fixed the issue in new update.
Thank you, i going to take a look.


My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

Mr. Pedram

unfortunately this issue not solved in new update,
i let him know this issue.
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

Antechinus

Most themers don't pay any attention to RTL support. I did make a basic guide to doing RTL for custom themes, but I don't know if any of them paid attention. :D

http://www.simplemachines.org/community/index.php?topic=438174.0

Mr. Pedram

Thanks it's very useful, at least now i can do some change to theme on my own. :)
but couldn't find something about navigate_section, any idea for make this RTL correct?
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

The Domain Shop

Quote from: Mr. Pedram on March 14, 2013, 04:15:53 PM
Quote from: Shadow82x on March 14, 2013, 02:08:06 PM
What theme are you using? Maybe I could try taking a look, although it usually is best for the theme author to look at these issues directly.

http://custom.simplemachines.org/themes/index.php?lemma=2534

I have many issue with this theme, many of them not solved yet, some solved on my own, better i say it have many issue with RTL pages, include this new problem.

Now i just noticed, author has updated the theme, maybe still i have a chance ! hope he fixed the issue in new update.
Thank you, i going to take a look.

Instead of just posting here saying

QuoteI have many issue with this theme, many of them not solved yet, some solved on my own, better i say it have many issue with RTL pages, include this new problem.

I'm not a mind reader. You have never posted in the themes topic saying anything about any problems you have had with it so how do you expect me to fix them?

Mr. Pedram

I told you in past, surely you forget that (maybe because i change my username, i don't know) , it wasn't at support topic, i sent you 2-3 pm, and only one of them solved, anyway, it dosen't matter now. i solved some problems on my own.

The problem was, top bar RTL issue, last post RTL issue, first_th, and etc.. now navigate.
That you solved only the first_th issue via PM ;)

anyway Thank you for reply!
My Modifications:
» Loading For SMF
» Buddies Block
» Redirect Links
» Birthdate On Registration
» PM Warning
» Instagram
» Add Table,Td,Tr Button
» Search Topic & Board Button
Browse All...

Advertisement: