Advertisement:

Author Topic: Convert your tables to InnoDB  (Read 224390 times)

Offline Something like that

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,496
  • Gender: Male
  • ]
Re: Convert your tables to InnoDB
« Reply #220 on: January 05, 2010, 03:58:59 PM »
That seems very odd.

What can happen with all large boards, is that the log tables aren't cached in RAM, especially log_mark_read. The solution to this is increasing your innodb_buffer_pool_size. I don't know how big your forums are, nor what kind of hardware you're serving them with, but your innodb_buffer_pool_size should be at least 128M (guessing based on your traffic), but ideally large enough to contain the entirety of your InnoDB tables.

Can you post the output of status.php, including the variables or link to it?

Offline Flavious

  • Semi-Newbie
  • *
  • Posts: 62
Re: Convert your tables to InnoDB
« Reply #221 on: January 05, 2010, 05:16:47 PM »
Where do I find said Status.php? Not seeing it on the server...

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: Convert your tables to InnoDB
« Reply #222 on: January 05, 2010, 05:41:43 PM »
IchBin™        TinyPortal
Coding Guidelines       

Offline Flavious

  • Semi-Newbie
  • *
  • Posts: 62
Re: Convert your tables to InnoDB
« Reply #223 on: January 05, 2010, 06:11:16 PM »
Here's the output:

January 05, 2010, 03:09:37 PM
Operating System:    CentOS release 5.4 (Final)
Processor:    Intel® Xeon® CPU E5420 @ 2.50GHz (2500.131MHz)
Load averages:    6.21, 5.32, 5.28
Current processes:    11 (5 sleeping, 1 running, 5 zombie)
Processes by CPU:    php (6) 7.0%, (other) (5) 0.0%
Memory usage:    88.98% (3688796k / 4145640k)
Swap: 0.015% (620k / 4192944k)

Connections per second:      2.9521
Kilobytes received per second:    1.0906
Kilobytes sent per second:    0.8367
Queries per second:    99.5376
Percentage of slow queries:    0
Opened vs. Open tables:
(table_cache)    119.9295 (should be <= 80)
Table cache usage:
(table_cache)    1 (should be >= 0.5 and <= 0.9)
Key buffer read hit rate:
(key_buffer_size)    0.0035 (should be <= 0.01)
Key buffer write hit rate:
(key_buffer_size)    0.4614 (should be <= 0.5)
Thread cache hit rate:
(thread_cache_size)    160990.7313 (should be >= 30 )
Thread cache usage:
(thread_cache_size)    0.5 (should be >= 0.7 and <= 0.9)
Temporary table disk usage:
(tmp_table_size)    0.4547 (should be <= 0.5)
Sort merge pass rate:
(sort_buffer)    0 (should be <= 0.001)
Query cache enabled:
(query_cache_type)    1 (should be >= 1 and <= 1)
Query cache miss rate:
(query_cache_limit)    0.1745 (should be <= 0.5)
Query cache prune rate:
(query_cache_size)    0.2034 (should be <= 0.05)

Aborted_clients:     20000
Aborted_connects:    38823
Binlog_cache_disk_use:    0
Binlog_cache_use:    0
Bytes_received:    4080355597
Bytes_sent:    3130605643
Com_admin_commands:    2187812
Com_alter_db:    0
Com_alter_table:    1513
Com_analyze:    1
Com_backup_table:    0
Com_begin:    530693
Com_call_procedure:    0
Com_change_db:    10641731
Com_change_master:    0
Com_check:    301
Com_checksum:    0
Com_commit:    322457
Com_create_db:    57
Com_create_function:    0
Com_create_index:    2
Com_create_table:    309701
Com_create_user:    0
Com_dealloc_sql:    324539
Com_delete:    6842578
Com_delete_multi:    43
Com_do:    0
Com_drop_db:    41
Com_drop_function:    0
Com_drop_index:    0
Com_drop_table:    23609
Com_drop_user:    0
Com_execute_sql:    324539
Com_flush:    13719
Com_grant:    19570
Com_ha_close:    0
Com_ha_open:    0
Com_ha_read:    0
Com_help:    0
Com_insert:    6939635
Com_insert_select:    66246
Com_kill:    157
Com_load:    0
Com_load_master_data:    0
Com_load_master_table:    0
Com_lock_tables:    1093180
Com_optimize:    14131
Com_preload_keys:    0
Com_prepare_sql:    324539
Com_purge:    0
Com_purge_before_date:    0
Com_rename_table:    0
Com_repair:    2282
Com_replace:    819765
Com_replace_select:    41
Com_reset:    0
Com_restore_table:    0
Com_revoke:    3
Com_revoke_all:    0
Com_rollback:    571
Com_savepoint:    0
Com_select:    52149270
Com_set_option:    5036216
Com_show_binlog_events:    0
Com_show_binlogs:    119
Com_show_charsets:    1013
Com_show_collations:    1118
Com_show_column_types:    0
Com_show_create_db:    3
Com_show_create_table:    563311
Com_show_databases:    12882
Com_show_errors:    0
Com_show_fields:    853523
Com_show_grants:    40198
Com_show_innodb_status:    0
Com_show_keys:    1912
Com_show_logs:    0
Com_show_master_status:    0
Com_show_ndb_status:    0
Com_show_new_master:    0
Com_show_open_tables:    0
Com_show_privileges:    0
Com_show_processlist:    1113
Com_show_slave_hosts:    0
Com_show_slave_status:    0
Com_show_status:    196
Com_show_storage_engines:    15
Com_show_tables:    235417
Com_show_triggers:    617656
Com_show_variables:    28595
Com_show_warnings:    29
Com_slave_start:    0
Com_slave_stop:    0
Com_stmt_close:    324539
Com_stmt_execute:    324539
Com_stmt_fetch:    0
Com_stmt_prepare:    324539
Com_stmt_reset:    0
Com_stmt_send_long_data:    0
Com_truncate:    5330
Com_unlock_tables:    1093941
Com_update:    16524177
Com_update_multi:    35488
Com_xa_commit:    0
Com_xa_end:    0
Com_xa_prepare:    0
Com_xa_recover:    0
Com_xa_rollback:    0
Com_xa_start:    0
Compression:    OFF
Connections:    10786379
Created_tmp_disk_tables:    2593859
Created_tmp_files:    11
Created_tmp_tables:    5704089
Delayed_errors:    0
Delayed_insert_threads:    0
Delayed_writes:    0
Flush_commands:    1
Handler_commit:    538278
Handler_delete:    7522227
Handler_discover:    0
Handler_prepare:    0
Handler_read_first:    8845989
Handler_read_key:    2762765006
Handler_read_next:    3171941631
Handler_read_prev:    19614552
Handler_read_rnd:    86125298
Handler_read_rnd_next:    3395420968
Handler_rollback:    132449
Handler_savepoint:    0
Handler_savepoint_rollback:    0
Handler_update:    965488131
Handler_write:    684472009
Innodb_buffer_pool_pages_data:    492
Innodb_buffer_pool_pages_dirty:    0
Innodb_buffer_pool_pages_flushed:    213105
Innodb_buffer_pool_pages_free:    0
Innodb_buffer_pool_pages_misc:    20
Innodb_buffer_pool_pages_total:    512
Innodb_buffer_pool_read_ahead_rnd:    8131
Innodb_buffer_pool_read_ahead_seq:    479
Innodb_buffer_pool_read_requests:    71558805
Innodb_buffer_pool_reads:    147163
Innodb_buffer_pool_wait_free:    0
Innodb_buffer_pool_write_requests:    2107710
Innodb_data_fsyncs:    286850
Innodb_data_pending_fsyncs:    0
Innodb_data_pending_reads:    0
Innodb_data_pending_writes:    0
Innodb_data_read:    3681439744
Innodb_data_reads:    168287
Innodb_data_writes:    428975
Innodb_data_written:    2901644800
Innodb_dblwr_pages_written:    213105
Innodb_dblwr_writes:    37915
Innodb_log_waits:    0
Innodb_log_write_requests:    228243
Innodb_log_writes:    183938
Innodb_os_log_fsyncs:    212736
Innodb_os_log_pending_fsyncs:    0
Innodb_os_log_pending_writes:    0
Innodb_os_log_written:    199624704
Innodb_page_size:    16384
Innodb_pages_created:    6876
Innodb_pages_read:    224564
Innodb_pages_written:    213105
Innodb_row_lock_current_waits:    0
Innodb_row_lock_time:    32834
Innodb_row_lock_time_avg:    35
Innodb_row_lock_time_max:    3520
Innodb_row_lock_waits:    931
Innodb_rows_deleted:    1483
Innodb_rows_inserted:    108093
Innodb_rows_read:    29642994
Innodb_rows_updated:    161402
Key_blocks_not_flushed:    0
Key_blocks_unused:    0
Key_blocks_used:    14497
Key_read_requests:    4340076250
Key_reads:    15117512
Key_write_requests:    68887765
Key_writes:    31787254
Last_query_cost:    0.000000
Max_used_connections:    67
Ndb_cluster_node_id:    0
Ndb_config_from_host:    
Ndb_config_from_port:    0
Ndb_number_of_data_nodes:    0
Not_flushed_delayed_rows:    0
Open_files:    15185
Open_streams:    0
Open_tables:    10240
Opened_tables:    1228078
Prepared_stmt_count:    0
Qcache_free_blocks:    5988
Qcache_free_memory:    20268704
Qcache_hits:    246696684
Qcache_inserts:    43697548
Qcache_lowmem_prunes:    10607347
Qcache_not_cached:    8330228
Qcache_queries_in_cache:    16982
Qcache_total_blocks:    42045
Queries:    363693592
Questions:    363693592
Rpl_status:    NULL
Select_full_join:    1689630
Select_full_range_join:    8862
Select_range:    5368394
Select_range_check:    1049
Select_scan:    12862189
Slave_open_temp_tables:    0
Slave_retried_transactions:    0
Slave_running:    OFF
Slow_launch_threads:    0
Slow_queries:    226
Sort_merge_passes:    0
Sort_range:    1619125
Sort_rows:    632158553
Sort_scan:    3162107
Table_locks_immediate:    122577015
Table_locks_waited:    236329
Tc_log_max_pages_used:    0
Tc_log_page_size:    0
Tc_log_page_waits:    0
Threads_cached:    64
Threads_connected:    3
Threads_created:    67
Threads_running:    1
Uptime:    3653831

MySQL variables
auto_increment_increment:    1
auto_increment_offset:    1
automatic_sp_privileges:    ON
back_log:    50
basedir:    /
binlog_cache_size:    32768
bulk_insert_buffer_size:    8388608
character_set_client:    latin1
character_set_connection:    latin1
character_set_database:    latin1
character_set_filesystem:    binary
character_set_results:    latin1
character_set_server:    latin1
character_set_system:    utf8
character_sets_dir:    /usr/share/mysql/charsets/
collation_connection:    latin1_swedish_ci
collation_database:    latin1_swedish_ci
collation_server:    latin1_swedish_ci
completion_type:    0
concurrent_insert:    1
connect_timeout:    10
datadir:    /var/lib/mysql/
date_format:    %Y-%m-%d
datetime_format:    %Y-%m-%d %H:%i:%s
default_week_format:    0
delay_key_write:    ON
delayed_insert_limit:    100
delayed_insert_timeout:    300
delayed_queue_size:    1000
div_precision_increment:    4
keep_files_on_create:    OFF
engine_condition_pushdown:    OFF
expire_logs_days:    0
flush:    OFF
flush_time:    0
ft_boolean_syntax:    + -><()~*:""&|
ft_max_word_len:    84
ft_min_word_len:    4
ft_query_expansion_limit:    20
ft_stopword_file:    (built-in)
group_concat_max_len:    1024
have_archive:    YES
have_bdb:    NO
have_blackhole_engine:    YES
have_compress:    YES
have_community_features:    NO
have_profiling:    NO
have_crypt:    YES
have_csv:    YES
have_dynamic_loading:    YES
have_example_engine:    YES
have_federated_engine:    YES
have_geometry:    YES
have_innodb:    YES
have_isam:    NO
have_merge_engine:    YES
have_ndbcluster:    DISABLED
have_openssl:    NO
have_ssl:    NO
have_query_cache:    YES
have_raid:    NO
have_rtree_keys:    YES
have_symlink:    YES
hostname:    olympic.aqhostdns.com
init_connect:    
init_file:    
init_slave:    
innodb_additional_mem_pool_size:    1048576
innodb_autoextend_increment:    8
innodb_buffer_pool_awe_mem_mb:    0
innodb_buffer_pool_size:    8388608
innodb_checksums:    ON
innodb_commit_concurrency:    0
innodb_concurrency_tickets:    500
innodb_data_file_path:    ibdata1:10M:autoextend
innodb_data_home_dir:    
innodb_adaptive_hash_index:    ON
innodb_doublewrite:    ON
innodb_fast_shutdown:    1
innodb_file_io_threads:    4
innodb_file_per_table:    OFF
innodb_flush_log_at_trx_commit:    1
innodb_flush_method:    
innodb_force_recovery:    0
innodb_lock_wait_timeout:    50
innodb_locks_unsafe_for_binlog:    OFF
innodb_log_arch_dir:    
innodb_log_archive:    OFF
innodb_log_buffer_size:    1048576
innodb_log_file_size:    5242880
innodb_log_files_in_group:    2
innodb_log_group_home_dir:    ./
innodb_max_dirty_pages_pct:    90
innodb_max_purge_lag:    0
innodb_mirrored_log_groups:    1
innodb_open_files:    300
innodb_rollback_on_timeout:    OFF
innodb_support_xa:    ON
innodb_sync_spin_loops:    20
innodb_table_locks:    ON
innodb_thread_concurrency:    8
innodb_thread_sleep_delay:    10000
innodb_use_legacy_cardinality_algorithm:    ON
interactive_timeout:    300
join_buffer_size:    16777216
key_buffer_size:    16777216
key_cache_age_threshold:    300
key_cache_block_size:    1024
key_cache_division_limit:    100
language:    /usr/share/mysql/english/
large_files_support:    ON
large_page_size:    0
large_pages:    OFF
lc_time_names:    en_US
license:    GPL
local_infile:    ON
locked_in_memory:    OFF
log:    OFF
log_bin:    OFF
log_bin_trust_function_creators:    OFF
log_error:    
log_queries_not_using_indexes:    OFF
log_slave_updates:    OFF
log_slow_queries:    OFF
log_warnings:    1
long_query_time:    10
low_priority_updates:    OFF
lower_case_file_system:    OFF
lower_case_table_names:    0
max_allowed_packet:    16777216
max_binlog_cache_size:    4294963200
max_binlog_size:    1073741824
max_connect_errors:    100
max_connections:    750
max_delayed_threads:    20
max_error_count:    64
max_heap_table_size:    16777216
max_insert_delayed_threads:    20
max_join_size:    18446744073709551615
max_length_for_sort_data:    1024
max_prepared_stmt_count:    16382
max_relay_log_size:    0
max_seeks_for_key:    4294967295
max_sort_length:    1024
max_sp_recursion_depth:    0
max_tmp_tables:    32
max_user_connections:    50
max_write_lock_count:    4294967295
multi_range_count:    256
myisam_data_pointer_size:    6
myisam_max_sort_file_size:    2146435072
myisam_recover_options:    OFF
myisam_repair_threads:    1
myisam_sort_buffer_size:    67108864
myisam_stats_method:    nulls_unequal
ndb_autoincrement_prefetch_sz:    1
ndb_force_send:    ON
ndb_use_exact_count:    ON
ndb_use_transactions:    ON
ndb_cache_check_time:    0
ndb_connectstring:    
net_buffer_length:    16384
net_read_timeout:    30
net_retry_count:    10
net_write_timeout:    60
new:    OFF
old_passwords:    OFF
open_files_limit:    21240
optimizer_prune_level:    1
optimizer_search_depth:    62
pid_file:    /var/lib/mysql/olympic.aqhostdns.com.pid
plugin_dir:    
port:    3306
preload_buffer_size:    32768
protocol_version:    10
query_alloc_block_size:    8192
query_cache_limit:    1048576
query_cache_min_res_unit:    4096
query_cache_size:    67108864
query_cache_type:    ON
query_cache_wlock_invalidate:    OFF
query_prealloc_size:    8192
range_alloc_block_size:    4096
read_buffer_size:    16777216
read_only:    OFF
read_rnd_buffer_size:    262144
relay_log:    
relay_log_index:    
relay_log_info_file:    relay-log.info
relay_log_purge:    ON
relay_log_space_limit:    0
rpl_recovery_rank:    0
secure_auth:    OFF
secure_file_priv:    
server_id:    0
skip_external_locking:    ON
skip_networking:    OFF
skip_show_database:    OFF
slave_compressed_protocol:    OFF
slave_load_tmpdir:    /tmp/
slave_net_timeout:    3600
slave_skip_errors:    OFF
slave_transaction_retries:    10
slow_launch_time:    2
socket:    /var/lib/mysql/mysql.sock
sort_buffer_size:    33554432
sql_big_selects:    ON
sql_mode:    
sql_notes:    ON
sql_warnings:    OFF
ssl_ca:    
ssl_capath:    
ssl_cert:    
ssl_cipher:    
ssl_key:    
storage_engine:    MyISAM
sync_binlog:    0
sync_frm:    ON
system_time_zone:    PST
table_cache:    10240
table_lock_wait_timeout:    50
table_type:    MyISAM
thread_cache_size:    128
thread_stack:    196608
time_format:    %H:%i:%s
time_zone:    SYSTEM
timed_mutexes:    OFF
tmp_table_size:    33554432
tmpdir:    /tmp/
transaction_alloc_block_size:    8192
transaction_prealloc_size:    4096
tx_isolation:    REPEATABLE-READ
updatable_views_with_limit:    YES
version:    5.0.85-community
version_comment:    MySQL Community Edition (GPL)
version_compile_machine:    i686
version_compile_os:    pc-linux-gnu
wait_timeout:    300

Offline Something like that

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,496
  • Gender: Male
  • ]
Re: Convert your tables to InnoDB
« Reply #224 on: January 05, 2010, 06:20:08 PM »
As I suspected, your innodb_buffer_pool_size is extremely small. It's set to 8M right now. Set it to 384M.

Also, your key_buffer_size for MyISAM is also too small (16M). Set key_buffer_size to 128M.

You can also set innodb_flush_log_at_trx_commit to 2 for a big improvement in InnoDB writes.

That should fix your slow downs and make your forum about twice as fast. :)

Offline Flavious

  • Semi-Newbie
  • *
  • Posts: 62
Re: Convert your tables to InnoDB
« Reply #225 on: January 05, 2010, 06:37:11 PM »
God bless Mark. We will do that right now and see how she goes!

Offline Something like that

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,496
  • Gender: Male
  • ]
Re: Convert your tables to InnoDB
« Reply #226 on: January 05, 2010, 07:15:47 PM »
Do you have over 500k posts? If so, you should apply for the Big Boards group. It'll give you access to another forum with advice for people with big boards.

If you don't have that many posts yet, your traffic certainly warrants it, just tell them I sent you and point here. I don't make the decisions, but I think you should have access.

Offline Flavious

  • Semi-Newbie
  • *
  • Posts: 62
Re: Convert your tables to InnoDB
« Reply #227 on: January 12, 2010, 05:38:56 PM »
I have signed up for it. We continue to be plagued with all sorts of issues... internal server errors, lock ups, and now.. our most viewed thread has disappeared. My hosting provider is providing vague answers like "your scripts are using too much cpu". Is there anyone with huge Simple Machines experience available for paid consultation as well? Just in case - we may need it.

Offline forumite

  • Full Member
  • ***
  • Posts: 408
    • The RV Forum
Re: Convert your tables to InnoDB
« Reply #228 on: December 05, 2010, 08:25:51 AM »
Apologies for posting in an old topic, but most of the discussion appears relevant.

Having procrastinated for a long time, I was getting ready to convert defined tables from MyISAM to InnoDB, and stumbled on this warning in the MySQL docs:

http://dev.mysql.com/doc/refman/5.5/en/innodb-restrictions.html

Did something change, or is it advisable to continue with the conversion, ignoring the warning?

FWIW the conversion would be limited to the tables defined in earlier messages, and my.cnf will have the changes suggested.

TIA.

Offline 青山 素子

  • Server Team
  • SMF Super Hero
  • *
  • Posts: 17,074
  • 戦場ヶ原、蕩れ!
    • srvrguy on GitHub
    • @motokochan on Twitter
    • Nekomusume Moe
Re: Convert your tables to InnoDB
« Reply #229 on: December 05, 2010, 12:16:40 PM »
None of the size restrictions should apply to a default SMF table. If you do find an SMF table with over 1000 columns, please do share!

The red warnings are specifically for the "mysql" database that contains user, password, and grant information and if you are using InnDB over NFS due to the way that system handles locking.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


Offline forumite

  • Full Member
  • ***
  • Posts: 408
    • The RV Forum
Re: Convert your tables to InnoDB
« Reply #230 on: December 05, 2010, 12:23:47 PM »
Quote
The red warnings are specifically for the "mysql" database that contains user, password, and grant information .....

Ah so, thanks Motoko. I misunderstood the warnings, probably because I missed the significance of the term system tables.

Offline forumite

  • Full Member
  • ***
  • Posts: 408
    • The RV Forum
Re: Convert your tables to InnoDB
« Reply #231 on: December 09, 2010, 05:44:23 AM »
My forum has been suffering from sporadic chronic delays for some time. A few days ago I finally got around to converting the defined tables to InnoDB and made the requisite tweaks in my.cnf. Because of the prior sporadic nature of the behavior, I've been watching and testing to be sure the problem is fixed, and all I can say is - wow! what a difference.

One of Unkown's recommendations I haven't yet implemented is to change the log_floodcontrol table to be MEMORY/HEAP (ENGINE=MEMORY). But, my question is how important is this, and what will be the downside of not making this change? I just looked at the existing MyISAM log_floodcontrol table, and it's quite small (2.3KB).

TIA.

Offline Joshua Dickerson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,778
  • Gender: Male
    • joshuaadickerson on GitHub
    • joshuaadickerson on LinkedIn
Re: Convert your tables to InnoDB
« Reply #232 on: December 09, 2010, 04:51:57 PM »
I'd do it. It is worth it. Nothing is lost from doing it. Be sure to do the other changes in the sticky in this board as well.
Need help? See the wiki. Want to help SMF? See the wiki!

Did you know you can help develop SMF? See us on Github.

How have you bettered the world today?

Offline Thrilling

  • Semi-Newbie
  • *
  • Posts: 51
Re: Convert your tables to InnoDB
« Reply #233 on: January 10, 2011, 09:27:08 AM »
What are the phpmyadmin queries to be  run on SMF 2.0RC4?

These don't work:

Code: [Select]
ALTER TABLE smf_attachments
TYPE=InnoDB;
ALTER TABLE smf_collapsed_categories
TYPE=InnoDB;
ALTER TABLE smf_log_actions
TYPE=InnoDB;
ALTER TABLE smf_log_boards
TYPE=InnoDB;
ALTER TABLE smf_log_errors
TYPE=InnoDB;
ALTER TABLE smf_log_karma
TYPE=InnoDB;
ALTER TABLE smf_log_mark_read
TYPE=InnoDB;
ALTER TABLE smf_log_online
TYPE=InnoDB;
ALTER TABLE smf_log_search
TYPE=InnoDB;
ALTER TABLE smf_log_topics
TYPE=InnoDB;
ALTER TABLE smf_members
TYPE=InnoDB;
ALTER TABLE smf_pm_recipients
TYPE=InnoDB;
ALTER TABLE smf_sessions
TYPE=InnoDB;
ALTER TABLE smf_settings
TYPE=InnoDB;
ALTER TABLE smf_topics
TYPE=InnoDB;

Quote
MySQL said: Documentation
#1146 - Table 'geeksoup_forum.smf_log_search' doesn't exist
Geeksoup.net - Free Technical Support

Redefining tech support..

Offline 青山 素子

  • Server Team
  • SMF Super Hero
  • *
  • Posts: 17,074
  • 戦場ヶ原、蕩れ!
    • srvrguy on GitHub
    • @motokochan on Twitter
    • Nekomusume Moe
Re: Convert your tables to InnoDB
« Reply #234 on: January 10, 2011, 11:58:11 AM »
You need to adjust the queries for your table names. You might be using a different prefix, for example.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


Offline Masterd

  • SMF Hero
  • ******
  • Posts: 3,924
  • Gender: Male
Re: Convert your tables to InnoDB
« Reply #235 on: January 11, 2011, 06:55:25 AM »
I tried this on my forum and nothing happened.

Offline Paracelsus

  • Sr. Member
  • ****
  • Posts: 876
  • Gender: Male
Re: Convert your tables to InnoDB
« Reply #236 on: January 11, 2011, 07:07:11 AM »
I tried this on my forum and nothing happened.

What did you expect to happen?

Offline 008Rohit

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
    • TechTage
Re: Convert your tables to InnoDB
« Reply #237 on: April 24, 2011, 07:57:57 AM »
My Host iPage doesnt even support InnoDB tables. I tried to run this query "ALTER TABLE smf_attachments
TYPE=InnoDB;" and it said successful but smf_attachments was still MyIsam.
TechTage Forum - Vintage Technology - on MDDHosting - CloudLinux & LiteSpeed Powered - MDDHosting Review

Offline Masterd

  • SMF Hero
  • ******
  • Posts: 3,924
  • Gender: Male
Re: Convert your tables to InnoDB
« Reply #238 on: April 24, 2011, 08:04:24 AM »
If your host doesn't support InnoDB then you can do nothing.

Offline 008Rohit

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
    • TechTage
Re: Convert your tables to InnoDB
« Reply #239 on: April 24, 2011, 08:59:52 AM »
If your host doesn't support InnoDB then you can do nothing.
I am disgusted with iPage and planning to Move to Aspiration Hosting. :)
TechTage Forum - Vintage Technology - on MDDHosting - CloudLinux & LiteSpeed Powered - MDDHosting Review