Advertisement:

Author Topic: IIS 5 - how to set *blah blah blah* writable?  (Read 12355 times)

Offline a2h_

  • Jr. Member
  • **
  • Posts: 209
  • Gender: Male
    • Geniuose At Work
IIS 5 - how to set *blah blah blah* writable?
« on: January 18, 2007, 04:47:48 AM »
SMF Version: SMF 1.1.1
Quote
Simple Machines
SMF Installer
You're on a windows server, and some crucial files are not writable. Please ask your host to give write permissions to the user PHP is running under for the files in your SMF installation. The following files or directories need to be writable:

    * attachments
    * avatars
    * Packages
    * Packages/installed.list
    * Smileys
    * Themes
    * agreement.txt
    * Settings.php
    * Settings_bak.php

Click here to try this step again.

OK, I've installed IIS for personal uses, then installed PHP and MySQL successfully (pma runs :)) but I have absolutely -no- idea how to make those files I listed above writable. I've gone through IIS settings and used properties and ticked writable, but nothing seems to work. Help please?

IIS 5.1 on Windows XP MCE
offtopic - MCE uses XP Pro codebase, and MS forgot to take out IIS :P
With an underscore. Because the one without an underscore's taken.

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #1 on: January 18, 2007, 12:00:32 PM »
Right click the SMF folder and choose properties and the security tab.

You will need to add the IIS users (one is for FTP and one is for HTTP but as I can't remove which add both should do the trick!) and give them read / write / execute / modify permissions. The IIS users are something like IUSR_computername and IWAM_computername
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline a2h_

  • Jr. Member
  • **
  • Posts: 209
  • Gender: Male
    • Geniuose At Work
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #2 on: January 18, 2007, 05:10:47 PM »
How do I add users?

Anyway, if you have WLM I am willing to start a remote desktop session...

(oh and if you're not aware i'm setting up smf for personal uses...)
« Last Edit: January 18, 2007, 05:12:53 PM by rctxtreme »
With an underscore. Because the one without an underscore's taken.

Offline mrmichael

  • Newbie
  • *
  • Posts: 1
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #3 on: January 19, 2007, 06:44:45 AM »
I am experiencing the same problem,but the only difference is that I use the Apache server.
Am I going to do the same ???
Please help.....

Offline Daniel15

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,222
  • Gender: Male
  • http://dan.cx/
    • daaniel on Facebook
    • Daniel15 on GitHub
    • daniel15 on LinkedIn
    • @Daniel15 on Twitter
    • Daniel15
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #4 on: January 19, 2007, 07:34:59 AM »
Quote
How do I add users?
If you right-click the directory, click 'Properties', and go to the Security tab, there's an "Add" button. You need to type the username into the box.
If you don't see the Security tab, open Windows Explorer, and click Tools --> Folder Options. On the View tab, untick the "Use simple file sharing" box.
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,949
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #5 on: January 19, 2007, 01:50:03 PM »
I am experiencing the same problem,but the only difference is that I use the Apache server.
Am I going to do the same ???
Please help.....

If you're on Windows, you will need to give the Apache user account read, write and modify privileges on the SMF directories.

Right-click on a folder
Click "Properties"
If you don't see a "Permissions" tab, click "Cancel" and follow the above instructions for disabling simple file sharing, then return to this step.
Click on the "Permissions" tab
You should see a bunch of users and some permissions
If you don't see the Apache user listed there, follow the instructions above to add it.
Click on the apache user
Check the boxes (in the "Allow" column) next to Read, Write and Modify.
Click "Apply"

You should be given an option to apply that to any sub-folders and files - choose that option if you are.
Michael Eshom
Cincy Space - now open!

Offline a2h_

  • Jr. Member
  • **
  • Posts: 209
  • Gender: Male
    • Geniuose At Work
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #6 on: January 19, 2007, 05:56:07 PM »
Woo! Thanks so much!
With an underscore. Because the one without an underscore's taken.

Offline dkpeppard

  • Semi-Newbie
  • *
  • Posts: 31
  • Gender: Male
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #7 on: May 16, 2007, 03:46:29 PM »
I had this same issue.  I had to give the "Internet Guest Account" full access to the SMF directory. Once I did, the install/config page came up, created my database on the fly and finished setup.

So, I am now running Simple Machines on a Windows 2003 server, PHP 5.2.2, and MySQL 5.0.

Good luck. :)
« Last Edit: May 17, 2007, 01:20:47 PM by dkpeppard »

Offline InvisibleMan78

  • Semi-Newbie
  • *
  • Posts: 35
  • Gender: Male
Re: IIS 5 - how to set *blah blah blah* writable?
« Reply #8 on: September 04, 2007, 07:59:16 AM »
Thank you dkpeppard! That was the point!

I have set every single directory and file like listed in the initial post (for "Internet Guest Account"). But it doesn't work.

Since I set the entire SMF-Directory (and all the subdirectories) for the "Internet Guest Account" = IUSER_COMPUTERNAME to "Modify", the installation worked.

Maybe, someone should check, which file and directory REALLY needs write/modify-permission... ;D


Config: Windows 2003 Standard Server, PHP 5.2.4, MySQL 5.0.45