Advertisement:

Author Topic: Issues w/ typing popular *NIX based commands in posts?  (Read 3952 times)

Offline stealthx32

  • Semi-Newbie
  • *
  • Posts: 13
Issues w/ typing popular *NIX based commands in posts?
« on: September 05, 2007, 03:13:27 PM »
I'm not entirely sure what the deal is here.  I administrate 3 forums running SMF, and this is the only one it happens on (although this one is running PHP5, while the others are running PHP4).  When I try and type a post with commands WITH PARAMETERS such as:

wget
lynx

I get an error that says I can't access the index.php of SMF.

So, I can do things like:

wget
lynx

But I can't do things like:

wget file.name
lynx http://www.blah.com/file.txt [nofollow]

You can test it out here: link removed

Use preview please, so you don't spam the boards too badly. ;)  It doesn't seem to matter whether or not it's in a code block or not.

Status and phpinfo are available as well:

link removed
link removed
« Last Edit: September 06, 2007, 12:59:24 AM by stealthx32 »

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Issues w/ typing popular *NIX based commands in posts?
« Reply #1 on: September 05, 2007, 05:34:15 PM »
Try the mod_security fix.

Having problems with mod_security?
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline stealthx32

  • Semi-Newbie
  • *
  • Posts: 13
Re: Issues w/ typing popular *NIX based commands in posts?
« Reply #2 on: September 06, 2007, 12:59:53 AM »
Thanks!  Good catch.  I will mark it as solved.