Advertisement:

Author Topic: Unable to post after package install/uninstall  (Read 793 times)

Offline diablo3x.dk

  • Jr. Member
  • **
  • Posts: 168
Unable to post after package install/uninstall
« on: May 12, 2013, 01:50:21 PM »
Hello

I just encountered af problem on my site www.diablo3x.dk. I wanted to install this package: http://custom.simplemachines.org/mods/index.php?mod=3474

It installed without errors but the new functions didn't work, though. So, I decided to uninstall the package. Here the first problem occured; couldn't uninstall the package. So I decided to delete the package and afterwards upload the backed up files (display.php display.template.php karma.php). Everything seemed back to normal.

Shortly after I wanted to create a new topic, which I couldn't. I get this error when trying to submit a new post or topic:

Code: [Select]
Field 'karma_bad' doesn't have a default value
File: x:\xxx\Diablo3x\Sources\Subs-Post.php
Line: 1824

I have attached the subs-post.php file here. I really have no idea what to do. Please let me know if you need further information to help me out here. I really appreciate any help.

Thanks

/edit

I should mention that, afterwards, I found the automatically backed up files in the package directory and then I uploaded these files. No change. Still get the above error.

Offline Chalky

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,378
  • Gender: Female
  • If in doubt, give me beer...
    • ChalkCat
Re: Unable to post after package install/uninstall
« Reply #1 on: May 12, 2013, 01:57:37 PM »
It looks like the mod made database changes which are still there because you only restored backups of your files.  If you've had little or no activity on your forum, you might consider restoring your database backup, otherwise you should ask on the mod's support thread how to remove the mod from your database.

You might have been better trying to fix the mod problems or the uninstall problem before forcing it, but that's for next time  ;)

Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,588
  • Gender: Male
    • i30 Owners Club
Re: Unable to post after package install/uninstall
« Reply #2 on: May 12, 2013, 02:04:39 PM »
That mod doesn't seem to make any edits in Subs-post.php, tho it does add two columns to the DB.

If this were me, I'd delete those two DB columns 'karma_bad' and 'karma_good' from {db_prefix)messages.

Offline diablo3x.dk

  • Jr. Member
  • **
  • Posts: 168
Re: Unable to post after package install/uninstall
« Reply #3 on: May 12, 2013, 02:14:54 PM »
That mod doesn't seem to make any edits in Subs-post.php, tho it does add two columns to the DB.

If this were me, I'd delete those two DB columns 'karma_bad' and 'karma_good' from {db_prefix)messages.

Thanks, Shambles.

That did the job :)

Offline Chalky

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,378
  • Gender: Female
  • If in doubt, give me beer...
    • ChalkCat
Re: Unable to post after package install/uninstall
« Reply #4 on: May 12, 2013, 02:16:03 PM »
Nice one  :)

Marking solved...

Offline diablo3x.dk

  • Jr. Member
  • **
  • Posts: 168
Re: Unable to post after package install/uninstall
« Reply #5 on: May 12, 2013, 02:16:49 PM »
Yes. Thanks, ChalkCat.