• Welcome to Simple Machines Community Forum. Please login or sign up.
January 28, 2022, 03:49:27 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Member Awards ?

Started by XHIBIT911, June 19, 2013, 08:18:08 PM

Previous topic - Next topic

XHIBIT911

Are there any member award mods that actually work or have been updated within the last 3 years ?
The only ones Ive been able to find for 2.0.4 (even if I try to emulate backwards) dont work. The sources/admin.php fails and I can't even set it up after it loads, but it shows in ultimate profile mods.

Member Awards v2.2.3
I also have no interest in the auto awards medal system so whats out there that will allow me to award my members based on achievments ?

TheListener

How do you mean the sources/ admin fails?

XHIBIT911

When I upload it in packages manager there are several fails.
The mod doesnt even show in the admin panel, but it shows a link for member awards in ultimate profile.
That mod just isnt working for 2.0.4

TheListener

Did you still install the mod even with the test faileds?


XHIBIT911

Yes, thats how I found out that it still shows in Ultimate Profile, then I uninstalled and used the delete all files associated option and deleted the mod.

TheListener

When a file is shown as test failed it means a manual edit is required thus using the mods parser.

XHIBIT911

Ok thats over my head...how do I find and use the mods parser, and what exactly must I do to get this sorted out ?

TheListener

http://custom.simplemachines.org/mods/index.php?action=parse

The above link can be found when you click the parse button for the version of smf which you use.

(The attachment).

Go to whichever files showed as test failed.

XHIBIT911

OK I'm game to get this sorted so be patient, but...LOL where the heck is the parse button ?
I'm using 2.0.4 and dont ever recall seeing it

TheListener

Look at the mods download page.

All mods have a parse button.

XHIBIT911

Oh and by the way heres the screenshot I forgot to attach


XHIBIT911

OK now I just feel super retarded.
I've had several forums over the last 8 years and have seen the word parse thrown around and up until this very lightbulb moment didnt have a clue what the hell it meant or did.

DERP !

so on that parse page those are the manual edits I need to make after I reinstall ?

TheListener

Quote from: XHIBIT911 on June 19, 2013, 09:01:27 PM
Oh and by the way heres the screenshot I forgot to attach

You would have to look at the sections of code respective of these files which show as test failed.


TheListener

Quote from: XHIBIT911 on June 19, 2013, 09:04:21 PM
OK now I just feel super retarded.
I've had several forums over the last 8 years and have seen the word parse thrown around and up until this very lightbulb moment didnt have a clue what the hell it meant or did.

DERP !

so on that parse page those are the manual edits I need to make after I reinstall ?

Exactly.

:)

XHIBIT911

OK lemmie pin my ears back and roll my sleeves up and see how this goes.

TheListener

Don't forget to make a Backup first

* Old Fossil shouts deliberately wanting to be heard.

XHIBIT911

June 19, 2013, 11:15:58 PM #16 Last Edit: June 20, 2013, 03:42:02 AM by XHIBIT911
No dice...I wasted 3 hours on this and it didnt work....I'm not gonna bother with this one any further. It hasnt been updated in 2 years and its not worth the hassle since obviously the author has abandoned it. Thanks anyway for your help though

Kindred

First of all - the memer awards mod works just fine.

second - http://wiki.simplemachines.org/smf/Error_in_mod_installation

third...   if you have issues with or questions on a mod, then ask int he support topic dedicated to supporting that mod...  I bet that you find 90% of your questions have actually already been answered there as well
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

XHIBIT911

June 20, 2013, 02:49:30 AM #18 Last Edit: June 20, 2013, 03:13:57 AM by XHIBIT911
First of all I'll have you know Kindred that that mod is obviously buggy and thats why its 153 pages of people with issues dating back to its release.

Secondly I did read the thread...in fact I read 60+ pages of it. And I probably can count how many times you've said that the mod was "just fine".

And since you jumped the gun you'll see I already had made a post there, but being nasty is just your nature and I've seen it before from you in these forums.

As far as your 90% theory goes again you're wrong because as stated not only had I read for 2 1/2 hours post after post...I applied each instruction VERBATIM and the mod is still not correctly loading.

I've even deleted a previous Auto Award mod from the database tables itself and the Member Awards 2.3.3 version still shows TESTS FAILED when trying to reinstall. So assuming that I'm not capable of following instruction or digging for answers is a pretty arrogant assertion.
The bottom line is the mod may work for some on first install...for others it may finally work after parsing it...and then for many more (as proven in the thread itself) it still doesn't work at all...even after trying all the tricks including emulating and uninstalling and reinstalling numerous times that was suggested by Spud.

So there's no need for your condescendant demeanor constantly in a support forum. Especially when its clearly obvious that there are and have been ongoing issues with it.  People arent always as stupid as you try to make them out to be.


Storman™

I don't see how Kindred has been "nasty" to you ? You may well be frustrated that the mod doesn't work for you but the fact remains that you should be taking these issues up with the mod author and not posting issues relating to a specific mod in this board.

I've just tried to install and it installed fine. So saying that there are issues and that it's buggy is a false assertion as you haven't even used it yet.

The install is probably failing for you has it's trying to install against code thats been modified by other mods on your forum. Any mod will fail for the same reason and in those circumstances you need to install it by manually amending the relevant code.

Looking at the image for Load.php that you posted above I can see that there's a right curly bracket missing from your code so no wonder that file doesn't parse correctly.

Kindred

whether people are stupid or not is irreverent.
The fact is - if you have problems with a mod - you need to ask them in the support topic for that mod.  If you have read as many of my posts as you say, then you should know that.  The fact that you posted IN the support thread and then also came here means that you not only violated that instruction - but you also double posted the same questions across multiple boards... which is a violation of another rule/instruction.

Additionally...   the mod installs just fine on a clean forum. We know this because storman just did it.... I have done it on several forums as well.
Yup...   it may need a few tweaks, once installed - but those tweaks are listed in the support thread and hcfwesker has been compiling the edits and answering support questions in that thread for a while even if he isn't the author.

As for being condescending, I haven't been... up until now (as you continue to feel that the rules don't apply to you and cross post the same content in multiple places). I'll just link my answer and you can follow up (or not) in the correct location.
http://www.simplemachines.org/community/index.php?topic=114701.msg3564502#msg3564502


Finally... if you can't get the mod to work - then remove it and don't use it. No one is forcing you to do so.


Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

NanoSector

Locked, the OP should take this up with the mod author, there's not much we can do.
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Advertisement: