News:

Follow SMF on Twitter.

Main Menu

Problems

Started by Citrus_Sponge, June 19, 2013, 09:51:37 PM

Previous topic - Next topic

Citrus_Sponge

Well I own an SMF forum, and every time I try to post a new topic, it just takes me to an error page 'This web page is not available'. This also occurs when I was trying to edit my account setting, please help.

mashby

Welcome to SMF.

Do you have any mods installed? Who is your host? Did this issue just start happening or did it always happen?
Always be a little kinder than necessary.
- James M. Barrie

Citrus_Sponge

I only have the shoutbox mod installed, and my host is Envioshost.

This has been happening for ages, I have no idea what to do.

Oh and now the same errors occur when I'm trying to upload packages, this error is EVERYWHERE!

Kindred

sounds like that silly mod_security thing again...   ask you host if they have mod_security enabled... and if so, tell them to disable it.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Citrus_Sponge

Quote from: Kindred on June 20, 2013, 12:29:25 AM
sounds like that silly mod_security thing again...   ask you host if they have mod_security enabled... and if so, tell them to disable it.
They said they cannot disable it.

Colin

Yikes, why is that? There should really be no reason for them not to want to disable it. Who is your host?
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Citrus_Sponge

My host is: hxxp:envioushost.com [nonactive]

I've tried my all best to get them to disable it. :/

Colin

Can you ask them why they won't disable it? Maybe that will offer some insight into their reasoning.
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Shambles

Quote from: Citrus_Sponge
My host is: envioushost.com

I've tried my all best to get them to disable it. :/
You need to toughen up with them.

Remind them that your forum could be critical to the survival of your business and ask them for a 24 hour moratorium on the mod_sec feature while you determine the cause of your issue. If disabling mod_sec doesn't help, let them know that they can re-enable it. If disabling mod_sec does fix the problem, you'll need to start looking for a better host.

Storman™

QuoteYikes, why is that? There should really be no reason for them not to want to disable it.

I agree, its a pain the rear, but many hosts (rightly or wrongly) feel it gives them a degree of security and if their policy is to have it enabled on shared accounts then I doubt they will disable it just like that (even though they could). It's just one of things they keep quiet about when you sign up.

You could ask them to migrate you to a different node where it isn't enabled (if they have one of course....) but I'd be inclined to jump ship and go elsewhere.

Shambles

Quote from: Storman™You could ask them to migrate you to a different node where it isn't enabled...
Or failing that, ask to be put into a DMZ for a short while. That'll keep them "protected", so to speak.

Advertisement: