Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

Joker™

Quote from: Britannia360 on October 18, 2014, 02:53:35 PM
Well I completely uninstalled the last version and db tables and reinstalled with the new version. I noticed that if you like a post, the Total Likes :- of that person stays 0.
Will look into it.


Quote from: gorbi on October 19, 2014, 01:55:05 AM
I installed the 2.0 mod, he began to swear at Theme, although Theme I have a standard. Went back to 1.6.1, he began to work with bugs (
You can't degrade from 2.0 to earlier version as, 2.0 contains DB changes. Due to DB changes old versions are going to fail. I'd strongly recommend to install 2.0, and if you come across issues, please post them in this topic itself.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

gorbi

I repared DB and 1.6.1 began work.

Joker™

Quote from: gorbi on October 19, 2014, 08:04:31 AM
I repared DB and 1.6.1 began work.
And whats the exact issue with 2.0?
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

gorbi

2.0 swore on the template, although  template is a standard. 'll post a screenshot later.

heisenberg3041

#504
I have a Problem. In the post Show, under the User Avatar, stay " Total Likes ". So i have 7 Likes for one Thread... but under my Avatar stayed only " Total Likes : 0 " ...

/EDIT

Look in my Forum. ( German Forum ) http://movie-point.net/index.php?topic=127.0#msg553 [nofollow]

Steve

He's already looking into that ...

Quote from: Joker™ on October 19, 2014, 06:12:38 AM
Quote from: Britannia360 on October 18, 2014, 02:53:35 PM
Well I completely uninstalled the last version and db tables and reinstalled with the new version. I noticed that if you like a post, the Total Likes :- of that person stays 0.
Will look into it.
Please do not PM me for support. 

Joker™

Quote from: ryan_dwight on October 18, 2014, 02:30:53 PM
Great update Joker.

a little stuff due to my laziness is the permission which doesn't have a check all but nevertheless it was a great work. Thank you
Try to click on permission name and see the magic ;).


Quote from: Steve on October 19, 2014, 07:36:35 PM
He's already looking into that ...

Quote from: Joker™ on October 19, 2014, 06:12:38 AM
Quote from: Britannia360 on October 18, 2014, 02:53:35 PM
Well I completely uninstalled the last version and db tables and reinstalled with the new version. I noticed that if you like a post, the Total Likes :- of that person stays 0.
Will look into it.
Thanks for the reply. Thats why I love SMF :D
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

heisenberg3041

So what i have too do now ?

Joker™

Quote from: heisenberg3041 on October 20, 2014, 04:19:16 AM
So what i have too do now ?
Just wait for a while, before I can find the root cause of the issue
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

heisenberg3041


gorbi

Can you fix and 1.6.1 at the same time? )

shayneb

#511
I just cannot get this to work correctly (SMF 2.0.9, LikePosts 2.0, used package manager but also had to enter some things manually).

It worked once, and hasn't since. If you see the attached picture, you can see that I was able to like a post, but am now unable to "unlike" it. When I click the button, nothing happens at all. Clicking "You liked this" does nothing, either.

I made a test account (Global Moderator) if that is necessary.

Edit: In my error log, I have this: 2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callback

ryan_dwight

Quote from: Joker™ on October 20, 2014, 12:12:14 AM
Quote from: ryan_dwight on October 18, 2014, 02:30:53 PM
Great update Joker.

a little stuff due to my laziness is the permission which doesn't have a check all but nevertheless it was a great work. Thank you
Try to click on permission name and see the magic ;).


Quote from: Steve on October 19, 2014, 07:36:35 PM
He's already looking into that ...

Quote from: Joker™ on October 19, 2014, 06:12:38 AM
Quote from: Britannia360 on October 18, 2014, 02:53:35 PM
Well I completely uninstalled the last version and db tables and reinstalled with the new version. I noticed that if you like a post, the Total Likes :- of that person stays 0.
Will look into it.
Thanks for the reply. Thats why I love SMF :D
hahaha great magic you have there lol. Thanks

Joker™

Found the issue for total likes not appearing. Will be releasing a fixed version by tomorrow :)
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Joker™

Quote from: gorbi on October 20, 2014, 09:23:41 AM
Can you fix and 1.6.1 at the same time? )
Gorbi,

There isn't an extra theme edit introduced in 2.0, so if 1.6.1 is working fine on your forum, 2.0 should also work fine. Also you can parse the mod and make edits manually. Moreover, I'm not fixing any older version as we are progressing ahead with 2.0+ only.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Joker™

Quote from: shayneb on October 20, 2014, 02:36:07 PM
I just cannot get this to work correctly (SMF 2.0.9, LikePosts 2.0, used package manager but also had to enter some things manually).

It worked once, and hasn't since. If you see the attached picture, you can see that I was able to like a post, but am now unable to "unlike" it. When I click the button, nothing happens at all. Clicking "You liked this" does nothing, either.

I made a test account (Global Moderator) if that is necessary.

Edit: In my error log, I have this: 2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callback
Hi shayneb,

Whats the php version you are using?
Also can you make a fresh test forum and see if the error persist?
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Joker™

Quote from: ryan_dwight on October 20, 2014, 04:49:53 PM
Quote from: Joker™ on October 20, 2014, 12:12:14 AM
Quote from: ryan_dwight on October 18, 2014, 02:30:53 PM
Great update Joker.

a little stuff due to my laziness is the permission which doesn't have a check all but nevertheless it was a great work. Thank you
Try to click on permission name and see the magic ;).


Quote from: Steve on October 19, 2014, 07:36:35 PM
He's already looking into that ...

Quote from: Joker™ on October 19, 2014, 06:12:38 AM
Quote from: Britannia360 on October 18, 2014, 02:53:35 PM
Well I completely uninstalled the last version and db tables and reinstalled with the new version. I noticed that if you like a post, the Total Likes :- of that person stays 0.
Will look into it.
Thanks for the reply. Thats why I love SMF :D
hahaha great magic you have there lol. Thanks

:D
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

shayneb

Quote from: Joker™ on October 20, 2014, 11:37:46 PM
Quote from: shayneb on October 20, 2014, 02:36:07 PM
I just cannot get this to work correctly (SMF 2.0.9, LikePosts 2.0, used package manager but also had to enter some things manually).

It worked once, and hasn't since. If you see the attached picture, you can see that I was able to like a post, but am now unable to "unlike" it. When I click the button, nothing happens at all. Clicking "You liked this" does nothing, either.

I made a test account (Global Moderator) if that is necessary.

Edit: In my error log, I have this: 2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callback
Hi shayneb,

Whats the php version you are using?
Also can you make a fresh test forum and see if the error persist?

PHP version 5.4.24.  I made a completely new forum with *nothing* changed but adding this mod, and the "Like" button still does nothing.On the completely fresh forum, I still have the two errors in my error log:
http://www.shaynebundy.com/dndftw/forum2/index.php?action=likeposts;sa=like_post [nofollow]
Unable to load the 'main' template.

and

http://www.shaynebundy.com/dndftw/forum2/index.php?action=likeposts;sa=like_post [nofollow]
2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callbackApply Filter: Only show the errors from this file File: /home7/shaynebu/public_html/dndftw/forum2/index.php
Line: 161

Joker™

Quote from: shayneb on October 20, 2014, 11:53:07 PM
Quote from: Joker™ on October 20, 2014, 11:37:46 PM
Quote from: shayneb on October 20, 2014, 02:36:07 PM
I just cannot get this to work correctly (SMF 2.0.9, LikePosts 2.0, used package manager but also had to enter some things manually).

It worked once, and hasn't since. If you see the attached picture, you can see that I was able to like a post, but am now unable to "unlike" it. When I click the button, nothing happens at all. Clicking "You liked this" does nothing, either.

I made a test account (Global Moderator) if that is necessary.

Edit: In my error log, I have this: 2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callback
Hi shayneb,

Whats the php version you are using?
Also can you make a fresh test forum and see if the error persist?

PHP version 5.4.24.  I made a completely new forum with *nothing* changed but adding this mod, and the "Like" button still does nothing.On the completely fresh forum, I still have the two errors in my error log:
http://www.shaynebundy.com/dndftw/forum2/index.php?action=likeposts;sa=like_post
Unable to load the 'main' template.

and

http://www.shaynebundy.com/dndftw/forum2/index.php?action=likeposts;sa=like_post
2: call_user_func(LikePostsRouter::routeLikes) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callbackApply Filter: Only show the errors from this file File: /home7/shaynebu/public_html/dndftw/forum2/index.php
Line: 161
Are you able to access the like stats, likes admin panel etc?
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

shayneb

Ah, sorry for not including that: Likes Admin Page, yes (and as far as I can tell, every checkbox does what ti's supposed to), but Like Stats says: Unable to load the 'main' template.

Advertisement: