News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

gorbi

Quote from: Joker™ on November 02, 2014, 11:05:56 PM
Hi gorbi,
I'm unable to see the like notification button.
I turn again )

larry007

#561
Hi

look please to the picture...

1. The menu (template inferno) shines thru the like box overview and it is clickable...

I don't want this.... any help?

2. How can I put a image under "Unlike and like" button?

THX

power505

If I update mod on new version, does like stats resets or stayed the same?

gorbi


Joker™

Quote from: larry007 on November 03, 2014, 06:09:29 AM
Hi

look please to the picture...

1. The menu (template inferno) shines thru the like box overview and it is clickable...

I don't want this.... any help?

2. How can I put a image under "Unlike and like" button?

THX
Thanks for reporting it, will be fixed with the next release.


Quote from: power505 on November 04, 2014, 04:59:32 AM
If I update mod on new version, does like stats resets or stayed the same?
Likes stays intact and nothing gets deleted ;)


@gorbi, I've see the issue with likes notification and it'll be fixed with the next release.


Issues are tracked over here. Please do let me know if I missed to track something.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

power505

Quote from: Joker™ on October 27, 2014, 12:01:27 PM
Quote from: power505 on October 24, 2014, 08:13:05 AM
1. Is it possible to somehow remove "Total likes" field from profile (under avatar)?
Added 1st point as an option in admin panel
Quote from: Joker™ on November 04, 2014, 11:54:35 AM
Quote from: power505 on November 04, 2014, 04:59:32 AM
If I update mod on new version, does like stats resets or stayed the same?
Likes stays intact and nothing gets deleted ;)

Thx for answer. I especially appreciate what you did from first quote :)

Elizabeth II

tiny detail issue, if you like a post, sometimes (when it already has likes) it goes:

(You & 2 other people liked this)

Joker™

Quote from: Britannia360 on November 04, 2014, 03:45:20 PM
tiny detail issue, if you like a post, sometimes (when it already has likes) it goes:

(You & 2 other people liked this)

Opps, look like text is not parsed into HTML entity. Tracked

Joker made a booboo :laugh:
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

szinski

I seem to be having an issue with SSL. When I connect to my forum via https: none of the javascript works. Will someone point me in the right direction how to fix this? Thanks!

szinski

Never mind, I edited LikePosts.php and changed all references of http://ajax... to https://ajax... which solved the problem.

Joker™

Quote from: Blue Crab on November 07, 2014, 04:21:57 PM
Never mind, I edited LikePosts.php and changed all references of http://ajax... to https://ajax... which solved the problem.
Nice to hear, still tracked
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

RoadRanger

Awesome mod, I replaced my kludged "karma" usage with it :) . I do wish it looked a bit more integrated with the forum, maybe with the "Like" button next to the "report to moderator"? It'd be cool to change the "report to moderator" to a "report" button similar to the "like" button too :) . One minor bug I see is if a topic is "pinned" the (x people like this) message on the topic overstrikes the "pinned" icon:
http://cacophony.aspinock.com/index.php?board=26.0 [nofollow]

iain sherriff

Hi
I installed  this on a test board. It went ok but gave install error on index.template.php.

I'm sure this is because I have the "unread enhancement" mod so the bit of code your mod looks for isn't there !

The like button appeared and all the admin stuff was there and useable. When I clicked the button there was no action tho...............could this be just because of the error ?

(I can't show you as the test site crashed  over something else)
SMF 2.0.12

Steve

Hopefully someone with coding skills (because I have none) can help me here ...

I have a test fail on 3 themes and all 3 are for the same reason. In index.template.php the mod is looking for:

<li><a href="', $scripturl, '?action=unreadreplies">', $txt['show_unread_replies'], '</a></li>';

And wants to add after that:


if(LikePosts::$LikePostsUtils->showLikeNotification()) {
echo '
<li><a href="#" class="showLikeNotification" onclick="lpObj.likePostsNotification.showLikeNotification()">', $txt['like_show_notifications'], '</a></li>';
}


But in these 3 themes, the only place where 'action=unreadreplies' shows is in this code:

<div id="t_bar">';
if ($context['user']['is_logged'])
{
  echo'
<div class="time_bar">
<span>', $context['current_time'], '</span>
</div>
<div class="user_bar">
  <span><a href="', $scripturl, '?action=unread">', $txt['unread'], '</a></span> |
<span><a href="', $scripturl, '?action=unreadreplies">', $txt['unread_replies'], '</a></span>
</div>';
}
else
{
echo '
<div class="user_bar">
<script type="text/javascript" src="', $settings['default_theme_url'], '/scripts/sha1.js"></script>
<form id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>
<span>'.$txt['username'].': </span><input type="text" name="user" size="10" class="input_text" />
<span>'.$txt['password'].': </span><input type="password" name="passwrd" size="10" class="input_password" />
<input type="submit" value="', $txt['login'], '" class="button_submit" />
</form>
</div>';
}
 
echo'
</div>


How do I rewrite the last code to make this work?
Please do not PM me for support.

Black Tiger

I just installed this mod on a 2.0.9 forum via the package manager and got a white screen afterwards.
It seemed instead of making some "Likepost" directory's in the Theme section in the images and scripts directory, it made empty files called "likeposts.
Same happened with the DB directory in Sources/Likeposts.

After I deleted the empty files and created the directory's as should be. Things were working fine again.

Maye this can be fixed in the next release?
Greetings, Black Tiger

njsuperglide

I installed this mod on my SMF 2.06 and can access the admin screens but the Like button does not appear on my posts.

iain sherriff

Quote from: Steve on November 27, 2014, 07:25:41 PM
Hopefully someone with coding skills (because I have none) can help me here ...

Steve. This will be due to a mod you have (see my post above). If you read this topic there are examples people have posted that have answers......none of them help with my theme issue but you may be lucky :)
Otherwise someone will answer .....
SMF 2.0.12

Steve

I can't imagine it being a mod issue as all my other themes worked just fine. I've read this entire thread and there's nothing that suggests a solution for me. I just need to know how to code that one section in those 3 themes so the mod works the way it's supposed to. Thanks though. :)
Please do not PM me for support.

iain sherriff

My guess is that you have a mod that has altered that part of the SMF code (a navigation mod of some type like mine). The mod works fine but as it has altered the code this "like" mod can't see the code it looks for when installing
SMF 2.0.12

Steve

#579
If that were the case it wouldn't work on any theme that I have, would it not?

Besides, I really don't care WHY it's not working, I'd just like to know how to write the code above so that it WILL work on those themes.
Please do not PM me for support.

Advertisement: