News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

nax

Many thanks for your advice and Joker for this mod - So far so good! It's in and working.

halpaslan

Is it possible to like post as a tapatalk option?

Paracelsus

One feature I would much appreciate in the Like system is if there was the possibility of sorting posts in a topic by likes (ascending/descending). This way one could read from the most to the least popular posts in a topic (and vice-versa).

Gluz

This Mod is really good, but with Pretty URLs MOD the notification popup doesn't show, as soon I dissable Pretty URLs the notification popup shows when I press the link on the user-area. All other things of the mod work as intended, only the notification popup doesn't show up with Pretty URLs activated.

I don't know what to do, this mod is different from others I used to edit to fix some things that doesn't work by just install it or that other mods broke, and can't figure out how Pretty URLs affect this MOD.

Paracelsus

Hi,

I'm having problems trying to install this MOD... something in the non theme template related files but that disrupts the layout and lots of css/javascript/jquery functions in my theme making the forum unusable.

In Firefox the console shows the following:
Quote"jquery is already loaded with version: 2.1.1" index.php:1938:4
"result of version check: 1" index.php:1940:5
TypeError: $ is not a function

Any ideas on how to fix this?

Tom.B

#645
Hi there, this mod looks great, and I've installed it!

However, I can't figure out how to like people's posts...



Can't see a like button!







Any ideas?

Thanks in advance,
Tom.B

Paracelsus

Tom, I see your theme is based on Reseller, same here. Read the post above yours, I'm having similar problems. My guess is that is something related to JQuery being declared several times at the same time. Hope someone with more expertise can help here.

Tom.B

Quote from: Paracelsus on April 09, 2015, 01:57:14 PM
Tom, I see your theme is based on Reseller, same here. Read the post above yours, I'm having similar problems. My guess is that is something related to JQuery being declared several times at the same time. Hope someone with more expertise can help here.

Ah right. I'm based on Redsy, not Reseller... unless it's the same thing and I'm being dumb. :P

Yes would be nice if someone could come and help!

Gluz

#648
For the like button not showing, is not the Jquery problem is the CSS, the Like button have display:none; and that's why it doesn't show, but the button is there. If you open with Inspect element and search just above the signature, the button is there but is hidden. I see that after I installed the MOD but as I say, after Inspecting the elements got it work.


And for my problem, I still can't figure out what to do, the only way to get the Notification popup to work is when I disable Pretty URLs.



EDIT:
Nevermind, I change from html <a> to <span> and it works, better than I though, as it doesn't reload the page.

Paracelsus

Quote from: Tom.B on April 09, 2015, 05:16:20 PM
Quote from: Paracelsus on April 09, 2015, 01:57:14 PM
Tom, I see your theme is based on Reseller, same here. Read the post above yours, I'm having similar problems. My guess is that is something related to JQuery being declared several times at the same time. Hope someone with more expertise can help here.

Ah right. I'm based on Redsy, not Reseller... unless it's the same thing and I'm being dumb. :P

Yes would be nice if someone could come and help!

Sorry, yours is based on Redsy, mine on Reseller, but it's the same author and the same type of coding so in the end it's pretty similar.

Paracelsus

Quote from: Gluz on April 09, 2015, 07:34:34 PM
For the like button not showing, is not the Jquery problem is the CSS, the Like button have display:none; and that's why it doesn't show, but the button is there. If you open with Inspect element and search just above the signature, the button is there but is hidden. I see that after I installed the MOD but as I say, after Inspecting the elements got it work.


And for my problem, I still can't figure out what to do, the only way to get the Notification popup to work is when I disable Pretty URLs.



EDIT:
Nevermind, I change from html <a> to <span> and it works, better than I though, as it doesn't reload the page.

Yeah, but why is the Like button hidden with display:none in the first place? It doesn't make sense.

In my case, that's not the only problem, I have also issues with the layout being changed in several places without even touching the template files. I can only suspect some conflict at code level.

Gluz

I have one site with Reseller, and I tested there, and as I said, it's hidden with display:none

Also, the MOD have a little bit ugly CSS in my opinion, I changed a lot of things for my site, to get it some how integrated with the theme, but for get it work only need to delete the hidden rule.

I almost forgot to mention, you can't Like your own post, so to test, aside of checking permissions on groups that can see/give Likes and the permissions of the boards, the post need to be from another user. That's how I see that the Like button was present but hidden.

Some pics on the Reseller theme with the inspector:
http://puu.sh/h8mT4.png
http://puu.sh/h8mTC.png

Tom.B

If it's hidden with Display: None, how do I revert that so it is displayed?

Gluz

Are you sure that the MOD is installed in your theme? Inspecting your page doesn't seem to have it enabled in the theme. Check in yout Theme folder, in Display.template.php that above this line:
// Show the member's signature?
there are code of LikePost MOD, 'cause the first time I installed the MOD, I only installed in the default theme and not in my theme.

Tom.B

I've installed it now, although now I'm unsure of what to do. I'm a newbie to this sort of thing!

Paracelsus

Quote from: Gluz on April 10, 2015, 04:25:39 AM
I have one site with Reseller, and I tested there, and as I said, it's hidden with display:none

Also, the MOD have a little bit ugly CSS in my opinion, I changed a lot of things for my site, to get it some how integrated with the theme, but for get it work only need to delete the hidden rule.

I almost forgot to mention, you can't Like your own post, so to test, aside of checking permissions on groups that can see/give Likes and the permissions of the boards, the post need to be from another user. That's how I see that the Like button was present but hidden.

Some pics on the Reseller theme with the inspector:
http://puu.sh/h8mT4.png
http://puu.sh/h8mTC.png

That can be solved, but I've got also other problems with the Mod. For instance, the "New" button just disappears from messageindex, and I see no way to retrieve it.

Schachazubi

Joker, thank you for the Great Like-Mod and your Help and Answers at this Thread.


Problem:

Board 2.0.7 + Like 1.3.1 = Works fine
Board 2.0.7 + Like 1.3.1 + SMF Quiz 1.1.0 = Like Works, but Quiz did not load. Maybe a JQuery-Thing.

Board 2.0.7 + Like 2.0.3 + SMF Quiz 1.1.0 = Likes did not Work but Quiz Works

Board 2.0.9 + Like 1.3.1 = Works fine - fresh Installation, no other Mods - only Like
Board 2.0.9 + Like 2.0.3 = Works not - same Installation, no other Mods - only Like (tested on Webspace + tested on a own root-Server)

Board 2.0.7 + Like 2.0.3 = Works not - fresh Installation, no other Mods - only Like (tested on Webspace + tested on a own root-Server)


Summary:

I wanted to use Like Posts + SMF Quiz working on my 2.0.9
Like Posts 2.0.3 don't want to work on my Forum, even on a fresh 2.0.7, even on a 2.0.9 - on 2 different Websites (once tried on Webspace, once tried on a root-Server)


I dont get/find a Error-Message.

2.0.7 Likes did not work = There is simply no (orange) Like-Button.
Using 1.3.1, the Like Button appear instandly.


Sorry, English is not my Native Language.
Did anyone has the same Issues and like to share Information - or has a Tip or a Solution for me?

Greetings, Schachazubi

suhaneankit

Sounds good.

Quote from: barnaby jonez on July 16, 2013, 12:22:05 PM
Joker,

Using an example from vBullitin, when you receive a Like, you click on that notification, and it will show you what posts were given likes, and by whom. [X Person liked your post(s) in this thread...]

Similarly, Facebook does this the same way. [X Person liked your Status...]

It doesnt have to be as specific as this, but something that basically says "Hey, there is some activity. Someone read your post, and liked it." -- this gets the user to zip straight there and see who is giving them props.

Does this help?
7 Steps IRCTC Registration IRCTC Registration in 7 Steps
Check PNR Status IRCTC PNR Status

roshaoar

Great mod - the only issue for me on 2.0.10 with a bunch of mods and responsive curve is that the popup window on "Show new replies to your posts" automatically disappears after a second or so. Can you give me a hint which file I'd want to look at to make this popup stay open?

Thank you for your time,

-Johan

Gluz

You mean, the popup on "Show Likes notification".

I have that problem too, and what I did is change from <a> to <span> in the index.template.php of my Theme, and the only thing missing to be viewed as another link is to add a CSS rule for hover over that span and underline the text as a normal link.

index.template.php:
if(LikePosts::$LikePostsUtils->showLikeNotification()) {
echo '
<li><span class="showLikeNotification" style="cursor:pointer" onclick="lpObj.likePostsNotification.showLikeNotification()">', $txt['like_show_notifications'], '</span></li>';
}


CSS:
.showLikeNotification:hover {
text-decoration: underline;
}

Advertisement: