News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

peterwaalker

Quote from: Gluz on May 02, 2015, 05:57:36 PM
Here you are.

I have Reseller Theme on one of my forums and I see the error on the file, so I modify your index.template according to the parser.

I have done exactly what you did in that index.template.php but likes refused to show under posts on post pages. There is no like/unlike button under posted message.
Instead the total likes received by users on user profile avatar are showing.

Find:
<li><a href="', $scripturl, '?action=unreadreplies">', $txt['unread_replies'], '</a></li>

Replace:
<li><a href="', $scripturl, '?action=unreadreplies">', $txt['unread_replies'], '</a></li>';
if(LikePosts::$LikePostsUtils->showLikeNotification()) {
echo '
<li><a href="#" class="showLikeNotification" onclick="lpObj.likePostsNotification.showLikeNotification()">', $txt['like_show_notifications'], '</a></li>';
}
echo '


There was no error after replacing code above. But the likes button are not displaying. I have verified 'like mod' codes in various files directories and all codes are in there. Or Is there any other thing i am missing?

Gluz

In my site the Like Button didn't show either, but the button is there, so I modified /Themes/default/css/LikePost.css this rule in particular to see the button:

Line 52:
.like_post_box {
    line-height: 22px;
    position: relative;
    display: none;
}


to this:
.like_post_box {
    line-height: 22px;
    position: relative;
    display: block;
}


And it show the button.


Searching trough the GitHub of the MOD I found this fix commit, where that display: none; were introduced, but if I'm not wrong that fix is only for the MessageIndex in the Sticky Threads, in the posts the button didn't show because of that display: none;

That's why most of the users that install the latest versions didn't see the button but I know is there because I inspect the page elements and see the button.

Joker™

Quote from: peterwaalker on May 02, 2015, 04:31:57 AM
Quote from: Joker™ on May 01, 2015, 11:53:20 PM
Quote from: peterwaalker on April 30, 2015, 03:32:30 PM

I was using this mod on another theme until recently when i changed theme. i found out that it is not showing on posts bottom and profile post avatar of all members. So i decided to uninstall and reinstall before i come up with that error on installation.
It gave me double error when i want to reinstall on my current theme. What shall i do?
see image


Please i'm still waiting for a detailed guide.
Thank you
Make backup of files before editing anything

Error in mod installation - http://wiki.simplemachines.org/smf/Error_in_mod_installation
How to install mods manually - http://wiki.simplemachines.org/smf/Manual_installation_of_mods

Edits for this mod - http://custom.simplemachines.org/mods/index.php?action=parse;mod=3708;attach=238068;smf_version=2.0.10

I hope this will be helpful in resolving the issue :)

Please my question is if I continue with the installation is it going to break something?
The test passed on other themes except reseller theme which is my current theme.
See image of failed installation test.
I have downloaded mysql data base.

No it won't break anything, but the functionality added to index template won't work, i.e notification thinggy :)
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

peterwaalker

Quote from: Gluz on May 02, 2015, 10:10:58 PM
In my site the Like Button didn't show either, but the button is there, so I modified /Themes/default/css/LikePost.css this rule in particular to see the button:

Line 52:
.like_post_box {
    line-height: 22px;
    position: relative;
    display: none;
}


to this:
.like_post_box {
    line-height: 22px;
    position: relative;
    display: block;
}


And it show the button.


Searching trough the GitHub of the MOD I found this fix commit, where that display: none; were introduced, but if I'm not wrong that fix is only for the MessageIndex in the Sticky Threads, in the posts the button didn't show because of that display: none;

That's why most of the users that install the latest versions didn't see the button but I know is there because I inspect the page elements and see the button.

Thanks a lot. It worked like charm.
I owe great appreciation. How i wish you could help me on the questions i have been asking here

ⓜⓤⓡⓐⓣ

Hi, I want to add a button to the form.
I am writing this code into subs.php .
'Begeniler' => array(
'title' => $txt['like_show_notifications'],
'href' => '"#" class="showLikeNotification" onclick="lpObj.likePostsNotification.showLikeNotification',
'show' => true,
),

of course, it does not.
What should be the correct code for popup?

Edit: Because every theme "unreadpost" There is no.

digiflash

I updated from 1.0.3 to 2.0.3.
"Recount Like stats" doesn't help. Likes are gone? I don't know if the table was dropped as I uninstalled the old mod?!

Gluz

Quote from: mert1i on May 05, 2015, 04:05:45 AM
Hi, I want to add a button to the form.
I am writing this code into subs.php .
'Begeniler' => array(
'title' => $txt['like_show_notifications'],
'href' => '"#" class="showLikeNotification" onclick="lpObj.likePostsNotification.showLikeNotification',
'show' => true,
),

of course, it does not.
What should be the correct code for popup?

Edit: Because every theme "unreadpost" There is no.

I think the right code for a menu button is:
'Begeniler' => array(
'title' => $txt['like_show_notifications'],
'href' => 'javascript: lpObj.likePostsNotification.showLikeNotification()',
'show' => true,
),


#Untested

ⓜⓤⓡⓐⓣ

#687
Quote from: Gluz on May 05, 2015, 11:34:34 AM


I think the right code for a menu button is:
'Begeniler' => array(
'title' => $txt['like_show_notifications'],
'href' => 'javascript: lpObj.likePostsNotification.showLikeNotification()',
'show' => true,
),


#Untested
Thank you, but Unfortunately it didn't work. It's as page loading, staying on the same page.

EDIT:I'm sorry, it works well.

Siirist

Hi Joker,

Thanks for this GREAT MOD!!!!  ;D

However, it only works on Curve theme.  :(

SMF v2.0.10

MODs
1.    Like Posts    2.0.3    
2.    Menu_Icons    1.0    
3.    PM Warning    1.0    
4.    Topic Solved    1.1.1    
5.    Google Translate for SMF 2.0    1.4    
6.    Default_Membergroup    2.0    
7.    Enhanced Dropdown    1.3    
8.    Board-color-and-icons    1.1    
9.    Caps_Lock_Detection_on_Login    1.1.0.2    

Themes that the user is able to select:
    SMF Default Theme - Curve
    Core Theme
    Hope
    Bright Forest
    Ostara
    Sunshine

Link to Test Forum
USERNAME=testmember    (is a regular member)
PASSWORD=letmesee
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

margarett

Which errors do you get in the other themes? Isn't it just the small error in index.template.php?
http://www.simplemachines.org/community/index.php?topic=506743.msg3782211#msg3782211
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Siirist

Quote from: margarett on May 15, 2015, 06:54:56 PM
Which errors do you get in the other themes? Isn't it just the small error in index.template.php?
http://www.simplemachines.org/community/index.php?topic=506743.msg3782211#msg3782211

Yum, yes?

   Execute Modification    ./Themes/brightforest_23/Display.template.php    Test successful
      1.    Add Before    ./Themes/brightforest_23/Display.template.php    Test successful
      2.    Add Before    ./Themes/brightforest_23/Display.template.php    Test successful
      Execute Modification    ./Themes/brightforest_23/MessageIndex.template.php    Test successful
      1.    Add After    ./Themes/brightforest_23/MessageIndex.template.php    Test successful
      Execute Modification    ./Themes/brightforest_23/index.template.php    Test failed
      1.    Add After    ./Themes/brightforest_23/index.template.php    Test failed

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Joker™

Quote from: Schachazubi on April 17, 2015, 09:31:20 AM
Joker, thank you for the Great Like-Mod and your Help and Answers at this Thread.


Problem:

Board 2.0.7 + Like 1.3.1 = Works fine
Board 2.0.7 + Like 1.3.1 + SMF Quiz 1.1.0 = Like Works, but Quiz did not load. Maybe a JQuery-Thing.

Board 2.0.7 + Like 2.0.3 + SMF Quiz 1.1.0 = Likes did not Work but Quiz Works

Board 2.0.9 + Like 1.3.1 = Works fine - fresh Installation, no other Mods - only Like
Board 2.0.9 + Like 2.0.3 = Works not - same Installation, no other Mods - only Like (tested on Webspace + tested on a own root-Server)

Board 2.0.7 + Like 2.0.3 = Works not - fresh Installation, no other Mods - only Like (tested on Webspace + tested on a own root-Server)


Summary:

I wanted to use Like Posts + SMF Quiz working on my 2.0.9
Like Posts 2.0.3 don't want to work on my Forum, even on a fresh 2.0.7, even on a 2.0.9 - on 2 different Websites (once tried on Webspace, once tried on a root-Server)


I dont get/find a Error-Message.

2.0.7 Likes did not work = There is simply no (orange) Like-Button.
Using 1.3.1, the Like Button appear instandly.


Sorry, English is not my Native Language.
Did anyone has the same Issues and like to share Information - or has a Tip or a Solution for me?

Greetings, Schachazubi

Hey there,

I tried reproducing the issue, but couldn't reproduce the same. Lets see if its resolved with the upcoming version.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Schachazubi


Joker™

Please try out 2.0.4

- Not pretty url friendly - https://github.com/siddhartha-gupta/SMF-Likes/issues/41
- Issue with reseller theme - https://github.com/siddhartha-gupta/SMF-Likes/issues/43
- Issue on iPad for overlays - https://github.com/siddhartha-gupta/SMF-Likes/issues/40
- Issue with SMF Quiz mod - https://github.com/siddhartha-gupta/SMF-Likes/issues/42
- Use isNullUndefined instead of typeof - https://github.com/siddhartha-gupta/SMF-Likes/issues/44
- Added Turkish translations - https://github.com/siddhartha-gupta/SMF-Likes/pull/37
- Few css changes for like posts notification box
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Siirist

Thanks Joker,  :)

Okay, will uninstall 2.0.3 and then install 2.0.4

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Quote from: Siirist on May 14, 2015, 11:20:05 AM
Hi Joker,

Thanks for this GREAT MOD!!!!  ;D

However, it only works on Curve theme.  :(

SMF v2.0.9

MODs
1.    Like Posts    2.0.4       
2.    Menu_Icons    1.0    
3.    PM Warning    1.0    
4.    Topic Solved    1.1.1    
5.    Google Translate for SMF 2.0    1.4    
6.    Default_Membergroup    2.0    
7.    Enhanced Dropdown    1.3    
8.    Board-color-and-icons    1.1    
9.    Caps_Lock_Detection_on_Login    1.1.0.2    

Themes that the user is able to select:
    SMF Default Theme - Curve
    Core Theme
    Hope
    Bright Forest (haven't even tried this theme due to failed when installing)
    Ostara
    Sunshine

Link to Test Forum
USERNAME=testmember    (is a regular member)
PASSWORD=letmesee

Hi again,

I tried the MOD after uninstalling v2.0.3 and then installing v2.0.4.
The results were
while using default theme (Curve) the mod seemed to function as intended
while using Ostara theme the box didn't appear (see screenshot)

Thoughts?

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Gluz

For me is working now very well, I resolved some jQuery conflicts with the Theme itself and now works great. Good job.

PD: I'm Al-eXs in Github :P

Joker™

Sorry guys, Joker made a boo boo

Please update to v_2.0.5
- Updated LikePosts.min.js with recent changes
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Joker™

Quote from: Siirist on May 16, 2015, 02:47:17 PM
Quote from: Siirist on May 14, 2015, 11:20:05 AM
Hi Joker,

Thanks for this GREAT MOD!!!!  ;D

However, it only works on Curve theme.  :(

SMF v2.0.9

MODs
1.    Like Posts    2.0.4       
2.    Menu_Icons    1.0    
3.    PM Warning    1.0    
4.    Topic Solved    1.1.1    
5.    Google Translate for SMF 2.0    1.4    
6.    Default_Membergroup    2.0    
7.    Enhanced Dropdown    1.3    
8.    Board-color-and-icons    1.1    
9.    Caps_Lock_Detection_on_Login    1.1.0.2    

Themes that the user is able to select:
    SMF Default Theme - Curve
    Core Theme
    Hope
    Bright Forest (haven't even tried this theme due to failed when installing)
    Ostara
    Sunshine

Link to Test Forum
USERNAME=testmember    (is a regular member)
PASSWORD=letmesee

Hi again,

I tried the MOD after uninstalling v2.0.3 and then installing v2.0.4.
The results were
while using default theme (Curve) the mod seemed to function as intended
while using Ostara theme the box didn't appear (see screenshot)

Thoughts?

Be Well,
Siirist
Check settings from admin panel
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Joker™

Quote from: Gluz on May 16, 2015, 07:07:00 PM
For me is working now very well, I resolved some jQuery conflicts with the Theme itself and now works great. Good job.

PD: I'm Al-eXs in Github :P
First of all a big thanks for providing such a great support in resolving the issues :).

Can you tell me the jQuery issues you have faced and theme name.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Advertisement: