Advertisement:

Author Topic: Help please with(Adding HTML Player in the right place in index.template) :D  (Read 8627 times)

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
I'm trying to add this code to index.template

Code: [Select]
<!-- Wikplayer http://www.wikplayer.com -->
<script type="text/javascript" src="http://www.wikplayer.com/code.js"
data-config="{'skin':'skins/wikfull/plainBlack/skin.css','volume':50,'autoplay':true,'shuffle':true,'repeat':1,'showcomment':false,'marqueetexton':true,'placement':'bottom','showplaylist':false,'playlist':[{'title':'It%27s%20The%20Most%20Wonderful%20Time%20Of%20The%20Year','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DgFtb3EtjEic'},{'title':'All%20I%20Want%20For%20Christmas%20Is%20You','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DyXQViqx6GMY'},{'title':'Let%20It%20Snow','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DmN7LW0Y00kE'},{'title':'Jingle%20Bell%20Rock','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DitcMLwMEeMQ%23t%3D36'},{'title':'Driving%20Home%20For%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DczhZbqpyBm8%23t%3D27'},{'title':'Merry%20Christmas%20Everybody','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D0A8KT365wlA'},{'title':'Winter%20Wonderland','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DSHE0Jo82_34%23t%3D56'},{'title':'Santa%20Baby','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3Dg7T0IK99ELs'},{'title':'It%27s%20Beginning%20To%20Look%20Alot%20Like%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DcHh7pW29Fy8'},{'title':'Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D5aw2yuYAKoE'},{'title':'Jingle%20Bells','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DVKtOBLvPs5Q'},{'title':'Run%20Run%20Rudolph','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3Dl849CulLhGQ'},{'title':'Baby%20It%27s%20Cold%20Outside','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D2Rhvtzzmq-Y'},{'title':'Rocking%20Around%20The%20Christmas%20Tree','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DbnIqLlBwzrc%23t%3D15'},{'title':'Silent%20Night','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DPGjByOI9Iqw'},{'title':'Holly%20Jolly%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DKjiMMDZoKmY'},{'title':'Have%20Yourself%20A%20Merry%20Little%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DnZ6yQgBvuoI'},{'title':'Santa%20Claus%20Is%20Coming%20To%20Town','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DSnA52s7qceM'},{'title':'Last%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DE8gmARGvPlI'},{'title':'Merry%20Christmas%20Everyone','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D5PkUWkxGWj0'},{'title':'Shake%20Up%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DJ-8VCL4uSUc'},{'title':'Deck%20The%20Halls','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D3-ykZUb3AEE'},{'title':'Carol%20Of%20The%20Bells%20(Pentatonix)','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DVOGByYObUqE'},{'title':'Rudolph%20The%20Red%20Nose%20Reindeer','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D0byH9h1ClBY'},{'title':'The%20Christmas%20Song','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DSOszvL9lgSs'},{'title':'I%20Wish%20It%20Could%20Be%20Christmas%20Everyday','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DZoxQ4Ul_DME'},{'title':'Do%20They%20Know%20It%27s%20Christmas','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D1AcD7hho9fs'},{'title':'Feliz%20Navidad','url':'http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DQ6ziiLE92Zg'}]}" ></script>
<!-- Wikplayer code end -->

It is html music player for christmas, when I add it right at bottom of index template it works fine but everything seems a bit bigger, board descriptions, whos online etc ect..

It says in instructions "Please place the code for your music player into your HTML page, immediately under the beginning of the <body> tag or <body ..." but I think I'm messing up somewhere when I try and add it there I get template parse error..

Can someone maybe add it in the right place for me? Thank you!

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Re: Help please with :D
« Reply #1 on: November 30, 2013, 04:41:49 PM »
How do I ask support questions the smart way?
How can I get my problems solved faster?

Please do not use Help as a topic. Be descriptive in subject, so we can know what it is about.

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
Re: Help please with :D
« Reply #2 on: November 30, 2013, 04:43:10 PM »
How do I ask support questions the smart way?
How can I get my problems solved faster?

Please do not use Help as a topic. Be descriptive in subject, so we can know what it is about.

Subject edited.

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Try this.

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
Try this.

Got this;

Code: [Select]
Template Parse Error!

There was a problem loading the /Themes/zone99/index.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.
syntax error, unexpected T_STRING, expecting ',' or ';'

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Replace with the original.
There is something in the code you are trying to insert that causes the template parse error.

A link to where you got it would be good.

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
Replace with the original.
There is something in the code you are trying to insert that causes the template parse error.

A link to where you got it would be good.

Well if I add it right to the end of the file it works fine, it's just the issue of the size of resolution of the board descriptions and other things seem to increase


(Btw, this is my test forum, it may not seem that much bigger but on my original forum with the amount of boards the increase is very noticeable.
« Last Edit: January 04, 2014, 10:46:45 AM by Britannia360 »

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
That is because you must be putting it outside the php closing.

As for changing the sizes, that is also due to the way it is coded.
I think even if got it to work the other way, it would have done same thing.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
I would strongly discourage this sort of thing.

The music will start playing as soon as it has loaded - and I don't think it'll keep its position between pages, so if a user sees the first page, music starts playing, then they go to the next page and the music restarts. This is likely to be more annoying than cute.
No good deed goes unpunished
All helpful urges should be circumvented

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
Noted, but it seems anything I add fonts seem to go bigger..

If I add this (without player)

Code: [Select]
<script src="http://tester2.synthasite.com/resources/white1.js" type="text/javascript"></script>
It will have the same issue as adding the media player with bigger fonts.. and generally the forum looking bigger..

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Then they may have something in their javascript file that is conflicting.

I agree with Arantor.
Music coming on right as page loads is major turn off on sites.
If I come across one, I close the tab right away.

Also, he does have a point about changing pages.
Not sure if it will reset the music or not.

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
It's strange because when I try it with the headers and footers mod it works without the fonts going bigger (the snow html code) but if I try with the music player code when I reload it the forum will come up for a brief moment (the fonts normal size), flash, and I can then only see the background image of the forum, nothing else, and the music plays tho..

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Could be conflict with the snow html code.

Offline Elizabeth II

  • Jr. Member
  • **
  • Posts: 245
  • E II R
    • @Ambrosia_News on Twitter
Oops, yeah forgot to mention it happens without it also

Offline Gargoyle

  • Sophist Member
  • *****
  • Posts: 1,148
  • Gender: Male
    • South Side Street Cars
Put it in a popup window so people can use it if they want, and the player isn't reset by switching pages.