• Welcome to Simple Machines Community Forum. Please login or sign up.
October 25, 2021, 09:45:15 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


No Browse Package ?

Started by Homie2Go, December 11, 2013, 09:46:41 PM

Previous topic - Next topic

Homie2Go

Well I am trying to download plugins and my issue is that when I try to load the Browse Packages url it won't work, but download and the other package tabs work. It just goes to a white page, please help. I have the latest update of SMF to.

Arantor

Please see the sticky topic in this board entitled "Do you get the "white screen of death" when accessing Admin or Package Installs?"

Should be the first topic in the list.
No good deed goes unpunished
All helpful urges should be circumvented

tophresh123

Change your dini_set MB to 128.. Happened to me as well. Mine works now.

Arantor

Quote from: tophresh123 on December 11, 2013, 09:50:29 PM
Change your dini_set MB to 128.. Happened to me as well. Mine works now.

As discussed in that topic :P
No good deed goes unpunished
All helpful urges should be circumvented

Homie2Go

Sorry I didn't bother to look through the posts, thank you.

Homie2Go

AT that post says that I need a better host, I do own a free forum from 000webhost, but like a year ago the SMF was working fine, not any issues at all.

Arantor

Well, 2.0 hasn't changed in that time...
No good deed goes unpunished
All helpful urges should be circumvented

Homie2Go

Well I am going to try the older smf versions, and hopefully it will work.

Arantor

I really couldn't recommend that. SMF 1.1.x will not be supported soon, SMF 2.0.x below 2.0.6 has security vulnerabilities.
No good deed goes unpunished
All helpful urges should be circumvented

Sir Osis of Liver


IIRC, this problem first occurred after one of the 2.0.x upgrades.  If you uninstall the upgrades in Package Manager and back up one step at a time, you may get rid of the problem.  (Bearing in mind Arantor's advice about security vulnerabilities.)

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Homie2Go

Well 2.0 isn't working for me either, so any recommended hosters that are cheap or free? Also crash what do you mean uninstall the upgrades in package manager?

Arantor

The white screen issue is an out of memory issue - and the only changes in 2.0 through 2.0.6 do not significantly alter memory usage in either direction (as can be verified from Customize > Upgrades up the top of this page, where you can step through the different versions)

This suggests to me that the problem isn't really related to us but a change in host configuration, e.g. an upgraded version of PHP that's more memory hungry than earlier versions.


The thing with hosting is that you get exactly what you pay for. If you insist on a free host, you have no right whatsoever to any expectations because you're actually costing them money in running your site and they have all kinds of limitations to limit how much resource you can take and to generally push you towards better hosting. But there's a whole board of hosting reviews you can look at...
No good deed goes unpunished
All helpful urges should be circumvented

Sir Osis of Liver


It does seem that 000webhost was one of the main culprits when this problem cropped up.

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Arantor

Especially given their unusual configuration. For example we've seen their system report having 64MB available but still fail to allow use above 32MB (regardless of anything SMF tries to do)

They also have a very old version of PCRE attached, so despite being PHP 5.3 at times, they're not even using facilities added by the PCRE library in 5.2 (which means, incidentally, Wedge will refuse to even install because a feature it depends on is not available, the use of \h as a regex meta character)
No good deed goes unpunished
All helpful urges should be circumvented

Homie2Go

Well I do use the free hosting from 000webhost, but I used to not have a issue at all. Honestly you guys should have to files that are supported, a file that uses less memory like older versions and have a file that is like 2.0.6 that uses more memory but is better.
Any recommends for cheap but good hosting companies?

Kindred

You seem to have missed the point.

SMF did not change anything in the way memory is handled.... which means that the HOST (specifically 000webhost and hosting24 changed something in their setup which caused it to fail.  Since they are oversellers AND misreport on the available memory, there is really not very much that SMF can do... especially since the software seems to work fine on pretty much every other host.

As for hosting...   you get what you pay for (to a point)
You can find some really good hosts for $6 a month..... and some free hosting that is acceptable...   but you will never find a "really good" free host.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Homie2Go

Quote from: Kindred on December 12, 2013, 09:40:56 AM
You seem to have missed the point.

SMF did not change anything in the way memory is handled.... which means that the HOST (specifically 000webhost and hosting24 changed something in their setup which caused it to fail.  Since they are oversellers AND misreport on the available memory, there is really not very much that SMF can do... especially since the software seems to work fine on pretty much every other host.

As for hosting...   you get what you pay for (to a point)
You can find some really good hosts for $6 a month..... and some free hosting that is acceptable...   but you will never find a "really good" free host.
So SMF version 1, and 2.0.6 didn't change the amount of memory needed to process?

Arantor

Correct, the memory use has not changed between 2.0 and 2.0.6, while 1.1.x vs 2.0 will see 2.0 use more memory because of the extra features in 2.0 will require slightly more memory to make happen.

But the fact that we've also seen this occur on 1.1.x does seem to suggest it isn't really an SMF thing...
No good deed goes unpunished
All helpful urges should be circumvented

Kindred

things may have changed between v1.1 and v2.0...   because they are significantly different systems (which is why themes and mods for 1.1.x will not work on 2.0)

On the other hand, as I said... SMF 2.0.x runs just fine on 99.9% of the other hosts....   which really seems to indicate (as we have said) a host issue
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: