Advertisement:

Author Topic: Проблем при администриране и управление на разделите  (Read 4356 times)

Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Здравейте, имам следният проблем. При администриране и управление на разделите след като съм подредил всичко и вляза от друг браузър ми показва разделите които съм направил но в разбъркан ред. Пробвах няколко пъти и ги изтрих и направих отново, но положението е същотот. Когато вляза а админ ми ги показва подредени, но вляза ли от друго място  са разбъркани.Моля, за съвет.

Offline Hristo

  • Jr. Member
  • **
  • Posts: 319
  • Gender: Male
Здравей,
Ще се опитам да те насоча  в правилната посока, но едва ли ще мога да ти помогна директно, защото проблема най-вероятно е извън компетенциите ми.

Дай повече информация:
Версия на СМФ?
Нова инсталация ли е или е стар форум, който е конвертиран и/или прехвърлен от друг хост и всякакви такива?
Има ли инсталирани модове?
Може би най-важния въпрос - имаш ли таблици в InnoDB формат?
Ако не си пробвал, пробвай за всеки раздел първо да го преместиш на друга позиция - запазваш, после го връщаш на желаната му позиция и пак съхраняваш.
Как си с английския? Защото както написах едва ли лично аз ще мога да ги помогна.

Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Здравейте, по ред на въпросите:
SMF 2.06, инсталацията е чисто нова, сега правя първите настройки, не прехвърлям нищо от никъде и инсталацията е чиста- няма модове, нищо.Пробвах и това с разделите и да местя позициите, не стана. Следващото което направих е да изтрия всичко и наново го направих, но пак се разместиха и така :) С английския нямам проблем, потърсих малко информация по въпроса и попаднах на теми които сметнах, че нямат общос моят случай.

Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Сега като погледна как е структорирано подреждането, мисля че това е начинът по който написах разделите първият път след което опитах да ги подредя. И си мисля дали няма някъде нещо като кеш който да е останал и заради това да ги подрежда по този начин.

Offline Hristo

  • Jr. Member
  • **
  • Posts: 319
  • Gender: Male
Кеш има, но едва ли е това. Все пак - отиваш в менюто за профилактика, най-отдолу има бутон за изтриване на кеша на форума.

Първо, да отхвърлим най-тривиалната причина. Знаеш ли как да ги подреждаш? С други думи ползваш ли опцията от ограденото в червено меню?:


Тъй като едва ли е в това причината да се върнем към "Може би най-важния въпрос - имаш ли таблици в InnoDB формат?". Пропусна да отговориш именно на него, затова си мисля, че дори не разбираш какво те питам. В този случай влез от контролния панел на хостинга, който ползваш в phpMyAdmin, в лявото меню кликни върху базата данни на форума ти и виж дали някои от таблиците не са в InnoDB формат. Трябва да видиш нещо като на скрийншота, и да видиш в колоната "Тип" дали някъде/навсякъде вместо MyISAM не е InnoDB:




Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Да знам от къде се подрежда, не мисля че това е проблема. Проверих и в phpMyAdmin за таблицата и всичко си е MyISAM. Сещам се за нещо друго, дали ако не съм дал пермишън примерно чрез FTP-клиента може да се получи това ?

Offline Hristo

  • Jr. Member
  • **
  • Posts: 319
  • Gender: Male
Честно казано идеите ми се изчерпиха, затова е най-добре да отвориш тема в този раздел:
http://www.simplemachines.org/community/index.php?board=147.0

В българския раздел активността е слаба, така че може да се наложи да чакаш много дълго докато се включи и друг, затова най-добре е да отвориш тема там. Дай възможно най-много информация - версията на СМФ, че е нова инсталация без модове, че си местил и връщал позициите им, че си проверил какви са таблиците, ако знаеш на какъв хостинг си - Линуск или Уин, версия на PHP, версия на MySQL и всичко друго, което можеш да добавиш. По този начин ще получиш бързо отговор и вярвам, че ще се намери причината и съответното решение.

П. П. Забравих да питам дали има някакви грешки в лога?

Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Много благодаря за помощта, ще пиша като реша проблема.

Offline @Bogo

  • Jr. Member
  • **
  • Posts: 309
  • Gender: Male
  • SMF 2.0.15
    • Mercedes-Benz forum
Здравейте, имам следният проблем. При администриране и управление на разделите след като съм подредил всичко и вляза от друг браузър ми показва разделите които съм направил но в разбъркан ред. Пробвах няколко пъти и ги изтрих и направих отново, но положението е същотот. Когато вляза а админ ми ги показва подредени, но вляза ли от друго място  са разбъркани.Моля, за съвет.

Здравей,

а кеша на браузъра изтри ли го? За мен проблема е в кеша или на форума или е в браузърите. Проблем нямаш на 99% съм сигурен.

Offline stroitel

  • Semi-Newbie
  • *
  • Posts: 15
Кеша на браузъра не съм трил тъй като влизам от различни браузъри и ситуацията е същата, да кеша на форума беше първото което изтрих. Всичко се оправи когато смених хостинга, оказа се че MySQL версията която ползва хостинга ми има проблем със SMF.