Advertisement:

Author Topic: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!  (Read 5911 times)

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« on: January 28, 2014, 05:23:31 AM »
We've installed a brand new 2.07 forum in a DotEasy forum, using cPanel and their Softaculous software, and could not even add boards. All the permissions are right, as far as we can see. We currently run an older version of SMF, also, and don't have this problem on that site.

After not being able to edit or delete anything, we uninstalled the softaculous installation and did a manual installation.

The same problem exists. We can't add, edit, or delete any boards.

Also, we added the SMF Gallery software, added a category, then tried to edit or delete that, and it's the same problem. We're not allowed to do so.

I've gone over the permissions again and again, and can find nothing amiss. My head admin and I are both Administrators, and we should be able to do ANYTHING, and we can't.

Please help!

Offline Storman™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,027
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #1 on: January 28, 2014, 05:25:32 AM »
Try installing it normally, don't use Softaculous.
Any Backup method is bettter than no Backup method....

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,575
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #2 on: January 28, 2014, 06:10:11 AM »
After not being able to edit or delete anything, we uninstalled the softaculous installation and did a manual installation.

The same problem exists. We can't add, edit, or delete any boards.

Try installing it normally, don't use Softaculous.

looks like they did...

sounds like your database does not proper permissions granted so it can write/insert new lines.

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #3 on: January 28, 2014, 06:17:33 AM »
I just couldn't understand from your post, what's the error that you get?
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #4 on: January 28, 2014, 01:11:11 PM »
It just says we are not allowed to edit the forum in just about any way!

I've installed several other test forums in other directories, to see if they have any problems, and every one of them is just fine.

I've been running SMF forums for 7 years, now, and have never had this problem before. Always the forums have simply installed and run as they should, with no problems, whatsoever!

I think we'll wipe and try one more time, and I'll take screenshots if there are any problems once again, and come back here and post.

Offline Storman™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,027
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #5 on: January 28, 2014, 01:48:30 PM »
Have you done what Ilori said and checked the permissions of the database user ? Simple creating a database user isn't enough, they must also have permission to write to the database.
Any Backup method is bettter than no Backup method....

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #6 on: January 28, 2014, 02:57:48 PM »
I'm not sure how to check the permissions of the DB user. I've never had to do that before. I haven't had to do anything other than set up the other forums (7 different ones).

I set up the SMF 2.0.7 forum myself this time, using a completely different database name and directory, and made sure I am the owner and admin. I get the same results.

Within the forum, I have Administrator status, and am, indeed, the only user. Administrators should be able to do anything.

I was able to change the name of the initial forum, and remove the SMF post. No problems.

I was able to add a second forum within that same category. No problems.

I tried to modify the category, and got the DotEasy error page, that says Error #403.

I tried to add a new category, and got the DotEasy error page, that says Error #403.

I checked the SMF Error Log, which says there were none.



I'm going to leave the installation as it is and enter a ticket with DotEasy, to see what they say.



In the meantime, I'm going to upload a 2.0.6 version to a different directory, and see how that goes.

Offline Storman™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,027
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #7 on: January 28, 2014, 03:07:11 PM »
Quote
I'm not sure how to check the permissions of the DB user. I've never had to do that before. I haven't had to do anything other than set up the other forums (7 different ones).

When you installed SMF you would have needed to enter the details of the database and the database user/password. How did you originally create that database and user ?

Any Backup method is bettter than no Backup method....

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,063
  • Gender: Male
    • Kindred-999 on GitHub
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #8 on: January 28, 2014, 03:59:04 PM »
AH HA!!!!!!!!

The issue with categories defines your problem.

your host has mod_security active and poorly configured. ask them to turn it off.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #9 on: January 28, 2014, 05:40:18 PM »
Kindred--it might be that, but I think I actually figured out the problem. I'll know soon.

I think that when we created our admin user for the database, neither of us knew that we had to set the access permissions! On our old server, we didn't have to do that.

I'm in the middle of installing 2.0.6 right now...doing the CHMOD stuff by ftp just to make sure it's all done.

Once I find out whether or not the forum works correctly with 2.0.6, I'll update immediately to 2.0.7. I think everything will be fine. At least I'm crossing all my fingers and toes! ;)

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #10 on: January 28, 2014, 05:58:21 PM »
Quote
AH HA!!!!!!!!

The issue with categories defines your problem.

your host has mod_security active and poorly configured. ask them to turn it off.

OK...that didn't work. The server wouldn't let me run the 2.0.6 installer script at all, and gave me an error #404, which corresponds to the #403 error.

I tried once more with 2.0.7, making sure to use my full access user name, and...nope...still can't edit.

So I think you're right, Kindred. I will add to the ticket I've already placed with DotEasy, quoting your answer, and see what they say.

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #11 on: January 29, 2014, 01:06:16 PM »
A note from the DotEasy support staff from three hours ago:

Quote
Hello Linda,

We have escalated the case to our server admin to make the necessary adjustments to mod_security. We will get back to you via this case ticket shortly.

Here's hoping that "shortly" means sometime today!

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed! (RESOLVED)
« Reply #12 on: January 29, 2014, 03:41:45 PM »
DotEasy has now made the necessary adjustments to the mod_security script, and all is well. Thank you so much, Kindred, for correctly identifying the issue. :)

Offline a10

  • Charter Member
  • Sr. Member
  • *
  • Posts: 844
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #13 on: January 30, 2014, 05:14:18 AM »
Good job by that host, I'll remember DotEasy if one day I need to switch host.
2.0.15, ssl, php 7.1.25, MySQL 10.1.30-MariaDB-1~xenial
Mods: Contact Page, Like Posts, Responsive Curve, Search Focus Dropdown.

Offline lindawing

  • Semi-Newbie
  • *
  • Posts: 59
  • Gender: Female
    • Neighborly Sims
Re: Installed Brand New 2.07 Forum--No Editing of Forum Allowed!
« Reply #14 on: January 30, 2014, 01:27:49 PM »
DotEasy always has about the best customer service around. No matter what problem you might have at any given point (and there are always going to be some, no matter what service you use), they are totally prompt, efficient, and knowledgeable. They pay attention to your needs and actually read your notes and answer sensibly.

I have been using them since 2003, and absolutely love them! No way would I ever switch!