• Welcome to Simple Machines Community Forum. Please login or sign up.
September 24, 2021, 03:08:36 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


New member's moderated posts don't generate topic subscription notifications.

Started by medicMe, January 28, 2014, 08:01:29 AM

Previous topic - Next topic

medicMe

Not sure if this is a known bug or not but:

New member's moderated posts don't generate topic subscription notification emails once approved by a mod.

So, upon approval, new post appears on the topic to other members and the public, but no email notifications are sent out to people subscribed to said topic.

This makes life hard for new members who signed up just to bump an old topic with a question.. since even if their post is approved, unless other members happen to notice the new post while browsing the board, they won't be notified of the new post.

margarett

It should be notifying, as least I can see that much in the code...

I have no email in my test setup, so I can't try any further.

But, please remember that the member must have chosen to receive said notifications: Profile --> Notifications --> For topics and boards I've requested notification on, notify me of:
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

medicMe

Quote from: margarett on January 28, 2014, 09:12:09 AM
It should be notifying, as least I can see that much in the code...

I have no email in my test setup, so I can't try any further.

But, please remember that the member must have chosen to receive said notifications: Profile --> Notifications --> For topics and boards I've requested notification on, notify me of:

I can assure you that the users are set to get notifications via email on a new post for a thread, and do so when a non-moderated post (a regular member's post that doesn't need moderation before updating the thread) bumps the thread.. it's really just the posts that are held back pending a moderator's approval that do not trigger an email notification once approved and public.

I don't get any errors in SMF about it, nor in my PHP / Apache log... and it's not an email server problem since all other notification emails are sent out as expected.


Arantor

No good deed goes unpunished
All helpful urges should be circumvented

medicMe


Advertisement: