• Welcome to Simple Machines Community Forum. Please login or sign up.

[SOLVED] {$member.link} doesn't work?

Started by Krillin, February 10, 2014, 12:54:40 AM

Previous topic - Next topic

Krillin

February 10, 2014, 12:54:40 AM Last Edit: April 23, 2014, 03:49:47 PM by Krillin
Today I sent out an e-mail to my community's members. I have searched these forums for the {$member.link} option and I did not find anything for results but "members" and "links" in them and I do not have time to search through 50 pages or more for this specific problem. If it has been answered or solved then I am sorry for this duplicate problem please just point me to a solution. Then perhaps the search functions needs to be address for better specific results? IDK.

But the problem is in the news letter I input the following message:
Quote from: SMF News Letter InputDear {$member.name},

We regret to report to all of our current members about an incorrect settings with our e-mail system within the forums. Due to changes in our web hosting company's policy the forum e-mails have not been getting out for who knows how long?! As we were not notified of these changes ourselves.

So members like, {$member.name}, may be surprised to find you have notifications waiting for you but you were not notified due to the notification e-mail not getting out to be delivered. The link we are providing is directly to your account profile, {$member.link}, to check for any pending notifications you may have missed.

Today we have corrected and tested this issue to be working. But this is an alert to give you a heads up about anyone with pending messages or other notifications (post replies, subscriptions, private messages, etc.). So we are asking all members to get in there and check their account accordingly.

We are sorry for this mishap even though this was out of our realm of control. But we are sincerely sorry about none of the notification e-mails getting out to forum members.

Regards,
The Krillin's World Gaming Community Team.

{$board_url}

Only to have produced this output to e-mail:
Quote from: Actual E-Mail ReceivedDear Krillin,

We regret to report to all of our current members about an incorrect settings with our e-mail system within the forums. Due to changes in our web hosting company's policy the forum e-mails have not been getting out for who knows how long?! As we were not notified of these changes ourselves.

So members like, Krillin, may be surprised to find you have notifications waiting for you but you were not notified due to the notification e-mail not getting out to be delivered. The link we are providing is directly to your account profile, Krillin, to check for any pending notifications you may have missed.

Today we have corrected and tested this issue to be working. But this is an alert to give you a heads up about anyone with pending messages or other notifications (post replies, subscriptions, private messages, etc.). So we are asking all members to get in there and check their account accordingly.

We are sorry for this mishap even though this was out of our realm of control. But we are sincerely sorry about none of the notification e-mails getting out to forum members.

Regards,
The Krillin's World Gaming Community Team.

http://www.krillinsworld.us/forum/index.php

So why is it the {$member.link} did not give the member their profile link? Something tells me this is a misfire in the building of the member link? Because as you can see, this should have produced the member's link and not the {$member.name} as seen above.

Quote from: News Letter Help MenuIn this message you can use a few "variables". These are:
{$board_url} - The URL to your forum.
{$current_time} - The current time.
{$member.email} - The current member's email.
{$member.link} - The current member's link.
{$member.id} - The current member's id.
{$member.name} - The current member's name. (for personalization.)
{$latest_member.link} - The most recently registered member's link.
{$latest_member.id} - The most recently registered member's id.
{$latest_member.name} - The most recently registered member's name.

Forum Version is SMF 2.0.7.
Using the following MODS:
Bots VS Browsers 1.2 (Author of)
Advanced Login Form 1.2.2
EmailValidator 1.0
Birthday On Register 1.0
notCaptcha 1.06.2

Best Regards,
Krillin
Gaming Community Web Site
Forums Use: SMF 2.0.18
Mods Installed: (NONE)
Browser: Chrome

shadow82x

In order to use that function you'll need to select "Send in HTML format. (with this you can put normal HTML in the email.)" when sending newsletters. HTML is required to parse {$member.link} since its hyperlinking a profiles name.
Colin B
Former Spammer, Customize, & Support Team Member

Krillin

Quote from: mcblaber on February 10, 2014, 03:20:36 AM
In order to use that function you'll need to select "Send in HTML format. (with this you can put normal HTML in the email.)" when sending newsletters. HTML is required to parse {$member.link} since its hyperlinking a profiles name.
If this were the case, then why did {$board_url} parse but not {$member.link}? If I also recall, these messages were sent out as HTML so again, this is not a solution, just another stall tactic?

Best Regards,
Doc
Gaming Community Web Site
Forums Use: SMF 2.0.18
Mods Installed: (NONE)
Browser: Chrome

Kindred

What?   What do you mean by "just another stall tactic"?
You seem to have come in with a major chip of your shoulder, with your original post.. And with your response.
Saying "I don't feel like searching any more" and criticizing the site is really not a good way to encourage others to help you...
I suggest that you try moderating your tone and maybe others might be interested in helping you

As I read it, mcblabber answered your post 3 hours after you posted....  And then you came  back 3 weeks later.

You also say, "if you recall" ...  So, why don't you try sending out another test, with the checked off "send in HTML" box and see if it works.

If it still fails, then we'll look into it further....  Like possibly, what mods you have installed?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Krillin

Quote from: Kindred on March 02, 2014, 07:45:50 PM
What?   What do you mean by "just another stall tactic"?
You seem to have come in with a major chip of your shoulder, with your original post.. And with your response.
Saying "I don't feel like searching any more" and criticizing the site is really not a good way to encourage others to help you...
I suggest that you try moderating your tone and maybe others might be interested in helping you

As I read it, mcblabber answered your post 3 hours after you posted....  And then you came  back 3 weeks later.

You also say, "if you recall" ...  So, why don't you try sending out another test, with the checked off "send in HTML" box and see if it works.

If it still fails, then we'll look into it further....  Like possibly, what mods you have installed?

Excuse me? I am not one who is "politically correct" I am going to speak my mind and don't care if anyone is offended by my words, cause frankly, it is all about "local interpretation." I mean no offence in my findings or means of finding a solution. When I suddenly get busy from running my IT business, I am through in my findings and report them as I have done above. But based on this bull due to "local interpretation" is nonsense and nonproductive. My personality is one who is laid back, observant, shy and very out-spoken. But the fact is, I am holding back what I would really like to say because it is irrelevant. Even the fact that I have to explain myself is nonsense. But it appears to me as if you take things too personally.

"..a stall tactic..": means of diverting or putting off, etc.

"..I do not feel like searching anymore..": means I have spent more than enough time searching for a solution but came up with zilch.

"...if I recall..": means I am pretty sure I sent out an "HTML" version of the e-mail. As it appears the {$board_url} converted but not the feature of this topic?!

As for trying McBlaber's solution: I am trying not to disturb my members with such nonsense. When I have a mass message I want to broadcast, then I shall try it. Otherwise, I'll get to it when I can. If 3 days, 3 weeks, 3 months or 3 years then so be it. My game servers come 2nd to my business, website is 3rd. Especially with responses like this. I have to deal with VALVe for my game servers. I really do not need any more crap than I have to deal with.

You say I need to moderate my tone? This is all text, in plain old black and white, digital bits, no voice therefor there isn't any tone. It is all about "local interpretation" nothing more, nothing less.

I only sent a "newsletter" to the Administrators (Me and My wife). When the e-mail arrives, I will report back with the results.

Best Regards!
Gaming Community Web Site
Forums Use: SMF 2.0.18
Mods Installed: (NONE)
Browser: Chrome

Kindred

Or maybe your email client removed the link?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Krillin

It seems to have worked. I guess what I thought I did, did not happen?  :-\

The results:
http://www.krillinsworld.us/forum/index.php - The URL to your forum.
April 23, 2014, 03:15:15 PM - The current time.
krillinsworld@yahoo.com - The current member's email.
Krillin - The current member's link.
1 - The current member's id.
Krillin - The current member's name. (for personalization.) <--- This is a link
imzurcboi - The most recently registered member's link.
388 - The most recently registered member's id.
imzurcboi - The most recently registered member's name. <--- This is a link.

Regards,
The Krillin's World Gaming Community Team.

http://www.krillinsworld.us/forum/index.php

Not sure if the 2.0.7 update may have fixed a broken file as I have been seeing a lot undefined errors pointing to lines in files lately. IDK, we will see here soon enough.  ???

Thank you for your patience and being patient.

Best Regards,
Krillin
Gaming Community Web Site
Forums Use: SMF 2.0.18
Mods Installed: (NONE)
Browser: Chrome

Advertisement: