Advertisement:

Author Topic: Решение за ъпдейт, ако сте на бета версия  (Read 21038 times)

Offline @Bogo

  • Jr. Member
  • **
  • Posts: 309
  • Gender: Male
  • SMF 2.0.15
    • Mercedes-Benz forum
Здравейте,

от доста време бях на версия SMF 2.0 RC4 поради доста причини, най-вече заради някой модове. реших преди няколко дена да направя ъпдейт, но удари на камък, какви ли не начини не опитах, но в крайна сметка намерих решение.
Направих ръчно промените по php файловете и минах по този начин на версия SMF 2.01 и от там беше вече лесно през администрацията направих до последната версия с няколко клика на мишката.

Моето лично мнение е, ако можете вкарвайте код, не използвайте модули, защото не се знае до коя версия ще ги поддържа разработчика им. В тази насока работя вече, за да нямам бъдещи изненади.

Offline @Bogo

  • Jr. Member
  • **
  • Posts: 309
  • Gender: Male
  • SMF 2.0.15
    • Mercedes-Benz forum
Re: Решение за ъпдейт, ако сте на бета версия
« Reply #1 on: February 22, 2014, 04:25:59 PM »
Не се разминах само с това, имаше разлика в доста файлове във версиите им. Днес цял ден съм си играл да оправя и този проблем. Грешката е изцяло моя, доста версии бях изостанал поне 7.

Offline Hristo

  • Jr. Member
  • **
  • Posts: 319
  • Gender: Male
Re: Решение за ъпдейт, ако сте на бета версия
« Reply #2 on: February 22, 2014, 05:57:01 PM »
На тест форума ми имах над 100 инсталирани мода и въпреки това рядко имаше конфликт при инсталиране на нова версия, а когато имаше най-често лесно се решаваше проблема. Общо взето почти всички модове, които са съвместими с версиите над RC3 работят без проблем с най-новите. Понякога може да се наложи дребни промени на ръка, но това не е болка за умиране. Та, кои са били модовете (ако са от официалните), които са те възпирали да ъпгрейдваш?

Offline @Bogo

  • Jr. Member
  • **
  • Posts: 309
  • Gender: Male
  • SMF 2.0.15
    • Mercedes-Benz forum
Re: Решение за ъпдейт, ако сте на бета версия
« Reply #3 on: February 23, 2014, 05:10:54 AM »
Здравей Христо,

в самото начало бях на SMF 1.19 без да използвам никакви модули, чиста инсталация   след което направих ъпдейт до версия на SMF 2.0 RC1 и се започна едно търсене на модули и тяхната инсталация. :) Да ти кажа честно, нямам на идея колко съм тествал, но на форума не бяха повече от 10 от който реално се използваха 2-3. :) Според мене е най-добре, слагай код ръчно не използвай модулите, има две причини, какви промени правят по ядрото на SMF, поддръжката на разработчика не се знае до кога ще е. Вярно форума поддържа емулация на версията, но това не е решение.


Поздрави!