News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

SMF Caching & Memcached unix socket issue

Started by digger, June 16, 2014, 08:39:03 AM

Previous topic - Next topic

digger

SMF function get_memcached_server() don't work with socket address like unix:///any/socket:0

ziycon

Can you give any more information, you'll need to supply information of when and where it occurred and steps to replicated if possible, are there any other error messages or warnings?

digger

Quote from: ziycon on June 16, 2014, 10:48:59 AM
Can you give any more information, you'll need to supply information of when and where it occurred and steps to replicated if possible, are there any other error messages or warnings?

1) Install memcached and set up it to use unix socket.
2) Go to Admin - Server Settings - Caching, enable cache and set Memcached settings to your Memcached socket (unix:///path/socket:0).
3) Go to Admin - Logs and see Memcached errors.


ziycon


digger

Quote from: ziycon on June 16, 2014, 11:06:18 AM
Can you paste the exact errors please?
memcache_connect() expects parameter 2 to be long, string given

Arantor

Sockets are not supported. I'm not sure this is technically a bug.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

digger

Quote from: ‽ on June 16, 2014, 11:25:27 AM
Sockets are not supported. I'm not sure this is technically a bug.
It just needs to modify a few lines in this function to make it work with sockets too.

Arantor

Then by all means suggest the changes and it can be supported in 2.1...
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

Advertisement: