Advertisement:

Author Topic: I have an issue with cookies and I cannot login as an admin anymore.  (Read 7164 times)

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
I don't know what I did, but I installed a new theme and now I cannot login or save anything. I keep getting this when logging in
 
Quote
Sorry, but you've reached your login attempts threshold. Please wait 30 seconds and try again later.
When I did have access it would give me an error "Session verification failed. Please try logging out and back in again, and then try again.", When I try to login I go to a blank page. Also, when I tried to save settings or something, the next page would be blank.
Repair settings does not work, I tried changing the cookie multiple times now.

www.dnmodz.com

Offline Ninja ZX-10RR

  • SMF Hero
  • ******
  • Posts: 2,149
  • Gender: Male
  • Sniper Legends
    • Flavio93Zena on Facebook
    • Virtual Interactive Games Entertainment Forum
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #1 on: July 22, 2014, 02:51:43 AM »
Try to simply clear the cookies and the cache...
Then http://wiki.simplemachines.org/smf/Administration_-_I_accidentally_lost_my_admin_account!_What_can_I_do, try this one and see if you can manage to remove that theme or either http://wiki.simplemachines.org/smf/Backup ;)
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.
♥ Jess ♥

STOP EDITING MY PROFILE

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #2 on: July 22, 2014, 03:00:16 AM »
Here's the issue, I do have access to the admin account, it's just SMF that won't let me login. It just either goes to blank page or gives me a "Try waiting 30 seconds to login again" error. The theme is the default curve. I haven't made a back up since 1~ month ago, but that's far, wouldn't posts get lost?

Offline Ninja ZX-10RR

  • SMF Hero
  • ******
  • Posts: 2,149
  • Gender: Male
  • Sniper Legends
    • Flavio93Zena on Facebook
    • Virtual Interactive Games Entertainment Forum
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #3 on: July 22, 2014, 03:15:41 AM »
Your answer suggests that you didn't read the second link I provided, if I linked it well there is a reason for it mate, the reason is that backing up would not affect your POSTS but only the rest.
Also
I do have access to the admin account
and
it's just SMF that won't let me login.
are a bit contradictory :P
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.
♥ Jess ♥

STOP EDITING MY PROFILE

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #4 on: July 22, 2014, 03:19:54 AM »
As in this, maybe it's a little confusing. An admin account is there on the server, I cannot access it, not because I forgot my pass/deleted/or lost it, it's because SMF is giving me an error after I input my username and password. As for a back up, posts, information, and simple things stay right? Except uploads and images?

Offline Justyne

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,410
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #5 on: July 22, 2014, 03:28:22 AM »
Assuming it's just theme.. try this

YOUR_URL/index.php?action=theme;sa=pick;u=1;theme=1

That should let you see the default theme and you might be able to log in then.


If not, repair settings is your friend. Maybe you are doing something wrong there.

http://wiki.simplemachines.org/smf/Repair_settings.php

You can change the theme there.

If you could let us know what settings you see when you open repair we might be able to assist better and tell you which one is skewed.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #6 on: July 22, 2014, 04:01:38 AM »
These are my screen shots.
 

Offline Justyne

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,410
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #7 on: July 22, 2014, 04:06:11 AM »
Have you tried renaming your cookie yet?

Also, Maintenance mode is on. That should not stop you logging as an admin but it would stop you as a member - though usually with a different error message.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #8 on: July 22, 2014, 04:12:24 AM »
I tried everything. I tried changing the cookie name, nothing shows up in the error logs, or maybe I'm reading them wrong. Where do they start? Most recent in the first page of phpmyadmin or the back page?

Offline Ninja ZX-10RR

  • SMF Hero
  • ******
  • Posts: 2,149
  • Gender: Male
  • Sniper Legends
    • Flavio93Zena on Facebook
    • Virtual Interactive Games Entertainment Forum
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #9 on: July 22, 2014, 04:21:43 AM »
Again I would use a backup file before/after the last installed mod... So everything would restore and posts would be untouched...
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.
♥ Jess ♥

STOP EDITING MY PROFILE

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #10 on: July 22, 2014, 04:39:35 AM »
Ok so do you recommend this? I Replace all SMF files with a clean one and reinstall all the themes and extra stuff, and reconnect to the mySQL database? Will that work?

Offline Justyne

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,410
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #11 on: July 22, 2014, 05:27:12 AM »
Since you seem to be able to log in sometimes for a bit?

Admin CP, Server Settings > Cookies and Sessions

Enable local storage of cookies - unchecked


Usually SMF handles cookies better than the broswer.

I still don't understand though how this issue could have occurred through installation of a new theme.

Sure there werent any new mods or something you are forgetting?
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #12 on: July 22, 2014, 05:41:47 AM »
None of this could be cause by a duff theme...

One of these should be selected, in Server Settings:

Enable local storage of cookies
(SSI won't work well with this on.)
 
Use subdomain independent cookies
(turn off local cookies first!)


But, obviously, not both.

If you're OK with sending me a PM with your login details, after reading THIS, I could take a look, for you.

Before you do that, though, it might be that just using a different browser will get you in.

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #13 on: July 22, 2014, 05:42:01 AM »
I uninstalled simpleportal, and nothing came up unsuccessful beforehand when I ran the uninstall.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #14 on: July 22, 2014, 05:46:34 AM »
Ah... How long ago did you do that?

I notice something rather odd...

"SMF 2.0.6 | SMF© 2011 l Simple Machines lDzinerStudio - Inferno Theme"

Even if you're using the default "Curve" theme. That says "We have a cockup, somewhere", to me...

('course, upgrading to v2.0.8 is a Good PlanTM...)

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #15 on: July 22, 2014, 05:51:20 AM »
That was part of simple portal I think, I made a footer because the previous theme got rid of the SMF footer due to space.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #16 on: July 22, 2014, 05:55:52 AM »
I have your details and I'm having a butcher's. Gimme a few minutes...

"Sorry, but you've reached your login attempts threshold. Please wait 30 seconds and try again later." is causing me to have to wait, though.

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #17 on: July 22, 2014, 05:58:12 AM »
That always shows up, it doesn't matter. Those 30 seconds are infinite! The error message shows up everywhere.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #18 on: July 22, 2014, 05:58:56 AM »
Could be a symptom.

I just sent you a PM, coz it's saying the password's wrong. :(

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #19 on: July 22, 2014, 06:08:18 AM »
Oh, joy...

Put the login details in, hit "Log in" and I'm getting a blank screen. Tried six different browsers, too. :(

I wonder if we have one of those weird coincidences, here... Just as you did your theme and stuff, I wonder if, at exactly the same time, your host did something to their server?

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #20 on: July 22, 2014, 06:11:19 AM »
Well do you think re uploading the main files would work? Does it have to do with anything on mysql? I dont think it's the users cookies. I hope not.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #21 on: July 22, 2014, 06:17:37 AM »
Difficult to tell, from what little I can see.

If I was in your boat, I'd contact the host, first, to see if they've changed anything.

If they haven't, I'd restore the last backup OF THE SOFTWARE (Not the database) that I have. (Assuming you have one)

If that doesn't work, I'd try this:

http://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #22 on: July 22, 2014, 06:36:10 AM »
Oh my GOD! It's back! thank you thank you thank you! All of you.

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #23 on: July 22, 2014, 06:46:12 AM »
WooHoo!

What did you do?

Offline mani123

  • Semi-Newbie
  • *
  • Posts: 49
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #24 on: July 22, 2014, 06:57:46 AM »
I did the restoration of the main files. I followed that last link you sent. :)

kat

  • Guest
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #25 on: July 22, 2014, 07:31:04 AM »
Might come in handy, for others, you see...?

WoOt!

Offline Ninja ZX-10RR

  • SMF Hero
  • ******
  • Posts: 2,149
  • Gender: Male
  • Sniper Legends
    • Flavio93Zena on Facebook
    • Virtual Interactive Games Entertainment Forum
Re: I have an issue with cookies and I cannot login as an admin anymore.
« Reply #26 on: July 22, 2014, 02:06:30 PM »
As a footnote, the restore you did was the first thing I had suggested... But glad that it worked.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.
♥ Jess ♥

STOP EDITING MY PROFILE