Advertisement:

Author Topic: Post and PM Inline Attachments  (Read 176250 times)

Offline njtweb

  • Jr. Member
  • **
  • Posts: 380
Re: Post and PM Inline Attachments
« Reply #800 on: June 12, 2018, 01:50:09 PM »
Is there a setting so that when an image is clicked on it cannot be downloaded? I have the download line and counter setting set to disabled but if an image is clicked on it still downloads.

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 411
  • Gender: Female
Re: Post and PM Inline Attachments
« Reply #801 on: June 12, 2018, 07:30:06 PM »
Is there a setting so that when an image is clicked on it cannot be downloaded? I have the download line and counter setting set to disabled but if an image is clicked on it still downloads.
Not in this mod - it simply allows images to be displayed within the text of a message/PM.

Offline njtweb

  • Jr. Member
  • **
  • Posts: 380
Re: Post and PM Inline Attachments
« Reply #802 on: June 13, 2018, 09:23:51 AM »
Well that's odd, seems like it's something that was missed. I guess I can't use it then.

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 411
  • Gender: Female
Re: Post and PM Inline Attachments
« Reply #803 on: June 13, 2018, 02:47:06 PM »
Well that's odd, seems like it's something that was missed. I guess I can't use it then.
I’m not sure why you think it - it’s function matches it’s description.

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
Re: Post and PM Inline Attachments
« Reply #804 on: June 19, 2018, 05:56:12 AM »
Getting this error a lot, does anyone know what it means?

Guest
IP address 120.154.2.185   
June 14, 2018, 05:52:22 AM
58dcdbc75b862015e29f15060a85985c
Type of error: Undefined
https://reformaps.org/forum/index.php?action=search2
8: Undefined index: href
File: /home2/reformaps/public_html/forum/Themes/default/languages/InlineAttachments.english.php (body_above sub template - eval?)
Line: 440

Offline Gryzor

  • Sr. Member
  • ****
  • Posts: 769
  • Gender: Male
  • CPCwiki.eu - The Amstrad CPC Encyclopaedia!
    • CPCWiki
Re: Post and PM Inline Attachments
« Reply #805 on: June 19, 2018, 06:08:26 AM »
I still can't make it work... this has been happening for the several last version now - when I click 'insert' nothing whatsoever happens :(

Anybody has an idea as to what to check?

Thanks!

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 411
  • Gender: Female
Re: Post and PM Inline Attachments
« Reply #806 on: June 19, 2018, 06:37:04 AM »
Getting this error a lot, does anyone know what it means?

Guest
IP address 120.154.2.185   
June 14, 2018, 05:52:22 AM
58dcdbc75b862015e29f15060a85985c
Type of error: Undefined
https://reformaps.org/forum/index.php?action=search2
8: Undefined index: href
File: /home2/reformaps/public_html/forum/Themes/default/languages/InlineAttachments.english.php (body_above sub template - eval?)
Line: 440
Try enabling the "Disable evaluation of templates" setting in Server Settings to see if you can get a more meaningful error message - the file ./Themes/default/languages/InlineAttachments.english.php only has 26 lines and the error is being generated elsewhere.

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 411
  • Gender: Female
Re: Post and PM Inline Attachments
« Reply #807 on: June 19, 2018, 06:39:25 AM »
I still can't make it work... this has been happening for the several last version now - when I click 'insert' nothing whatsoever happens :(

Anybody has an idea as to what to check?
Not really - it could be a Javascript conflict with another mod.

Are you able to get it working on a test forum that doesn't have any other mods installed?

Offline Gryzor

  • Sr. Member
  • ****
  • Posts: 769
  • Gender: Male
  • CPCwiki.eu - The Amstrad CPC Encyclopaedia!
    • CPCWiki
Re: Post and PM Inline Attachments
« Reply #808 on: June 19, 2018, 06:44:19 AM »
Hm, no. A conflict is what I thought, too, but the problem appeared out of the blue - not some mod I installed. I think I had just updated this one.

I'm pretty sure it'd work fine on a test forum with no other mods, so it's potentially a useless exercise though?

I'll see if I can further reduce the amount of mods I'm using; I was wondering though if there was some concrete method to find where the error is generated...

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 411
  • Gender: Female
Re: Post and PM Inline Attachments
« Reply #809 on: June 19, 2018, 06:50:35 AM »
Hm, no. A conflict is what I thought, too, but the problem appeared out of the blue - not some mod I installed. I think I had just updated this one.

I'm pretty sure it'd work fine on a test forum with no other mods, so it's potentially a useless exercise though?
If you think it's not caused by a mod conflict then installing it on a forum on the same host that no other mods installed will confirm it's not a hosting-related issue.

Quote
I'll see if I can further reduce the amount of mods I'm using; I was wondering though if there was some concrete method to find where the error is generated...
Are you actually getting any error messages?

Offline Gryzor

  • Sr. Member
  • ****
  • Posts: 769
  • Gender: Male
  • CPCwiki.eu - The Amstrad CPC Encyclopaedia!
    • CPCWiki
Re: Post and PM Inline Attachments
« Reply #810 on: June 19, 2018, 06:52:07 AM »
Forgot to mention that - apologies. No, there are no error messages...

Offline demlak

  • Jr. Member
  • **
  • Posts: 160
Re: Post and PM Inline Attachments
« Reply #811 on: June 20, 2018, 07:30:58 PM »
any idea how to convert old postings in smf_messages table to match this mod with old postings made with this old mod?
https://www.simplemachines.org/community/index.php?topic=376767.0

just replacing
                                                                      [attachimg=
with
                                                                      [attachment=
would not do the trick for example on
                                                                      [attachment=1 width=750 align=center]


also matching with regex like:
                                                                      perl -pE 's/\[attachimg=(\d+).*?\]/[attachment=$1]/'
does not reflect alignment.