• Welcome to Simple Machines Community Forum. Please login or sign up.

Upgrade von 1.1.20 auf 2.0.9 geht nicht

Started by morle800, October 20, 2014, 03:16:31 AM

Previous topic - Next topic

morle800

Moin

beim Versuch das SMF 1.1.20 auf 2.0.9 zu upgraden hängt sich der Vorgang beim Konvertieren der Datenbank auf. Irgendwann gehts weiter und man kann es fertigstellen. Auf den erstem Blick scheint dann alles ok zu sein. Aber die Beiträge sind dann alle da, nur die Inhalte fehlen. Hat einer ne Idee?

LG

Justyne

Nur um hier bei der Formulierung mitzukommen, die Threads/Topics und Posts sind da aber der Inhalt derer ist leer?

Hast du mal in der DB nachgeschaut ob die Daten dort vorhanden sind?
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Die Daten beim 1.1.20 sind alle korrekt. Nur nach dem Upgrade halt nicht

Quote...Threads/Topics und Posts sind da aber der Inhalt derer ist leer...

Ja ganz genau.

Justyne

Kannst du mal bei PHP-MyAdmin oder dem Equivalent deines Hosts in der Tabelle smf_messages nachschauen was da an Daten vorhanden ist?

Das macht einen Unterschied ob die Daten dort vorhanden sind und "nur" inkorrekt angezeigt werden oder ob sie da auch fehlen.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Die Daten werden nicht übernommen, sind also auch nicht in der DB

Justyne

Das ist aber sehr seltsam.

Gibt es ein backup vom 1.1.20er Forum?

Und das würde ich mir gerne selbst mal anschauen in PHP-MyAdmin. Wenn du magst schmeiß mir mal eine PM mit login Daten rüber-
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Ja das Backup habe ich wieder eingespielt. Phpmyadmin habe ich nicht, ich gehe direkt übern Server drauf.

Justyne

Irgendwas musst du doch in deinem Hostingaccount haben damit man sich die DB mal anschauen kann.

Hat dein Host kein Cpanel oder sowas in der Art?
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Hier ist das gespiegelte Forum
Will nicht wieder auf 2.0.9 uppen, bis ich ne "Idee" habe wie die Konvertierung durchläuft

Justyne

Wenn du penetrant ignorierst was ich dir sage kann ich einfach nicht helfen. Das gespiegelte 1.1.20 sagt mir so erstmal gar nichts.

Was ich brauche ist wie die DB aussieht nachdem das upgrade script gelaufen ist.

Das Forum Interface ist dafür leider nicht ausreichend.

Dein Problem hört sich nach encoding an (Bauchgefühl), sprich die Daten sind in der DB vorhanden werden aber als leere Posts angezeigt. Allerdings ist raten keine sinnvolle Supportstrategie.

Du musst mir schon die Daten geben die ich brauche um irgendwas festzustellen.

Lass das upgrade mal auf deinem Spiegel laufen. Wenn du echt kein Cpanel/PHP my admin oder ähnliches hast, dann lade mal ein komplettes DB backup herunter und wir schauen uns dann die Daten in einem Texteditor an.

Solange wir nicht wissen was bei der DB Umwandlung schiefgeht können wir das auch nicht beheben.

Du kannst nach dem upgrade mal probieren alles nach UTF-8 zu konvertieren. Das hilft manchmal.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Ich ignoriere nicht, vor allem nicht penetrant :o Ich sitze nur nicht permanent am Rechner. Wede nachher nochmal das Upgrade versuchen. Kann die DB gerne zur Verfügung stellen.

Justyne

Dann sag das doch :-) Das ist doch absolut kein Problem. Du glaubst nicht wie oft Leute einfach das wonach man fragt überlesen und dann verzweifeln weil keiner helfen kann. Da geh ich lieber mal auf Nummer sicher dass die Leute wissen was gebraucht wird damit es weitergehen kann.

Meine englischen Kollegen meinen 1.1.20 -> 2.0.8 und dann von 2.0.8 nach 2.0.9 über Paketmanager hat bei ähnlichen (aber nicht identischen) Fällen auch schonmal geholfen.

Wenn alle Stricke reissen können wir das auch mal probieren - aber soweit sind wir noch nicht.

Denke dass ist nur eine encoding Einstellung irgendwo. 
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

So Update gemacht, Beiträge wieder weg.

Hab die Datenbank nun über ein integriertes phpmyadmin offen. Willst über TeamViewer draufschauen?
Dieses mal scheinen die Beiträge in der DB da zu sein

Justyne

Ja, ich würde gerne mal draufschauen.


Beiträge in der DB da ist ein gutes Zeichen. Super.

Kannst du mal schauen was die DB in phpMyadmin für eine collation hat und was in settings.php hinterlegt ist?
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

Also wenn ich in den Beiträgen auf editieren gehe, sind sie da  :o :o :o


Justyne

Okay... und Settings.php hat die gleiche? SMF macht schonmal lustige Sachen wenn das nicht übereinstimmt.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800

In der settings kann ich nur German finden

Justyne

Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

morle800


Advertisement: