Advertisement:

Author Topic: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().  (Read 5973 times)

Offline KosiMazaki

  • Semi-Newbie
  • *
  • Posts: 14
Witam serdecznie

Nie mogę sobie poradzić z namierzeniem i naprawą błędu jaki mi się pojawia w error_log po aktualizacji z 2.0.8 na 2.0.9. Otóż pojawia się takie coś:

[30-Nov-2014 11:28:50] PHP Fatal error:  Cannot redeclare template_quotefast() (previously declared in /home/forum/public_html/Sources/Load.php(2152) : eval()'d code:25) in /home/forum/public_html/Sources/Load.php(2152) : eval()'d code on line 1001

Po przełączeniu DisableTemplateEval "1" tak jak tu napisano w myAdmin jest teraz taki błąd:

[12-Dec-2014 10:59:06] PHP Fatal error:  Cannot redeclare template_quotefast() (previously declared in /home/forum/public_html/Themes/default/Xml.template.php:25) in /home/forum/public_html/Themes/default/Post.template.php on line 1001

Z modów jakie mam zainstalowane to:

Post Count Visible Only To Admin    1.0.2
SimpleColorizer     1.1
Post History    1.03
Tapatalk SMF 2.0 Plugin    4.2.0 (wcześniej 4.0.1)

Przed aktualizacją oczywiście wszystkie mody odinstalowane, pliki podmienione na oryginalne jeśli była jakaś podmianka lub edycja. Zrobiłem nawet pełną instalację od zera i dalej mi się ten błąd pojawia. Myślałem, że może któryś z modów ten błąd powoduje ale nawet wyłączenie wszystkich nie rozwiązało sprawy. Domyślam się, że gdzieś jest zdublowane wywołanie funkcji "cytuj" ale nie bardzo umiem sobie poradzić z odszukaniem tego. Stąd pytanie do mądrzejszych ode mnie :) . Będę wdzięczny za każdą pomoc :) .

Pozdrawiam
Mazak

Offline KosiMazaki

  • Semi-Newbie
  • *
  • Posts: 14
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #1 on: December 21, 2014, 05:10:52 AM »
Nikt się z podobnym problemem nie spotkał? Damn.. :P

Offline MESWEB

  • Full Member
  • ***
  • Posts: 410
  • Gender: Male
    • Don't let errors.win
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #2 on: December 21, 2014, 05:44:38 AM »
Niech zgandę darmowy hosting?

Offline KosiMazaki

  • Semi-Newbie
  • *
  • Posts: 14
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #3 on: December 22, 2014, 06:22:03 PM »
Niech zgandę darmowy hosting?

Niestety nie. Płatny i do tej pory nie było problemu.

Offline MESWEB

  • Full Member
  • ***
  • Posts: 410
  • Gender: Male
    • Don't let errors.win
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #4 on: December 22, 2014, 06:38:31 PM »
Z tego co sie dowiedziałem to używasz modyfikacji SMF to nie jest oryginalny SMF - ktoś cos tam poszperał i udostępnił swoją wersję SMF
Pobierz nową instalkę tutaj ze strony i zainstaluj.

Offline KosiMazaki

  • Semi-Newbie
  • *
  • Posts: 14
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #5 on: December 24, 2014, 07:52:39 AM »
Z tego co sie dowiedziałem to używasz modyfikacji SMF to nie jest oryginalny SMF - ktoś cos tam poszperał i udostępnił swoją wersję SMF
Pobierz nową instalkę tutaj ze strony i zainstaluj.

Hmmm pobierane było ze strony simplemachines, a nie z tego co oferował dostawca. Do tego tłumaczenie z smf.pl. No nic, po świętach z ciekawości machnę reinstalkę.

Pozdrawiam i wesołych świąt życzę.
Mazak

Offline MESWEB

  • Full Member
  • ***
  • Posts: 410
  • Gender: Male
    • Don't let errors.win
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #6 on: December 24, 2014, 03:24:46 PM »
W pliku/Xml.template.php poqiniwn być nagłówek o zmodyfikowanym SMF:
Code: [Select]
<?php
/**
* @name EosAlpha BBS
* @copyright 2011 Alex Vie silvercircle(AT)gmail(DOT)com
*
* This software is a derived product, based on:
*
* Simple Machines Forum (SMF)
* copyright: 2011 Simple Machines (http://www.simplemachines.org)
* license: BSD, See included LICENSE.TXT for terms and conditions.
*

Tu masz link https://github.com/silvercircle/SMF

Offline KosiMazaki

  • Semi-Newbie
  • *
  • Posts: 14
Re: Po aktualizacji do 2.0.9 - Błąd: Cannot redeclare template_quotefast().
« Reply #7 on: December 29, 2014, 06:54:37 PM »
U mnie jest tak:

Code: [Select]
<?php
/**
 * Simple Machines Forum (SMF)
 *
 * @package SMF
 * @author Simple Machines
 * @copyright 2011 Simple Machines
 * @license http://www.simplemachines.org/about/smf/license.php BSD
 *
 * @version 2.0
 */

plik znajduje się w: .../Themes/default/xml.template.php