• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 01:34:14 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


SMF 2.1 Beta 1 Released

Started by Oldiesmann, November 21, 2014, 12:40:06 AM

Previous topic - Next topic

superj707

Quote from: Kindred on November 24, 2014, 04:12:46 PM
1- ALL mods will be uninstalled - just like any other major upgrade. There is currently no converter from a mod system to the core system...
2- some may - especially those which use hooks - most mods for 2.0 will likely NOT work on 2.1
3- the curve2 theme in 2.1 is responsive.   This will not apply to any other theme unless that theme is also built to be responsive. Your 2.0 theme will most definitely ***NOT*** work in 2.1 and there is no easy or good way to make it do so.
4- don't know...   you'd have to look at the list of commits. However, I will note that your 60% is specific to you - not to all installations, since MOST systems seem to correctly process the subscription return from PayPal.

Thank you for the reply.

Arantor

Paid subs did receive some dev time to improve the situation but I didn't fancy setting up all the stuff to do payment handling on a test site...
No good deed goes unpunished
All helpful urges should be circumvented

superj707

To be fair, I just did a test (due to the reply above.)
I used 2.0.9 right out of the box with no other mods of any kind installed and tested paid subs.
It was hit and miss. The system really does need some help. I would like to see this because I use it to monetize my site.

Arantor

Which is why I specifically spent some time on it earlier in 2.1's development.

However, the people who can fix issues *never* seem to run into issues with it...
No good deed goes unpunished
All helpful urges should be circumvented

Kindred

And yet, we use it, successfully, here... And on dozens of other sites.

Now, I am not saying that it does not need some work...  But your analysis seems to be skewed.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

superj707

Quote from: Kindred on November 24, 2014, 06:17:37 PM
And yet, we use it, successfully, here... And on dozens of other sites.

Now, I am not saying that it does not need some work...  But your analysis seems to be skewed.
I don't know, I am not meaning to make this personal or anything. it's a great idea and I am glad it's working for some people.
I can only report on what my experience is.  Hopefully 2.1 is the solution for my issues.

shazoo!

Yes yes yes!! This is going to be the best upgrade ever!!!!

dsanchez

Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

Oldiesmann

As far as the smfpacks likes/alerts things go... At some point I will look into writing a script to import the data into the new format for 2.1, since I use both mods on my site as well. However, it will be my own script and not an official SMF script, and I don't plan on writing it until we get closer to a final version of 2.1.
Michael Eshom
Cincy Space - now open!

Black Tiger

Well congratulations, nice to hear things are going well.
However I will wait until there is a stable release.

QuoteThe general installation and upgrading procedure remains the same, however, once you upgrade from an older version to 2.1 you cannot go back, so please take careful consideration before upgrading any live site..
Which is not quite true. You would be crazy if you don't make a database backup and a backup of all files and folders before you go and upgrade to 2.1. So if things don't work, you can always delete everything and restore the backup.
But it's good to have this kind of warning, because there are still people out there who think backups are not reallly necessary.;)
Greetings, Black Tiger

Antes

Quote from: Black Tiger on November 25, 2014, 10:56:06 AM
QuoteThe general installation and upgrading procedure remains the same, however, once you upgrade from an older version to 2.1 you cannot go back, so please take careful consideration before upgrading any live site..
Which is not quite true. You would be crazy if you don't make a database backup and a backup of all files and folders before you go and upgrade to 2.1. So if things don't work, you can always delete everything and restore the backup.
But it's good to have this kind of warning, because there are still people out there who think backups are not reallly necessary.;)

Some misunderstanding I guess, you cannot downgrade from SMF 2.1, that's what we meant in there. You can always open your backup. But you cannot downgrade your SMF 2.1 to SMF 2.0 or lower versions.

levely

For a new forum, will I be able to select the beta version in Godaddy or HostGator auto uploaders?

geoff691

First of all, congratulations on the new version...very well done.  I look forward to upgrading in due course.

Can I ask...

1) Will there be a facility to imbed video in the new version?

2) Will you be able to incorporate tweets and Facebook posts?

3) I struggle to moderate sometimes so are there any enhancements which will make my job any easier?

Arantor

1) No, because this would drastically increase maintenance in our experience.

2) Same as 1.

3) Define 'struggle'. There are changes, but without understanding what your problems are, it's hard to know if there's anything that can be improved.
No good deed goes unpunished
All helpful urges should be circumvented

Antes

Quote from: levely on November 25, 2014, 11:02:15 AM
For a new forum, will I be able to select the beta version in Godaddy or HostGator auto uploaders?

Hello,

Since we don't have any contract or partnership with those companies about "auto-installer" or "upgrader" we cannot say its possible or not please consult your hosting team to get this question's answer.

Thank you

Quote from: geoff691 on November 25, 2014, 11:13:02 AM
First of all, congratulations on the new version...very well done.  I look forward to upgrading in due course.

Can I ask...

1) Will there be a facility to imbed video in the new version?

2) Will you be able to incorporate tweets and Facebook posts?

3) I struggle to moderate sometimes so are there any enhancements which will make my job any easier?

1) There is no planned feature as "embed" or "auto embed" for videos.
2) I don't really understand what you mean with "incorporate" tweets or FB posts.
3) You need to specify your problems facing while moderating your forum.

Please open a new topic about 2 & 3 with more details so we can help you further.

Thank you

geoff691

Quote from: Arantor on November 25, 2014, 11:17:46 AM
1) No, because this would drastically increase maintenance in our experience.

2) Same as 1.

3) Define 'struggle'. There are changes, but without understanding what your problems are, it's hard to know if there's anything that can be improved.

Basically the sheer volume of posts every day.  I have had to invent my own system of keeping track as to where I have edited up to on any particular thread.  A sort of marker system for editors would be useful.


Arantor

That sounds like more complex than most forums actually need (bear in mind that this forum gets hundreds and hundreds of posts per day...)
No good deed goes unpunished
All helpful urges should be circumvented

Kindred

on the subject of autoinstallers...
I certainly HOPE that they DO NOT offer the beta 1 version.

Beta1 is ***NOT*** intended for or recommended for a live/production site.

And - if you are using an autoinstalled from the host, then you may not have the technical wherewithal to run/test a beta - which may require some code tweaking to run or fix minor issues as they are discovered and addressed.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

ARG01

Quote from: levely on November 25, 2014, 11:02:15 AM
For a new forum, will I be able to select the beta version in Godaddy or HostGator auto uploaders?

First, the GoDaddy and Hostgator supplied "auto uploaders" are normally one or two SMF versions behind.
Second, they don't make it a practice to offer beta (unstable) versions of any software unless there are specific terms offered by the creator. In this case SMF warns not to use on a "live/production site" therefore, GD and HG considers this beta as unstable.  So the answer is, probably not.
No, I will not offer free downloads to Premium DzinerStuido themes. Please stop asking.

Gryzor

It's a pity it won't support video auto-embedding (YouTube mostly)... Oh well, will resort to third-party mods again.

As for Twitter and FB posts embedding, this would be interesting (insert a link to the tweet and fetch the tweet itself, perhaps nicely formatted like the Twitter API supports), but how useful would it be? How often do you do something of the sort?

Advertisement: