• Welcome to Simple Machines Community Forum. Please login or sign up.

Yet Another YouTube BBCode Tag

Started by dougiefresh, December 10, 2014, 06:09:01 PM

Previous topic - Next topic

hannes_kann_es

How can I disable auto-embed? I only want it to be embedded with the bbc. Thanks in advance!

landyvlad

Quote from: hannes_kann_es on March 07, 2018, 03:09:45 PM
How can I disable auto-embed? I only want it to be embedded with the bbc. Thanks in advance!

Uninstall the mod.  Auto-embed is it's whole point.
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

To paraphrase Kindred: "There are no technical solutions to social problems."

hannes_kann_es

Your comment was ... helpful. If that's the whole purpose, the mod should be named "Yet another Youtube autoembed".

Nevermind I figured it out. Remove the call to BBCode_YouTube_Embed($message, $smileys, $cache_id, $parse_tags); in Sources/Subs.php.

Inside that function i find the following
// Is message empty, OR autoembedding links disabled?  If so, return to caller:
if ($message === false || !empty($context['bbc_youtube']['ignore']))
return;

But there is no setting for it?

dougiefresh

Uploaded v4.11 - March 8th, 2018
o Added missing option to disable YouTube bbcodes amongst YouTube options.
o Added new option to disable autoembedding for YouTube links.




@hannes_kann_es: So you want an option to disable auto-embed?  Request granted!

hannes_kann_es


kittonium

Hi, can you tell me how I can fix the centering of the video when using ADK Portal?


that's my problem

using it like this..



[center]
[size=16pt][b][color=orange]March 2:[/color][/b][/size]
New Fallout New Vegas Video!!
[youtube]https://www.youtube.com/watch?v=0D7YkLa_VdU[/youtube]
[/center]



BUT, on normal threads (not AdkPortal homepage) the stuff displays fine

kittonium

also, seems to ignore width and height parameters if the post is in the adk portal

landyvlad

dougie - good on you for the update :)

kitto - that's a question you would need to ask in the support for ADK portal.
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

To paraphrase Kindred: "There are no technical solutions to social problems."

dougiefresh

Quote from: kittonium on March 08, 2018, 04:24:04 PM
Hi, can you tell me how I can fix the centering of the video when using ADK Portal?
Quote from: kittonium on March 08, 2018, 04:33:16 PM
also, seems to ignore width and height parameters if the post is in the adk portal
I will look into both issues.

kittonium


dougiefresh

Uploaded v4.12 - April 8th, 2018
o Fixed issue with ADK Portal that prevented video from being shown at proper size.




@kittonium:  Sorry about the wait!  I believe the issue you reported is fixed.  Let me know if it rears it's ugly head again!  Thanks!

kittonium

Quote from: dougiefresh on April 08, 2018, 10:55:01 AM
Uploaded v4.12 - April 8th, 2018
o Fixed issue with ADK Portal that prevented video from being shown at proper size.




@kittonium:  Sorry about the wait!  I believe the issue you reported is fixed.  Let me know if it rears it's ugly head again!  Thanks!

Thanks a lot :D

wtfwtf

it is trying to embed the youtube channels how to fix that ?

dougiefresh

Surround the URL like this: [url]{url}[/url].  The mod's auto-embed code should NOT attempt to add the youtube tags to the URL.

aegersz

i have installed this because of my "doug addiction" ... thanks mate, i have added this to my forum for anybody that wishes to tailor their youtube experience.
The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

mlaket

May 08, 2018, 07:28:21 PM #295 Last Edit: May 08, 2018, 07:48:36 PM by mlaket
my website is having problems with this package, I don't have any backups too, please help me to fix it

it says: "Call to undefined function BBCode_YouTube_Embed()"

Edit: website just started to work again after I replaced subs.php in sources folder with original file

-Rock Lee-

I'm going with some lag but I'll update the translations :laugh:


Regards!
¡Regresando como cual Fenix! ~ Bomber Code
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

dougiefresh

May 21, 2018, 10:49:09 PM #297 Last Edit: May 21, 2018, 11:16:43 PM by dougiefresh
Uploaded v4.13 - May 21st, 2018
o Updated Spanish Latin translation, courtsey of Rock Lee.




@Rock Lee:  Thanks for the update!  It's been included in this version!

StarredSkies

Hello! I recently got this modification for my website and for awhile autoplay was working, but with the update recently, the autoplay option has stopped working. Any idea why?

GigaWatt

With v4.13 ???. It's only got language files added, there are no code updates.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Advertisement: