• Welcome to Simple Machines Community Forum. Please login or sign up.

Auto Tweet Embed

Started by vbgamer45, January 11, 2015, 03:21:09 PM

Previous topic - Next topic

vbgamer45

Quoting the emebed tweets?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Hamm9

Quote from: vbgamer45 on January 21, 2020, 09:36:44 PM
Quoting the emebed tweets?

Quoting any message is impossible. I get a Loading message on the top that never goes away. The editor doesn't work either—no smileys, no font options.

I modified autotwitter.xml. First, I change the jQuery version from 2.1.1 to 3.1.1. But still the same. Deleting all the modification for the Load.php file solves the problem.

Hamm9

This is what I get on Web Console when I visit any thread from the forum with the package installed.


TypeError: $.sceditor is undefined topic,424.30.html:1010:5
    <anonymous> topic,424.30.html:1010
    jQuery 4
        j
        fireWith
        ready
        I
jQuery.Deferred exception: $(...).superfish is not a function @/foro/Themes/default/scripts/minified.js?beta21:460:390
j@https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js:2:29948
g/</k<@https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js:2:30262
undefined jquery.min.js:2:31525
TypeError: $(...).superfish is not a function minified.js:460:390
    <anonymous> /foro/Themes/default/scripts/minified.js?beta21:460
    jQuery 2
        j
        k
TypeError: oIframe is undefined 2 drafts.js:25:23
    init /foro/Themes/default/scripts/drafts.js?beta21:25
    <anonymous> /foro/Themes/default/scripts/drafts.js?beta21:15


When I click on Quote button, I get this:

TypeError: $(...).data(...) is undefined topic,424.30.html:1101:26
    onDocReceived topic,424.30.html:1101
    success minified.js:74
    jQuery 4
        j
        fireWith
        x
        b


None of these errors appear with the package uninstalled.

wylekk

February 22, 2020, 04:29:45 AM #163 Last Edit: February 22, 2020, 04:43:09 AM by wylekk
Try connecting like this

<script type="text/javascript" src="' . $settings['default_theme_url'] . '/scripts/jquery-3.2.1.min.js"></script>

or so
<script src="https://code.jquery.com/jquery-3.4.1.min.js" integrity="sha256-CSXorXvZcTkaix6Yvo6HppcZGetbYMGWSFlBw8HfCJo=" crossorigin="anonymous"></script>

spiros

I already have a version of jquery.min.js loading on my theme (v3.4.1, here). Is it possible to remove/adapt the extra jquery call in this line in Load.php? I tried so, but the embed did not work then.

<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>

Post with embed here:  https://www.translatum.gr/forum/index.php?topic=977462.0

vbgamer45

Please fix I can't see the issue your bbc code is messed up.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

chinaren

Quote from: vbgamer45 on April 26, 2020, 10:06:55 AM
Please fix I can't see the issue your bbc code is messed up.


So sorry!  I was trying to fix the post but my internet started playing up, and it was driving me mad, so, total redo.


When I try to install this mod in the usual fashion, it says that is corrupted or not compatible with this version of SMF, as per the message below.


Now, my version of SMF is 2.1 RC2 which, according to the mod, is compatible.  So any ideas what i'm doing wrong?  'cos it's bound to be me.


Thank you!  :)


The package you are trying to download or install is either corrupt or not compatible with this version of SMF.
The Opus Path - The Next Generation of the Written Word

vbgamer45

Fixed should install for 2.1 RC2
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

chinaren

Thank you!  You are a hero VBG!  :D
The Opus Path - The Next Generation of the Written Word

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Rob Lightbody

Big fan of this Mod, but it seems to have stopped working recently?

Here's a post I made that includes some tweets - https://www.theqe2story.com/forum/index.php?topic=9313.msg108341#msg108341

In my error log, I can see errors such as this
Database Error: Incorrect string value: '\xF0\x9F\x87\xAC\xF0\x9F...' for column `theqesto_smf1`.`smf_tweet_cache`.`html` at row 1Apply Filter: Only show the errors from this fileFile: /home/theqesto/public_html/forum/tweet-cache.php

Thanks for any advice.

vbgamer45

Change the the character encoding of  the database table smf_tweet_cache to utf8 to solve I believe.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Arantor

Think you need utf8mb4, and the queries to be on a connection that used SET NAMES utf8mb4; to make that work.
No good deed goes unpunished
All helpful urges should be circumvented

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Rob Lightbody

Quote from: vbgamer45 on May 08, 2020, 09:37:22 AM
Change the the character encoding of  the database table smf_tweet_cache to utf8 to solve I believe.

Hi,

Thanks for replying.  I remember that I did have that problem once before, but its on UTF8 general now so don't know why i'm getting the error this time

Arantor

Because UTF8 general only has a subset of real UTF-8, which emojis don't fit into. Hence the suggestion for utf8mb4.
No good deed goes unpunished
All helpful urges should be circumvented

vbgamer45

Update
2.0
+Added support to Emoji's thanks to Arantor for changes needed
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Rob Lightbody

Many thanks for the update.

I uninstalled 1.1 (including the data) and then reinstalled your new v2.0.

It is now no longer erroring, which is lovely, however I'm also not getting the thumbnail preview of the tweet either...

See - https://www.theqe2story.com/forum/index.php?topic=8675.0 and https://www.theqe2story.com/forum/index.php?topic=9164.0 for two random examples from my forum.

vbgamer45

Seems to load for me ok
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Rob Lightbody

Quote from: vbgamer45 on May 13, 2020, 11:05:25 AM
Seems to load for me ok

Me too now!  How strange!   Thats awesome though, thanks very much for your work on this package, its hugely appreciated.

Advertisement: