Advertisement:

Author Topic: Paid Subscription Not Taking Effect  (Read 3431 times)

Offline Cyber-Box

  • Semi-Newbie
  • *
  • Posts: 23
Paid Subscription Not Taking Effect
« on: February 05, 2015, 08:29:44 PM »
I have set them up with the correct settings, set the IPN in PayPal and asked if they were being blocked (was told everything was okay on their end).  I turned off auto-renew.  My error log had this:

Quote
Apply Filter: Only show the error messages of this URL
http://creadorescreativos.com/index.php?action=profile;area=subscriptions;u=2 [nofollow]
Apply Filter: Only show the errors with the same message
8: Undefined index: def_avatar
Apply Filter: Only show the errors from this file
File: /home/www/creadorescreativos.com/Sources/Load.php
Line: 1329


I assumed it had to do with a default avatar for membergroups mod so I uninstalled the mod.  Running the subscription again, the error no longer shows. 

I've uploaded new subscriptions.php and /Sources/Subscriptions-PayPal.php files, but nothing happens.

My susbcriptions show up as finished and not active so I have to manually edit the subscriptions for the members.  (I've noticed the end date is set to 2005 when I go in to manually edit.)  After each time I try I also run the corresponding Scheduled Task.

It's supposed to change membergroups so that they have special features on the forum, but it only does so when I do the manual changes.

I'm using SMF 2.0.9

Any help is greatly appreciated.

Offline Chas Large

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,108
  • Gender: Male
  • Running 2.0.xx on Apache.
    • Chas.Large on Facebook
    • https://www.linkedin.com/in/charles-large-568ba213 on LinkedIn
    • @https://twitter.com/ on Twitter
    • Chas Large's Site
Re: Paid Subscription Not Taking Effect
« Reply #1 on: February 06, 2015, 07:26:47 AM »
Not seeing this on my test site, so must be something on yours, possibly a clashing modification. Can you please upload as an attachment your Load.php file so I can have a look at it.
My Modifications :)  My Forum

Please DO NOT PM me with support requests. Post the problem in the appropriate Support Board so everyone can benefit from the advice given.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,014
    • StoryBB/StoryBB on GitHub
Re: Paid Subscription Not Taking Effect
« Reply #2 on: February 06, 2015, 07:31:13 AM »
Well, the error is related to the default avatar mod.

The overriding error... are you using a business account and does the email address you gave PayPal match the address you gave SMF?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: Paid Subscription Not Taking Effect
« Reply #3 on: February 06, 2015, 07:33:37 AM »
That "2005" issue in Paid subscriptions is an old problem that we've seen randomly popping up.
Check this: http://www.simplemachines.org/community/index.php?topic=529203.0

edit: Ninja'd :P
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,999
Re: Paid Subscription Not Taking Effect
« Reply #4 on: February 06, 2015, 01:20:31 PM »
... are you using a business account and does the email address you gave PayPal match the address you gave SMF?

That would log two errors, which OP is not getting. 

2005 end date is not a problem, that's default value for subscription not activated.

A new sub that does not activate but shows as finished is a fairly recent problem.  Have not been able to duplicate it, and haven't had sufficient access to an affected forum to determine the cause.  Will take another look when I have time tonight.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,014
    • StoryBB/StoryBB on GitHub
Re: Paid Subscription Not Taking Effect
« Reply #5 on: February 06, 2015, 02:03:30 PM »
Excuse me for asking questions that might be relevant to debugging.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,999
Re: Paid Subscription Not Taking Effect
« Reply #6 on: February 06, 2015, 09:08:07 PM »
Not being critical, Arantor.  This looks like a different problem.  The email address glitch only occurs with recurring payments, which OP has disabled, and errors out cleanly, logging two errors, one for PP subscription, one for the payment.  If this is the same critter I had a quick look at a month or two ago, IPN is received, processed without error, but a broken subscription is created.  Was first reported around 2.0.8 - 2.0.9.

Offline Cyber-Box

  • Semi-Newbie
  • *
  • Posts: 23
Re: Paid Subscription Not Taking Effect
« Reply #7 on: February 11, 2015, 12:06:27 PM »
Not seeing this on my test site, so must be something on yours, possibly a clashing modification. Can you please upload as an attachment your Load.php file so I can have a look at it.
Here ya go. and thank you.


I had different emails so I created a new business PayPal account to start off clean.  I replaced the files with new ones and started the whole process again with new subscriptions (non-recurring).  I took a look at the recommended thread and did the suggested replacements.  The PayPal account is a business account with only one email address associated to it, I tried again but now is it not only giving me the same results it is also giving me the following errors:

Code: [Select]
http://creadorescreativos.com/subscriptions.php

Apply Filter: Only show the errors with the same message

Unknown Paid Subscriptions transaction type.
mc_gross: 0.10
protection_eligibility: Ineligible
payer_id: 84DK79PDQVVQC
tax: 0.00
payment_date: 08:44:03 Feb 11, 2015 PST
payment_status: Completed
charset: windows-1252
first_name: xxxxxxxxxxc
mc_fee: 0.10
notify_version: 3.8
custom:
payer_status: verified
business: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
quantity: 1
verify_sign: AD4xuBHhxVBOCmsu.NlBPNGD.XFYAWsTiDXB7x9wELSbOlV2KcGgYLta
payer_email: xxxxxxxxxxxxxxxxxxx
txn_id: 12A76400E31491833
payment_type: instant
payer_business_name: xxxxxxxxxx
last_name: Rivera
receiver_email: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
payment_fee: 0.10
receiver_id: 2JPLAPYMWDBXW
txn_type: web_accept
item_name: socios Subscription
mc_currency: USD
item_number: 5+2
residence_country: US
handling_amount: 0.00
transaction_subject:
payment_gross: 0.10
shipping: 0.00
ipn_track_id: 31691c8151b7e

Code: [Select]
Apply Filter: Only show the error messages of this member Guest
Apply Filter: Only show the error messages of this IP address 173.0.81.1   
   Reverse chronological order of list Today at 12:44:33 PM
Apply Filter: Only show the error messages of this session b331eacdfee54f8f29e6137440403bab
Apply Filter: Only show the errors of this type Type of error: General 

Apply Filter: Only show the error messages of this URL

http://creadorescreativos.com/subscriptions.php

Apply Filter: Only show the errors with the same message

Unable to send mail to the email address 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxx'


And I JUST noticed it says "member guest", which the profile I'm using to buy with is a registered member.
« Last Edit: February 11, 2015, 12:24:32 PM by Krash »

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,999
Re: Paid Subscription Not Taking Effect
« Reply #8 on: February 11, 2015, 12:25:45 PM »
If you can pm temporary admin access, will have a look tonight.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,999
Re: Paid Subscription Not Taking Effect
« Reply #9 on: February 12, 2015, 12:07:58 AM »
Ok, there are a number of things wrong here, but it does appear to be the same problem I saw a while back.  First off, the email address is Paid Subs settings does not match the address in the IPN post data - it's case sensitive, and they weren't the same.  Fixed that, otherwise the post data is correct.  Also seems to be a problem with your email setup, attempts to email notifications fail and throw errors.  That you may have to take up with your host.  If they don't support php email, you'll have to switch to smtp.

Getting back to Paid Subs, what happens now is PayPal payment is successful, IPN is received and data is correct, it's processed without error, and appears to create a broken subscription.  Member's group does not change, doesn't show up in member profile (no 'Existing Subscriptions'), or in the subscription details in ACP ('There are currently no subscribers to this subscription!'), but in 'View Subscriptions' it adds one to 'Finished'.  The only way to get rid of it is to manually activate the subscription, then delete it, which deducts one from 'Finished'.  When admin goes to member Profile -> Paid Subs, the subscription has the 'Edit Subscription' link (not 'Add Subscription'), even though it's not shown in 'Existing Subscriptions', and has the correct start date/time, but the 2005 end date. 

Don't have access to database, but it seems to be adding something to log_subscribed.  Best guess is it's logging the subscription, but not updating the end date.  This is an original 2.0.9 install, not patched up from earlier version, running a dozen or so mods. 


Just tried it on my clean, original 2.0.9 test install using OP's PayPal account, works fine.  Here are his mods -

1. 'Read the Rules' Link Above Post Button 2.0  [ Install Mod ] [ List Files ] [ Delete ] 
2. Mark PM Unread 0.1.0   [ Uninstall ] [ List Files ] [ Delete ] 
3. Add Facebook Like, Tweet, and Google +1 1.0.3a   [ Uninstall ] [ List Files ] [ Delete ] 
4. Group Online Status 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
5. @mention members 1.1.2   [ Uninstall ] [ List Files ] [ Delete ] 
6. Happy Birthday 0.3   [ Uninstall ] [ List Files ] [ Delete ] 
7. Custom Fields On Memberlist 1.0  [ Install Mod ] [ List Files ] [ Delete ] 
8. Ultimate Profile 0.9.1   [ Uninstall ] [ List Files ] [ Delete ] 
9. Custom Fields On Memberlist 1.1  [ Install Mod ] [ List Files ] [ Delete ] 
10. Online status on login 1.7   [ Uninstall ] [ List Files ] [ Delete ] 
11. AMSP - Add Member's Signature Permission 1.0.1   [ Uninstall ] [ List Files ] [ Delete ] 
12. Default Avatar Per Membergroup 1.0  [ Install Mod ] [ List Files ] [ Delete ] 
13. Google Analytics Code 1.5   [ Uninstall ] [ List Files ] [ Delete ] 
14. SA Chat 0.1.5 Rev110  [ Install Mod ] [ List Files ] [ Delete ] 
15. Ad Managment 3.2   [ Uninstall ] [ List Files ] [ Delete ] 
16. AdditionalMembergroups 1.04   [ Uninstall ] [ List Files ] [ Delete ] 
17. Simple Audio Video Embedder 3.1   [ Uninstall ] [ List Files ]

Going off now, will get back to this tomorrow.  Any ideas would be appreciated. 

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: Paid Subscription Not Taking Effect
« Reply #10 on: February 12, 2015, 04:38:15 AM »
I would start by uninstall my "AdditionalMembergroups". I never used Paid Subs so I might have missed something...
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline Cyber-Box

  • Semi-Newbie
  • *
  • Posts: 23
Re: Paid Subscription Not Taking Effect
« Reply #11 on: February 24, 2015, 06:12:09 AM »
Ok, there are a number of things wrong here, but it does appear to be the same problem I saw a while back.  First off, the email address is Paid Subs settings does not match the address in the IPN post data - it's case sensitive, and they weren't the same.  Fixed that, otherwise the post data is correct.  Also seems to be a problem with your email setup, attempts to email notifications fail and throw errors.  That you may have to take up with your host.  If they don't support php email, you'll have to switch to smtp.

Getting back to Paid Subs, what happens now is PayPal payment is successful, IPN is received and data is correct, it's processed without error, and appears to create a broken subscription.  Member's group does not change, doesn't show up in member profile (no 'Existing Subscriptions'), or in the subscription details in ACP ('There are currently no subscribers to this subscription!'), but in 'View Subscriptions' it adds one to 'Finished'.  The only way to get rid of it is to manually activate the subscription, then delete it, which deducts one from 'Finished'.  When admin goes to member Profile -> Paid Subs, the subscription has the 'Edit Subscription' link (not 'Add Subscription'), even though it's not shown in 'Existing Subscriptions', and has the correct start date/time, but the 2005 end date. 

Don't have access to database, but it seems to be adding something to log_subscribed.  Best guess is it's logging the subscription, but not updating the end date.  This is an original 2.0.9 install, not patched up from earlier version, running a dozen or so mods. 


Just tried it on my clean, original 2.0.9 test install using OP's PayPal account, works fine.  Here are his mods -

1. 'Read the Rules' Link Above Post Button 2.0  [ Install Mod ] [ List Files ] [ Delete ] 
2. Mark PM Unread 0.1.0   [ Uninstall ] [ List Files ] [ Delete ] 
3. Add Facebook Like, Tweet, and Google +1 1.0.3a   [ Uninstall ] [ List Files ] [ Delete ] 
4. Group Online Status 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
5. @mention members 1.1.2   [ Uninstall ] [ List Files ] [ Delete ] 
6. Happy Birthday 0.3   [ Uninstall ] [ List Files ] [ Delete ] 
7. Custom Fields On Memberlist 1.0  [ Install Mod ] [ List Files ] [ Delete ] 
8. Ultimate Profile 0.9.1   [ Uninstall ] [ List Files ] [ Delete ] 
9. Custom Fields On Memberlist 1.1  [ Install Mod ] [ List Files ] [ Delete ] 
10. Online status on login 1.7   [ Uninstall ] [ List Files ] [ Delete ] 
11. AMSP - Add Member's Signature Permission 1.0.1   [ Uninstall ] [ List Files ] [ Delete ] 
12. Default Avatar Per Membergroup 1.0  [ Install Mod ] [ List Files ] [ Delete ] 
13. Google Analytics Code 1.5   [ Uninstall ] [ List Files ] [ Delete ] 
14. SA Chat 0.1.5 Rev110  [ Install Mod ] [ List Files ] [ Delete ] 
15. Ad Managment 3.2   [ Uninstall ] [ List Files ] [ Delete ] 
16. AdditionalMembergroups 1.04   [ Uninstall ] [ List Files ] [ Delete ] 
17. Simple Audio Video Embedder 3.1   [ Uninstall ] [ List Files ]

Going off now, will get back to this tomorrow.  Any ideas would be appreciated. 

Thank you so much for your help.
Regarding the email, I check the host email and it says it's "POP3/IMAP/SMTP Server" but I changed the SMF email anyway.  When I retried the subscription issue, it said it didn't send that email either.  Out of curiosity I tried sending a topic to hotmail, outlook, yahoo, and gmail and all of those also gave me the unable to send error. :(

Back to the subscription issue, the subscription is the additional membergroup.  I wanted the members to
move up the ranks" within the post groups and be able to show that off in the their profile area when they post something.  But I also wanted to be able to identify who's "donated" to the forum. I call the 'forum associates'.  It's why I actually downloaded that mod. :-\  Could it possibly be some OTHER mod?  I'm trying to figure out which one to "sacrifice".  LOLOL ;)

I get an email from PayPal when someone pays the subscription and I noticed the Edit Subscription link, so I'll just do it manually until I can figure something out. :(

But thank you so much.


Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,999
Re: Paid Subscription Not Taking Effect
« Reply #12 on: February 24, 2015, 01:32:39 PM »
I would set up a clean 2.0.9 test install in a different directory, confirm that Paid Subs works (it should), then install your mods one at a time until it stops working.  That'll tell you which mod is causing the problem. 

Offline Cyber-Box

  • Semi-Newbie
  • *
  • Posts: 23
Re: Paid Subscription Not Taking Effect
« Reply #13 on: February 25, 2015, 04:48:35 AM »
You're so smart. LOLOL  I'm not being sarcastic or anything.  I'm serious.  Can you tell I'm new?  LOL  But, I'm learning with you guys so thanks.  ;D

P.S. By the way, it really is greatly appreciated not just because of the help with this project of mine but because I'm planning to homeschool in some years and I really want to be able to tell my kid I can help him out with just about anything.  :D