Advertisement:

Author Topic: FUDForum 3.0.4  (Read 16038 times)

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #20 on: March 11, 2015, 06:00:15 AM »
Thx and kudos to a very nice job so far ! When I see the kind of support you and other top members provide,
I am really grateful and happy to be able to switch to this great forum platform !  :D
Thank you :)

Quote
Last : will members have to reset their passwords to log in ?
Unfortunately yes :(

Quote
However, there are some pictures that don't show up, quite a lot of them actually, after I ran the maintenance tasks
you mentionned. I get that kind of thing :

index.php?=getfile&id=776&private=0
Can you please link me a topic where that happens? The "original" topic in FUD and the corresponding "converted" topic in SMF ;) PM me if you don't want the links in public ;)

Quote
Also, will it be possible to "replace" the existing FUD install by this one or any request to an existing message will have
to be re-directed ?
First part, yes. You just need to remove the FUD files from "www" and put the contents of "smf" folder in "www". then you load and run repair_settings to fix the URL and paths in SMF ;)
What is repair_settings.php?
BUT DON'T DO THIS ALREADY!!! First you should test SMF, check if it was correctly converted, convert again, check again, etc, etc... Don't rush it ;)
The second part... Not really sure. Out of the box, no...
But it should be possible to fetch the URL, process it and cause a redirect... Eg:
www.yourforum.com/index.php?t=msg&th=2&start=0&
Should become
www.yourforum.com/index.php?topic=8.0

I'm pretty sure something will be forgotten with this approach but hey, better than nothing :P
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #21 on: March 11, 2015, 10:06:33 AM »
OK, 2 things:

It seems that your attachments weren't converted, I need to take a look at that, but it should be (has to! :P ) fixable.
The inline pictures, unfortunately not. SMF doesn't support inline attachments... There are 2 MODs which do that, but aren't compatible with FUD's syntax.
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline eldritch1969

  • Semi-Newbie
  • *
  • Posts: 51
Re: FUDForum 3.0.4
« Reply #22 on: March 11, 2015, 10:53:59 AM »
so it means that photos won't be seen inside messages ?
If it is the case, how can members include them ?

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #23 on: March 11, 2015, 11:05:50 AM »
After I fixed the issue with attachments :P the pictures that are attached to the post will still be attached. But will not be shown inline --> directly inside the post content.

After the conversion, new pictures can be attached using SMF's default attachments system. And you can post new pictures inline if you use one of these MODs
https://github.com/Spuds/SMF-ILA
http://custom.simplemachines.org/mods/index.php?mod=3770

But the existing posts will not have images in posts. They will be attached, yes, but not directly shown inside the post :(
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #24 on: March 11, 2015, 07:29:39 PM »
OK so I fixed some minor things but the attachments were actually correctly converted, it's just that in SMF guests have no permission to see them :P
So everything is in place. Any further problems that you spotted?
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline eldritch1969

  • Semi-Newbie
  • *
  • Posts: 51
Re: FUDForum 3.0.4
« Reply #25 on: March 12, 2015, 01:14:48 AM »
Hi !
Talking about attachments, when I click on some of them, they don't show up as photos, I have a message asking me to download the file. I can't even see them. Isn't there any way to have a kind of plug-in like Lightbox to watch them ?

Also, smileys don't show up, I suppose there won't be a way to get them back ?

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #26 on: March 12, 2015, 05:44:26 AM »
Can you point me to one of these attachments?

About the smileys, I have to check but I *think* that the converter doesn't handle them. I'll check ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline eldritch1969

  • Semi-Newbie
  • *
  • Posts: 51
Re: FUDForum 3.0.4
« Reply #27 on: March 12, 2015, 06:44:15 AM »
Ok, no problem about the smileys :)

http://smf.bartopmania.com/index.php?topic=904.0

This for instance, but there are plenty others. If I click on one of them, it just ask for d/load the pic;

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 48,079
Re: FUDForum 3.0.4
« Reply #28 on: March 12, 2015, 07:23:08 AM »
Code: [Select]
<img src="images/smiley_icons/gamer.gif" border="0" alt="gamer">
can you create an images/smiley_icons folder and put the old fudforum smileys in that folder? that should make them appear.

Offline eldritch1969

  • Semi-Newbie
  • *
  • Posts: 51
Re: FUDForum 3.0.4
« Reply #29 on: March 12, 2015, 12:19:25 PM »
Thx
Does it have to be this folder's name ?
I transferred the fud icon folder renamed "fudforum" in smf's smileys folder and make it default
but that doesn't work

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: FUDForum 3.0.4
« Reply #30 on: March 12, 2015, 12:27:26 PM »
Nop, that doesn't work...

The thing is... Most forum softwares use "codes" for the smileys (which are parsed when the post is being displayed), the same way they use BBC for inline attachments. FUD is... strange :P
The smileys are added as images directly in the post body, so that the only way is really to have the same images path available in SMF.
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline eldritch1969

  • Semi-Newbie
  • *
  • Posts: 51
Re: FUDForum 3.0.4
« Reply #31 on: March 12, 2015, 12:45:06 PM »
Yep, that's fine by me.
Strange that some pictures show up, whereas others don't. If they can't be dosplayed, it'll have to stay like that

Offline m_k

  • Newbie
  • *
  • Posts: 2
Re: FUDForum 3.0.4
« Reply #32 on: September 04, 2017, 10:05:55 AM »
With this setup:

Code: [Select]
FUDforum: 3.0.8RC1
PHP: 7.0.22-0ubuntu0.16.04.1
Database: mysql 5.7.19-0ubuntu0.16.04.1 (mysqli)
Operating system: Linux 4.4.0-87-generic

I get the following error message when running the converter:

Code: [Select]
Converting members...
Notice: Undefined property: mysqli_result::$EOF in /var/www/html/smf/convert.php on line 2721

Notice: Undefined property: mysqli_result::$Fields in /var/www/html/smf/convert.php on line 2725

Notice: Trying to get property of non-object in /var/www/html/smf/convert.php on line 2726

Fatal error: Uncaught Error: Call to undefined method mysqli_result::MoveNext() in /var/www/html/smf/convert.php:2731 Stack trace: #0 /var/www/html/smf/convert.php(1251): convert_fetch_assoc(Object(mysqli_result)) #1 /var/www/html/smf/convert.php(51): doStep1() #2 {main} thrown in /var/www/html/smf/convert.php on line 2731

Is this fixable in an easy way?

EDIT: Fixed by downgrading to PHP 5.6 and SMF 2.0.13
« Last Edit: September 04, 2017, 10:41:56 AM by m_k »

Offline m_k

  • Newbie
  • *
  • Posts: 2
Re: FUDForum 3.0.4
« Reply #33 on: September 04, 2017, 10:50:36 AM »
Line 43 should look like this for things to work:
Code: [Select]
         id AS id_member, SUBSTRING(login, 1, 80) AS member_name, '' AS ope│forum@vultr:~/1993$ ls | wc -l
    nid_uri, '' AS ignore_boards,