Advertisement:

Author Topic: Redsy  (Read 146660 times)

Offline Evanthe

  • Newbie
  • *
  • Posts: 3
Re: Redsy
« Reply #240 on: June 23, 2020, 04:41:14 PM »
Hi  :) I'm new here.

The theme has stopped working correctly in the mobile version, it loads expanded and it looks like the desktop version.
 I leave you the link of a screenshot so you can see better what I mean:



I love the theme and would not like to have to change it, is there any way to fix it?

Thanks

index.css

Code: (Search) [Select]
@media (max-width:767px) {
#IC .nav-tabs li span
{
display: none;
}
}

Code: (Replace) [Select]
@media (max-width:767px) {
#IC .nav-tabs li span
{
display: none;
}
#sp_left, #sp_right, #sp_center
{
width: 100%;
display: block;
}
}

Thanks for responding and for your help. 

I have changed it but it remains exactly the same. 

Any other idea? 

Offline Decent_946

  • Semi-Newbie
  • *
  • Posts: 68
  • Gender: Male
    • Extreme Fighting Zome
Re: Redsy
« Reply #241 on: June 24, 2020, 12:26:32 AM »

Thanks for responding and for your help. 

I have changed it but it remains exactly the same. 

Any other idea?
[/quote]
Sometimes you need to clear the cache+cookies to make the css effective. Dud you try this?
Thankx to RebellioN

Offline Evanthe

  • Newbie
  • *
  • Posts: 3
Re: Redsy
« Reply #242 on: June 24, 2020, 10:34:19 AM »

Thanks for responding and for your help. 

I have changed it but it remains exactly the same. 

Any other idea?
Quote
Sometimes you need to clear the cache+cookies to make the css effective. Dud you try this?

Done, not fixed :(

Offline rufovi

  • Newbie
  • *
  • Posts: 7
Re: Redsy
« Reply #243 on: August 05, 2020, 07:36:55 PM »
Hi Daniiel,

First of all, this is a very good theme!! Thank you so much!!

I'm newbie to this Redsy theme.

I've found that, after installing it, the "Visual verification image to display" has disappeared in Spanish utf8 language (see attachment "ES ko.PNG").
This setting is configured in: Configuration > Security and Moderation > Anti-Spam > Configure Verification Methods > Visual verification image to display

As you can see in "smf Languages.PNG" attached file I have 3 languages installed, with Spanish set to the default one.

I have switched back to the SMF default theme, and then the "Visual verification image to display" has appeared again, so I have checked Redsy files.

Using the Files Manager in CPanel I have had a look at this folder:
(smf-folder)/Themes/Redsy/languages/
(see "Redsy-Languages.PNG" attached file)

I have seen that the 3 "utf8.php" files had a wrong first character (see "Editing utf8-php.PNG" attached file). You have to Edit the files to see it. You will not see it if you View the files.

Deleting this first character and saving the file (in my case ThemeStrings.spanish_es-utf8.php) has solved the problem. (see "ES ok.PNG" attached file).

I have also attached the 3 utf8 php files in my folder in case you want to have a look at them (they are in "ThemeStrings.-utf8.php.zip").
ThemeStrings.english-utf8.php and ThemeStrings.spanish_latin-utf8.php should still have the problem.
ThemeStrings.spanish_es-utf8.php has been corrected by me.

Do you know if it is possible to solve this issue in future releases?
Many thanks in advance!!
Muchas gracias Daniiel!!


FYI:
I found this post and checked the solution proposed there:
https://www.simplemachines.org/community/index.php?topic=359056.msg2447442#msg2447442
Thank you for contributing to solve this!

Offline willymmx

  • Semi-Newbie
  • *
  • Posts: 32
Re: Redsy
« Reply #244 on: January 28, 2021, 11:42:53 AM »
Hi all! currently the error log constantly saves errors like this:
 - Use of undefined constant php - assumed 'php' (this will throw an Error in a future version of PHP)
    public_html/Themes/Redsy/languages/ThemeStrings.spanish_latin-utf8.php
    Línea: 1

Here is de file content:
Code: [Select]
<?php// Version: 2.0; ThemeStrings$txt['icons_check'] = 'Activar iconos sociales';$txt['rs_facebook'] = 'Facebook';$txt['facebook_check'] = 'Activar icono de Facebook';$txt['facebook_text'] = 'Direccion de la pagina de Facebook';$txt['rs_twitter'] = 'Twitter';$txt['twitter_check'] = 'Activar icono de Twitter';$txt['twitter_text'] = 'Direccion de la pagina de Twitter';$txt['rs_youtube'] = 'Youtube';$txt['youtube_check'] = 'Activar icono de Youtube';$txt['youtube_text'] = 'Direccion de la pagina de  Youtube';$txt['rs_rss'] = 'RSS';$txt['rss_check'] = 'Activar icono de RSS';$txt['rss_text'] = 'Direccion de la pagina de RSS';$txt['redsy_copyright'] = 'Agrega tu copyright personalizado';$txt['edit_profile'] = 'Editar perfil';$txt['profile_account'] = 'Configuracion de la cuenta';$txt['new_post'] = 'Nuevos temas';$txt['new_replies'] = 'Nuevas respuestas';$txt['redsy_navbar'] = 'Activar barra de navegacion fija';$txt['redsy_navbar_height'] = 'Altura de la barra de navegacion';$txt['redsy_navbar_height_desc'] = 'Minimo de altura: 50px';$txt['st_actions'] = 'Acciones';?>
anyone have any idea what the problem might be?
Thanks!

UPDATE! Problem solved, just replace the code with the one in file ThemeStrings.spanish_es.php
Code: [Select]
<?php
// Version: 2.0; ThemeStrings
$txt['icons_check'] = 'Activar iconos sociales';
$txt['rs_facebook'] = 'Facebook';
$txt['facebook_check'] = 'Activar icono de Facebook';
$txt['facebook_text'] = 'Direccion de la pagina de Facebook';
$txt['rs_twitter'] = 'Twitter';
$txt['twitter_check'] = 'Activar icono de Twitter';
$txt['twitter_text'] = 'Direccion de la pagina de Twitter';
$txt['rs_youtube'] = 'Youtube';
$txt['youtube_check'] = 'Activar icono de Youtube';
$txt['youtube_text'] = 'Direccion de la pagina de  Youtube';
$txt['rs_rss'] = 'RSS';
$txt['rss_check'] = 'Activar icono de RSS';
$txt['rss_text'] = 'Direccion de la pagina de RSS';
$txt['redsy_copyright'] = 'Agrega tu copyright personalizado';
$txt['edit_profile'] = 'Editar perfil';
$txt['profile_account'] = 'Configuracion de la cuenta';
$txt['new_post'] = 'Nuevos temas';
$txt['new_replies'] = 'Nuevas respuestas';
$txt['redsy_navbar'] = 'Activar barra de navegacion fija';
$txt['redsy_navbar_height'] = 'Altura de la barra de navegacion';
$txt['redsy_navbar_height_desc'] = 'Minimo de altura: 50px';
$txt['st_actions'] = 'Acciones';
?>

Offline glaukos

  • Newbie
  • *
  • Posts: 3
Re: Redsy
« Reply #245 on: March 02, 2021, 08:58:57 AM »
Hello,

I fence the following problem, when insert new post delay to appeared. Also when change something in admin panel delay to take the changes

Please for your advice

Thanks

Offline shadav

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,432
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Redsy
« Reply #246 on: March 02, 2021, 10:41:58 AM »
Hello,

I fence the following problem, when insert new post delay to appeared. Also when change something in admin panel delay to take the changes

Please for your advice

Thanks

that really wouldn't have much to do with the theme....that would be your severs response time....contact your host

Offline Diego Andrés

  • Customizer
  • SMF Hero
  • *
  • Posts: 3,833
  • Gender: Male
    • DiegoAndresCortes on GitHub
    • @bihgetter on Twitter
    • SMF Tricks - Free & Premium Themes
Re: Redsy
« Reply #247 on: March 02, 2021, 01:31:10 PM »
Hi all! currently the error log constantly saves errors like this:
 - Use of undefined constant php - assumed 'php' (this will throw an Error in a future version of PHP)
    public_html/Themes/Redsy/languages/ThemeStrings.spanish_latin-utf8.php
    Línea: 1

Here is de file content:
Code: [Select]
<?php// Version: 2.0; ThemeStrings$txt['icons_check'] = 'Activar iconos sociales';$txt['rs_facebook'] = 'Facebook';$txt['facebook_check'] = 'Activar icono de Facebook';$txt['facebook_text'] = 'Direccion de la pagina de Facebook';$txt['rs_twitter'] = 'Twitter';$txt['twitter_check'] = 'Activar icono de Twitter';$txt['twitter_text'] = 'Direccion de la pagina de Twitter';$txt['rs_youtube'] = 'Youtube';$txt['youtube_check'] = 'Activar icono de Youtube';$txt['youtube_text'] = 'Direccion de la pagina de  Youtube';$txt['rs_rss'] = 'RSS';$txt['rss_check'] = 'Activar icono de RSS';$txt['rss_text'] = 'Direccion de la pagina de RSS';$txt['redsy_copyright'] = 'Agrega tu copyright personalizado';$txt['edit_profile'] = 'Editar perfil';$txt['profile_account'] = 'Configuracion de la cuenta';$txt['new_post'] = 'Nuevos temas';$txt['new_replies'] = 'Nuevas respuestas';$txt['redsy_navbar'] = 'Activar barra de navegacion fija';$txt['redsy_navbar_height'] = 'Altura de la barra de navegacion';$txt['redsy_navbar_height_desc'] = 'Minimo de altura: 50px';$txt['st_actions'] = 'Acciones';?>
anyone have any idea what the problem might be?
Thanks!

Fixed and updated, no additional changes.

Thanks

SMF Tricks - Free & Premium Responsive Themes for SMF.

Offline willymmx

  • Semi-Newbie
  • *
  • Posts: 32
Re: Redsy
« Reply #248 on: March 02, 2021, 06:41:34 PM »
Hi all! currently the error log constantly saves errors like this:
 - Use of undefined constant php - assumed 'php' (this will throw an Error in a future version of PHP)
    public_html/Themes/Redsy/languages/ThemeStrings.spanish_latin-utf8.php
    Línea: 1

Here is de file content:
Code: [Select]
<?php// Version: 2.0; ThemeStrings$txt['icons_check'] = 'Activar iconos sociales';$txt['rs_facebook'] = 'Facebook';$txt['facebook_check'] = 'Activar icono de Facebook';$txt['facebook_text'] = 'Direccion de la pagina de Facebook';$txt['rs_twitter'] = 'Twitter';$txt['twitter_check'] = 'Activar icono de Twitter';$txt['twitter_text'] = 'Direccion de la pagina de Twitter';$txt['rs_youtube'] = 'Youtube';$txt['youtube_check'] = 'Activar icono de Youtube';$txt['youtube_text'] = 'Direccion de la pagina de  Youtube';$txt['rs_rss'] = 'RSS';$txt['rss_check'] = 'Activar icono de RSS';$txt['rss_text'] = 'Direccion de la pagina de RSS';$txt['redsy_copyright'] = 'Agrega tu copyright personalizado';$txt['edit_profile'] = 'Editar perfil';$txt['profile_account'] = 'Configuracion de la cuenta';$txt['new_post'] = 'Nuevos temas';$txt['new_replies'] = 'Nuevas respuestas';$txt['redsy_navbar'] = 'Activar barra de navegacion fija';$txt['redsy_navbar_height'] = 'Altura de la barra de navegacion';$txt['redsy_navbar_height_desc'] = 'Minimo de altura: 50px';$txt['st_actions'] = 'Acciones';?>
anyone have any idea what the problem might be?
Thanks!

Thanks Diego!

Fixed and updated, no additional changes.

Thanks

Offline Johnny Thunder

  • Newbie
  • *
  • Posts: 4
Re: Redsy
« Reply #249 on: March 13, 2021, 08:34:15 AM »
Hi everyone. I'm a new member and a new user of Simple Machines.

I have installed this theme and would like to change a colour if possible. The red colour that can be seen in the header, appears at various places throughout the theme. Is there a straightforward option to change this colour, or would I have to make changes in multiple files wherever this colour is used?

Thank you very much for any advice you may be able to give.


Offline shadav

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,432
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Redsy
« Reply #250 on: March 13, 2021, 11:44:59 AM »
Hi everyone. I'm a new member and a new user of Simple Machines.

I have installed this theme and would like to change a colour if possible. The red colour that can be seen in the header, appears at various places throughout the theme. Is there a straightforward option to change this colour, or would I have to make changes in multiple files wherever this colour is used?

Thank you very much for any advice you may be able to give.

depending on what browser you use, you should be able to right click the area that you wish to change and then click on inspect
this will show you what file to look for and what css part to change

if you need further help, a link to your site would be helpful as I don't use this theme

Offline glaukos

  • Newbie
  • *
  • Posts: 3
Re: Redsy
« Reply #251 on: March 16, 2021, 02:28:02 PM »
Hello,

I fence the following problem, when insert new post delay to appeared. Also when change something in admin panel delay to take the changes

Please for your advice

Thanks

that really wouldn't have much to do with the theme....that would be your severs response time....contact your host

Hi again,

i have tested with default theme smf version 2.0.18 and others themes and work fine. But with the redsy appeared after few minute (1~2 ).

Please for your advices

Offline glaukos

  • Newbie
  • *
  • Posts: 3
Re: Redsy
« Reply #252 on: March 22, 2021, 04:35:08 AM »
Hi again,

Finaly I found the problem, it was congiguration in the .htaccess file.

Thanks

Hello,

I fence the following problem, when insert new post delay to appeared. Also when change something in admin panel delay to take the changes

Please for your advice

Thanks

that really wouldn't have much to do with the theme....that would be your severs response time....contact your host

Hi again,

i have tested with default theme smf version 2.0.18 and others themes and work fine. But with the redsy appeared after few minute (1~2 ).

Please for your advices

Offline Johnny Thunder

  • Newbie
  • *
  • Posts: 4
Re: Redsy
« Reply #253 on: March 24, 2021, 04:03:11 AM »
Hi everyone. I'm a new member and a new user of Simple Machines.

I have installed this theme and would like to change a colour if possible. The red colour that can be seen in the header, appears at various places throughout the theme. Is there a straightforward option to change this colour, or would I have to make changes in multiple files wherever this colour is used?

Thank you very much for any advice you may be able to give.

depending on what browser you use, you should be able to right click the area that you wish to change and then click on inspect
this will show you what file to look for and what css part to change

if you need further help, a link to your site would be helpful as I don't use this theme


Thank you very much Shadav. I found it a little daunting at first but I have maneged to make all the changes required so far.
Thank you for the support and for giving me the confidence to try it.

Offline Johnny Thunder

  • Newbie
  • *
  • Posts: 4
Re: Redsy
« Reply #254 on: March 25, 2021, 06:03:54 AM »
Morning ladies and gents.

I hope someone can help me with an issue I am having. I have placed a background image on our forum using the following code:


Code: [Select]
/* Set a fontsize that will look the same in all browsers. */
body
{
   background: #000 url(https://redroar.online/Themes/Redsy_SMF2/images/backgroundimage.jpg) no-repeat fixed;
   background-size: 100%;
   
   margin: 0;
   padding: 0;
}



This appears to be working fine on desktops as the following image shows:









However, it is not working properly when members are viewing on their phone. I am assuming due to the portrait orientation of viewing.








The background image is 710px wide by 444px high.


Is there any way I can get this to work on mobiles by adding further code and/or a second image?



Thank you very much.



Offline Diego Andrés

  • Customizer
  • SMF Hero
  • *
  • Posts: 3,833
  • Gender: Male
    • DiegoAndresCortes on GitHub
    • @bihgetter on Twitter
    • SMF Tricks - Free & Premium Themes
Re: Redsy
« Reply #255 on: March 25, 2021, 01:13:30 PM »
It's because you put no-repeat
You could do simple stuff like repeat-y

Or keep no-repeat but use background-size: cover; or similar.

--------

Actually just realized you're using static position, this does not work in mobile devices.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Offline Johnny Thunder

  • Newbie
  • *
  • Posts: 4
Re: Redsy
« Reply #256 on: March 26, 2021, 07:02:18 AM »
Thank you for your reply Diego.

Is there  a way to change the code to enable it to work across all devices?
The members do not want a tiled background. They would like this single image to fill the background.


Thank you.