News:

Join the Facebook Fan Page.

Main Menu

SMF Post Prefix

Started by Diego Andrés, May 11, 2015, 10:37:35 PM

Previous topic - Next topic

landyvlad

I've had an unusual issue reported by one of my members who uses an iMac.
He is unable to access the drop down menu when creating or modifying the OP in a thread.

My other admins report that it works fine on their iPads and iPhones, so it might be something specific to the iMac

Any ideas?
"Put as much effort into your question as you'd expect someone to give in an answer"

Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Be the person your dog thinks you are.

Diego Andrés

2.1 - 22 May 2018
Finally adressed the issues in Search.php.
Fixed a small bug preventing the mod from previweing boards/groups in the settings.

SMF Tricks - Free & Premium Responsive Themes for SMF.

landyvlad

Hmm OK trying to install v 2.1

When I go to upload the mod package to SMF, I get the message:
"The file you are uploading already exists on the server. Please delete it first then try again."

In fact I currently have version 2.0.3, and I have not uploaded ver 2.1 previously.

Any idea what would be causing this or how to fix it?

I tried to uninstall v 2.0.3 and there are several errors thrown in the test parser, for replacements in ./Sources/Subs-Post.php and ./Sources/Search.php

What's the best course of action?
1. Press uninstall anyway, then find the ones it missed and edit manually? OR
2. Do all edits manually to remove the code?

Naturally I want to ensure that whatever way I approach it does NOT lose any of the existing prefix types, boards, etc.

Would love if you could help. Thanks  :)

http://gsx1400owners.org/forum


"Put as much effort into your question as you'd expect someone to give in an answer"

Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Be the person your dog thinks you are.

Diego Andrés


SMF Tricks - Free & Premium Responsive Themes for SMF.

pocttopus

This is great mod and I like it a lot.  :D
After updating from 2.0.3 version to 2.1 version, there is 2.0.3 still present.
Is this normal behavior? ???

Thanks! :)

Diego Andrés

Quote from: pocttopus on May 23, 2018, 04:56:41 AM
This is great mod and I like it a lot.  :D
After updating from 2.0.3 version to 2.1 version, there is 2.0.3 still present.
Is this normal behavior? ???

Thanks! :)

Nope, I just forgot to edit the version number inside the package.

SMF Tricks - Free & Premium Responsive Themes for SMF.

landyvlad

Diego I'm not sure what you mean - just do those edits / replace files.
Do you mean to run the uninstaller despite the errors, and then do those edits?

and when you say "And replace the files from Sources folder." - which files from where to where?

Sorry I'm a bit confused and

It won't let me upload the new version to SMF at all, which seems unrelated to the edits you suggest ?

Thank you for your patience.
"Put as much effort into your question as you'd expect someone to give in an answer"

Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Be the person your dog thinks you are.

Diego Andrés

I meant to update it doing that, instead of uninstalling it and installing it again.

Regards

SMF Tricks - Free & Premium Responsive Themes for SMF.

njtweb

Do prefixes have anything to do with the URL? I have a couple which I'd like to modify the prefix name, as long as changing it doesn't screw up the URL after it's changed.

Kindred

Not unless you use pretty urls
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Diego Andrés

2.1.1 - 05 July 2018
Fixed a minor issue when posting events in the calendar. Thanks to @GL700Wing for reporting and suggesting a solution.

SMF Tricks - Free & Premium Responsive Themes for SMF.

jack208

Got this installed on my ver 2.0.15 forum. No issue on the installation. Works as described. Great job here, Diego.

Have a usage question. I notice there are two ways one can assign permissions - 1) n the Permissions page and 2) in the Prefix Edit page.

1) (Generic) Permissions page
Here you can edit the Manage Prefixes and Use Prefixes permissions for each membergroup.

2) Prefix Edit page
However if you add or edit a prefix, in the Prefix Edit page, you can also assign "Allowed groups" permissions which said "Groups allowed to use the prefix".

My question is how does the (1) Use Prefixes permissions differ or overlap with the (2) Allowed groups permissions?

landyvlad

Umm, I have a question.  The mod is .rar but the package manager won't accept RAR files to upload. It chucks this error:

Quote
An Error Has Occurred!
The Package Manager currently allows only these file types: zip, tgz, tar.gz.

So I'm more than a little bit confused now.
"Put as much effort into your question as you'd expect someone to give in an answer"

Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Be the person your dog thinks you are.

GigaWatt

It's probably just a mistake on the author's part ;).

Extract the content in a folder, compress the content in a zip archive (no subdirectories, just the content), name the file however you like, as long as it ends with .zip, upload it via the package manager ;).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

landyvlad

Diego - sorry to keep hassling you on this.
Presumably the edits you noted earlier to update don't equate to the latest version (2.1.1).
I love this mod so I want to be absolutely sure I am doing it correctly. 

What's the best way to proceed as we stand now please?
"Put as much effort into your question as you'd expect someone to give in an answer"

Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Be the person your dog thinks you are.

confuseamuse

Quote from: GigaWatt on July 19, 2018, 05:04:40 PM
It's probably just a mistake on the author's part ;).

Extract the content in a folder, compress the content in a zip archive (no subdirectories, just the content), name the file however you like, as long as it ends with .zip, upload it via the package manager ;).

This is what I had to do when I was using it.

GigaWatt

Quote from: landyvlad on July 19, 2018, 08:28:38 PM
Presumably the edits you noted earlier to update don't equate to the latest version (2.1.1).

install.xml and package-info.xml have been modified on 07.05.‎2018.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

jack208

Am experiencing some issues when I filter a board by a prefix.

       
  • This board has about 15 pages (20 posts/pg) of topics
  • Nine prefixes in use on this board
  • I chose one of them "[KS]" to filter
  • It cuts down the page count to 4, and page 1 displays 20 topics of this [KS] filter
  • In pg 2, it shows only 7 topics (correctly filtered) but the rest of the topics have empty subject title (see attached screenshot)
  • Page 3 has ALL posts with empty subject title
  • Interestingly Page 4 displays all filtered topics properly
If I cleared the filter (select Show All Topics), things go back to normal.

The screenshot I've is on the STUDIO (responsive) theme but I tested this on the Default Curve theme with the same results. If you need to access my site, I can provide you with a dummy acct.

Hope to hear from Diego - or anyone who have some idea why this is happening? Thanks

Diego Andrés

Seems to be an issue never noticed.
I'll look into it

SMF Tricks - Free & Premium Responsive Themes for SMF.

StarredSkies

I've had the same problem as Jack today, actually! It fixed itself after awhile, but I'd definitely take a look at it when you have time.

Side note: Is there any possibility of adding the option to have more than one prefix in the future? This would be SUPER helpful.

Advertisement: