Advertisement:

Author Topic: Προβλημα σε 2.0.10 ( αναβαθμηση απο 1.1.21 )  (Read 2884 times)

Offline villasg

  • Full Member
  • ***
  • Posts: 481
Καλησπερα .Αντιμετοπιζω ενα σοβαρο προβλημα .
Κανω αναβαθμιση ( upgrade ) απο 1.1.21 ----> 2.0.10 .
Ολα βαινουν καλα .
Οταν εγκαταστω τα mods καποια στιγμη ο package manager ζητα στοιχεια Ftp γιατι κατι δεν ειναι εγγραψημο .
Μολις τα δωσω και κανει τεστ για την εγκατασταση - χωρις να γινει η εγκατασταση  , το φορουμ "χαλαει"
Internal server error (500) .......... και δεν ξαναπαιζει

Καποια ιδεα ?
« Last Edit: June 07, 2015, 10:31:41 AM by villasg »

Offline villasg

  • Full Member
  • ***
  • Posts: 481
Re: Προβλημα σε 2.0.10 ( αναβαθμηση απο 1.1.21 )
« Reply #1 on: June 07, 2015, 02:13:33 PM »
Μου βγαζει αυτο οταν παω να βαλω ενα mod

Code: [Select]
Οι πληροφορίες FTP είναι απαιτούμενες
Μερικά από τα αρχεία που ο διαχειριστής πακέτων πρέπει να τροποποιήσει, δεν είναι εγγράψιμα. Αυτό πρέπει να αλλαχθεί, με σύνδεση στο FTP και αλλαγή των δικαιωμάτων των αρχείων (με chmod) ή την δημιουργία αρχείων και φακέλων.

Offline villasg

  • Full Member
  • ***
  • Posts: 481
Re: Προβλημα σε 2.0.10 ( αναβαθμηση απο 1.1.21 )
« Reply #2 on: June 08, 2015, 04:38:45 AM »
Λυθηκε .
Το κολλημα γινοταν ,δεν ξερω γιατι , οταν το mod ειχε να βαλει καποια αρχεια σε ενα φακελο ή ενα ολοκληρο φακελο .
Τοτε ζηταγε στοιχεια ftp και οταν τα εδεινα ..........@@ το συμπαν .

Τελικα το εκανα με κομπινα .
Πειραζα το package-info.xml και αφαιρουσα ολες τις εντολες για μετακινηση αρχειων - φακελων .
Εκανα εγκατασταση το τροποποιημενο και μετα με "το χερι" (ftp) εβαζα τα αρχεια στην θεση που επρεπε να πανε

Πχ
ΤΟ
Code: [Select]
<install for="2.0.0 - 2.0.99">
<readme parsebbc="true">readme.txt</readme>
<code>add_remove_hooks.php</code>
<modification>install.xml</modification>
<modification>language.english.xml</modification>
<require-file name="Subs-BBCode-YouTube.php" destination="$sourcedir" />
<require-file name="youtube.png" destination="$imagesdir/bbc" />
</install>
<uninstall for="2.1 Beta 1">
<code>add_remove_hooks.php</code>
<modification reverse="true">install.xml</modification>
<modification reverse="true">language.english.xml</modification>
<remove-file name="$sourcedir/Subs-BBCode-YouTube.php" />
<remove-file name="$imagesdir/bbc/youtube.png" />
</uninstall>

ΤΟ ΕΚΑΝΑ
Code: [Select]
<install for="2.0.0 - 2.0.99">
<readme parsebbc="true">readme.txt</readme>
<code>add_remove_hooks.php</code>
<modification>install.xml</modification>
<modification>language.english.xml</modification>
</install>
<uninstall for="2.1 Beta 1">
<code>add_remove_hooks.php</code>
<modification reverse="true">install.xml</modification>
<modification reverse="true">language.english.xml</modification>
<remove-file name="$sourcedir/Subs-BBCode-YouTube.php" />
<remove-file name="$imagesdir/bbc/youtube.png" />
</uninstall>

Offline vkot

  • Local Moderator
  • Full Member
  • *
  • Posts: 602
  • Gender: Male
  • @}-'-,--
    • vassiliskotaras on LinkedIn
    • kithara.gr
Re: Προβλημα σε 2.0.10 ( αναβαθμηση απο 1.1.21 )
« Reply #3 on: June 12, 2015, 05:54:05 AM »
Έλεγξε τα δικαιώματα των φακέλων σου, και του χρήστη FTP.

Στην περίπτωση που ανεβάζεις τα αρχεία χειροκίνητα, δεν χρειάζεται να πειράζεις το package-info.xml, απλά αποτυγχάνουν σιωπηλά οι αυτόματες εντολές μεταφοράς αρχείων.
For specialized SMF installation/customization, Web Development, Linux Server Administration, click here.
Για εξειδικευμένες υπηρεσίες στα παραπάνω, πατήστε εδώ.