Advertisement:

Author Topic: YaBB 2.4 to SMF 1.1.14 (HELP)  (Read 7971 times)

Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
YaBB 2.4 to SMF 1.1.14 (HELP)
« on: July 17, 2015, 05:17:08 PM »
Hello there!

I've been using YaBB since... day one! i tried asking about a convert to PHPBB (but they don't seem to care and not possible.. lol)

Anyway, I've been aware of SMf for years (should of used it in the first place..) - such an awesome forum!

Right my problem is, i can only see YaBB 2.2 converter... i tried using it but nothing happens when i click 'convet' it's just a blank white screen....  i did a fresh install of SMF 1.1.14 then once the conversion is done i will upgrade the forum to the latest SMf version.

but for the love of god.. i cannot seem to get this to work???? what exactly does the conversion do? posts and members but i need to remake the boards or what?

So please... someone help me !

Thank you very much.


Lith

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,646
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @antesistan on Twitter
    • Lunarfall
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #1 on: July 17, 2015, 06:10:44 PM »
It should take categories/boards/users/posts/topics pretty much most of the basics of your forum.

You need to write error message here so we can help you more on this.
Active Project(s): [ SimpleDesk ] # [ Lunarfall ] # [ CoreStore ]

Past Project(s): [ ezPortal ]

Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #2 on: July 17, 2015, 06:17:58 PM »
It should take categories/boards/users/posts/topics pretty much most of the basics of your forum.

You need to write error message here so we can help you more on this.

hi, well that's the problem... the second i 'click convert' it just goes to a white screen nothing else happens.

i put convert.php and the yabb22_to_smf.php in root of my FTP once i load it up via the browser, it finds the paths to the smf forum 'forum' and paths to yabb 'cgi-bin'

click convert, blank white screen...... also what is smf database password? i assume thats the password to my MYSQL?

Really need to use SMF now... the YaBB board is very dated.


Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,646
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @antesistan on Twitter
    • Lunarfall
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #3 on: July 17, 2015, 06:27:18 PM »
You need to put both files (converter.php & sql file) into SMF's folder in same root of SSI.php
Active Project(s): [ SimpleDesk ] # [ Lunarfall ] # [ CoreStore ]

Past Project(s): [ ezPortal ]

Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #4 on: July 17, 2015, 06:55:39 PM »
You need to put both files (converter.php & sql file) into SMF's folder in same root of SSI.php

Files are

convert.php
yabb22_to_smf.php

when i enter ;convert in browser, it loads then click convert blank white screen.


Offline Westwegoman

  • Jr. Member
  • **
  • Posts: 189
  • Gender: Male
    • westwegoman on Facebook
    • Westwegoman on LinkedIn
    • Bayou State Fishing
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #5 on: July 18, 2015, 01:01:24 AM »
I always like to direct people want to convert to this post as it is what I used and worked for me. I went from YaBB 2.4 to SMF 1.1.14 to SMF 2.0.1 without any major problems.

http://www.simplemachines.org/community/index.php?topic=457735.0

Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #6 on: July 18, 2015, 01:55:19 AM »
Hey!

it worked for me! posts/threads/members its all there! now i need to upgrade to 2.0+ SMF

Will let you know how it goes !!

And can you please tell me, where to get themes? thank you!


Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #8 on: July 18, 2015, 03:55:40 PM »
http://custom.simplemachines.org/themes/

Thanks man!

one more thing...  the 'register' link goes to my yabb forum... where do i go to edit this to it registers to the smf?


Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 48,072
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #9 on: July 18, 2015, 04:17:07 PM »
where is the register button? if it is the one on your SMF forum it should stay at the forum.

Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #10 on: July 18, 2015, 05:02:30 PM »
where is the register button? if it is the one on your SMF forum it should stay at the forum.

my bad, it was features in 'news' it was a custom html link lol doh!!!

will let you know any more problems!

thanks guys! SMF is awesome!

only issues so far i found is the 'polls'... yikes... but meh only had 2 or 3 max on the forum.



Offline Lithtech

  • Semi-Newbie
  • *
  • Posts: 14
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #11 on: July 18, 2015, 08:31:04 PM »
ok guys!

everything seems to be in order except one thing...


2 sections on my forum have many posts in them... but they all say 0 replies?? and if i reply to one of them you don't see my post at all in it.

any solution to this? is this common from yabb to smf?


cheers


Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: YaBB 2.4 to SMF 1.1.14 (HELP)
« Reply #12 on: July 20, 2015, 01:03:13 PM »
You should run the "Maintenance" tasks: find and repair errors and recount all totals. That should bring the numbers back ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair