Advertisement:

Author Topic: 'Invisible posts' for certain member groups?  (Read 8222 times)

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
'Invisible posts' for certain member groups?
« on: October 06, 2015, 01:19:34 PM »
Hey all,

I've been offline for a while and haven't had much time to work on my site recently..

anyway, I've had a member point out they aren't able to view some posts and the quick reply is missing in certain topics..

I as an Admin can see everything just fine, and as a guest it appears normal too, but for some reason they are 'invisible' for other member groups..

I don't think it's a permissions issue as it's only recently happened and I haven't changed anything there for a while.
I feel so out of touch with how to even begin investigating where something could be going wrong..  :-X

If anyone is willing to have a look, here's an example of a 'broken' page..

http://www.420connect.co.uk/index.php?topic=1623.0

(should be able to see it as normal as a guest, but try logging in and revisiting it..
a: smftest / pw: smftest

I can provide further info if needed!

Many thanks
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,305
Re: 'Invisible posts' for certain member groups?
« Reply #1 on: October 06, 2015, 03:25:54 PM »
I'm seeing the entire thread as guest, but only first post when logged in.  Other threads display normally.  IIRC, someone reported a similar problem here recently, but all threads were affected.  Don't remember the outcome, will see if I can find it.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,305
Re: 'Invisible posts' for certain member groups?
« Reply #2 on: October 06, 2015, 03:57:48 PM »
No help here.  Problem was similar, but all threads were truncated.  OP dumped it and did a clean install before we were able to determine the problem.  This is different, only some threads are cut off, and only to logged members.  Can't think of anything in permissions that could cause this.  Which mods are you running?

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #3 on: October 07, 2015, 05:42:20 AM »
Hey,

Thanks for stopping by!

I do have quite a lot of MOD's installed but have only had this begin happening very recently that I know of..

Mod list:

Code: [Select]
1. SMF 2.0.11 Update 1.0
2. Super Simple Thread Tags 1.1a
3. Embed Instagram BBCode 1.3
4. Boilerplates for posts 3.1
5. Attach on QR by SMFPacks.com 1.0
6. Post and PM Inline Attachments 3.16
7. Ohara YouTube Embed 1.2.4
8. Email Inactive Users 1.1.1
9. Activity in Profile 1.1
10. Custom Form Mod 1.7
11. EU Cookie 1.3.1
12. Highslide Image Viewer 1.7
13. SMFPacks Social Profile Pro 1.0.3
14. QRR: Quick Reply Reposition 1.1.2
15. SMFPacks Alerts Pro 2.0.9
16. RHTAMI - Remove Hot Topic And Message Icons 1.1.6
17. SA Chat 1.0a Rev120
18. Bookmarks 2.5
19. SMF 1.1.21 / 2.0.10 Update 1.0
20. Custom BBCodes Manager 1.9
21. Say Thanks 1.3.1
22. @mention members 1.1.3
23. Admin Toolbox 1.0
24. Add Social Media Icons To Profiles 1.2.0
25. Bad Behavior mod 1.5.18
26. Shoutbox PM button - SimplePortal 2.3.5 1.0
27. SP-Shoutbox Notification Sound HTML5 0.5
28. Shoutbox Color Selector - SimplePortal 2.3.5 1.1a
29. SimplePortal 2.3.6
30. Invitation Message In Your Face (IMIYF) 0.3.2
31. Disable 'last edit by...' for Administrators 1.9
32. Social Login 3.3
33. Badge Awards 2.0
34. IMG Popup 1.0.2
35. Favourite (Favorite) Boards 1.2
36. Simple Menu Icons 1.0
37. Anonymous Boards 1.1
38. cbi 1.0 1.8.0
39. SP - Advanced Unread Posts 1.4
40. Tagging System 3.0
41. Stop Forum Spam 1.0
42. Country Flags 2.1
43. Better Profile Menu 1.9
44. Joinable Groups 1.0
45. Internal Links Use Same Window 1.2
46. URL Popup 1.0.2
47. Related Topics 1.401
48. Send Locked Topics To Bottom 1.0
49. More Spiders 1.2
50. Expanding & Collapsing Spoiler Tag 1.7
51. SMF Trader System 1.7
52. Arantor CAPTCHA 1.0.8
53. Misc Anti Spam 1.0
54. PDF Tag 1.2
55. Signature Area BBCode Buttons 2.0.3
56. Alternate User Posting 1.0.1
57. Move Right BBCode 1.5
58. Topic Solved 1.1.1
59. New Topic Button 1.0
60. RSS Feeder 1.1.5
61. Recount Member Posts 1.1
62. Display Signatures Only Once Per Page 1.0.3
63. Optimus Brave 1.8.7
64. Scrolling Buttons 0.3
65. Center User Info In Posts 1.0
66. WYSIWYG Quick Reply 2.3
67. LUP: Logout Under Profile 1.0.0
68. RIAST: Remove Index & Add Smart Title 1.3.0
69. ICAP: Info Center Access Permission 1.0.0
70. New Some/New None 1.3
71. AdditionalMembergroups 1.04
72. SMF Classifieds 4.0.3
73. E-Arcade 3.0
74. SMF Social Groups 2.4.7
75. Levertine Gallery 1.1.1
76. Cumulus Congestus 1.0

I'd really like to avoid having to make any dumps and begin rebuilding the forum, as I've had to do it a few times now and as my site is so heavily customised it can take a very long time! :( .. I'm guessing from my list of mods (if it's in order of installation), that the latest few mods might have something to do with it? I doubt the 2.0.11 update caused it so am more leaning towards the few before that..

I can post my display template if that might help?

Hmm!
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Steve

  • Freak
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,500
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: 'Invisible posts' for certain member groups?
« Reply #4 on: October 07, 2015, 08:15:51 AM »
It would be a wild guess but maybe the Quick Reply Reposition mod?
Online Manual

Please do not PM me for support.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,502
  • Gender: Male
    • Kindred-999 on GitHub
Re: 'Invisible posts' for certain member groups?
« Reply #5 on: October 07, 2015, 09:33:02 AM »
BTW: no... unless you have the mod which re-roders your packages by installation order -- the list of package is NOT in order of installation

(honestly, I don't know WHAT the default order is based on)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: 'Invisible posts' for certain member groups?
« Reply #6 on: October 07, 2015, 09:48:57 AM »
i believe the default order is alpha order based on package name.

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #7 on: October 07, 2015, 12:34:45 PM »
Okay, I had a look in my Packages/backups folder and sorted it by date.

I've removed a few mods and even tried the 2.0.11 update just incase but no luck so far? :(

I'm going to try and see if I can spot anything unusual in my display template but to be honest, I don't imagine I'll be able to spot if anything was wrong..

.. Wow! I was just about to send this and had a thought, tried it and it seems to have worked!  :laugh:


For some reason, when I lock the topic - the replies and (obviously the ability to reply) isn't shown..

I'm going to further test it, but it may have something to do with the @mention mod?
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #8 on: October 07, 2015, 12:51:55 PM »
I felt this deserved it owns reply..
I'm not really sure where it is coming from but here's what I have found so far..
(not tested on a clean install, so could be theme and/or mod related too)


It seems when someone is @mentioned and a topic is locked it causes the replies to appear hidden when viewing the topic as a member..

On my test, it also added a huge (padding?) space in the OP. when viewing the topic as a regular member..



.. I've also just noticed, the other replies either appear with the same padding issue (or normal, as they should - depending on the screen size - ((try resizing your browser window if you're testing))

(semi related sidenote: I also had a similar issue of missing content whilst using Tapatalk with my site and am now wondering if this other cause, was actually the fault there too..!  Hmm)
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,305
Re: 'Invisible posts' for certain member groups?
« Reply #9 on: October 07, 2015, 10:45:40 PM »
Most likely cause is a conflict between mods, i.e., two (or more) of them edited the same bit of code and buggered it up.  Not surprising, as you're running 76 mods.  You may also have a problem uninstalling the mods.  Tapatalk has been problematic for many 2.0 forums, but I don't see it currently installed.  If it uninstalled cleanly (big if), it shouldn't be causing any problems now.

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #10 on: October 08, 2015, 06:04:38 AM »
Hey,

I've just had another look into this and although the @mention mod appears to cause issues.
 I think the real problem is some of my tinkering to do with the theme .css ..whilst I thought I had implemented some ideas, although it seemed okay, I think I've brought up issues elsewhere..

Hopefully someone who understands themes can help me put things right!

I've had a look with 'Inspect Element' and after a bit of playing around found the "overflow: hidden;" part seems to be hiding the missing parts, but if I remove that line or change it to 'auto' it shows, but in a weird position..

Code: [Select]
.body_message
{
padding: 20px 0;
overflow: hidden;
}

It would be awesome if anyone wouldn't mind having a look over my theme files (specifically the responsive, @media stuff) as I think that is where the problem lies..

.. I'd be happy to offer a little donation to anyone who can help get me running smoothly :)
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Gluz

  • Sr. Member
  • ****
  • Posts: 985
  • Gender: Male
Re: 'Invisible posts' for certain member groups?
« Reply #11 on: October 08, 2015, 08:07:11 AM »
Looking some of the threads that have that problem compared with ones that does not, I see that the content is indeed there but is not well formated, looks like a missing closing tag in somewhere in the Display.template.php that breaks when is locked. That tag could be just moved inside a conditional, that only when is locked and the user is in some usergroup that can't post it doesn't show, in the other cases it shows the tag.

That really need to be inspected in deep, and I'm going to be back in my desktop in about 9 or 10 hours, so in the mean time you can see if you find the missing tag/s.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #12 on: October 08, 2015, 09:27:17 AM »
Many thanks for your insight Gluz!

I'm reading through the my Display.template.php trying to find where I am missing a tag but with such little knowledge and PHP being so confusing and 'fragile' it's making this a lot harder.. Much appreciated if you're able to take a look when you are able!

Kind Regards
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Gluz

  • Sr. Member
  • ****
  • Posts: 985
  • Gender: Male
Re: 'Invisible posts' for certain member groups?
« Reply #13 on: October 08, 2015, 09:15:08 PM »
Ok, I think I find the conditional that hide a couple of tags when locked.

Try with this Display.templete.php attached, and when it's up in the site we can check if it's only that the culprit of the mess.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #14 on: October 09, 2015, 02:55:07 AM »
I've just switched over to the version you've edited and on first inspections, I think you've nailed it!  ;D  O:)

Woo!

Thank you so much!
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Gluz

  • Sr. Member
  • ****
  • Posts: 985
  • Gender: Male
Re: 'Invisible posts' for certain member groups?
« Reply #15 on: October 09, 2015, 03:30:24 AM »
Maybe need to post in the Say Thanks MOD support thread that have this bug, or check if it was reported before, because only that part was causing all the trouble.

Glad to see that it works. ;)
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: 'Invisible posts' for certain member groups?
« Reply #16 on: October 09, 2015, 05:59:00 AM »
It will likely have been from an old installation not removing correctly or from another mod that also changed the same areas of code.

Many thanks again! :)

I'll mark this as solved for now anyway!
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)