Advertisement:

Author Topic: changing from https to http in Theme Settings  (Read 1783 times)

Offline jonesH

  • Jr. Member
  • **
  • Posts: 158
  • Gender: Male
changing from https to http in Theme Settings
« on: November 04, 2015, 08:28:53 PM »
I installed a stock SMF 2.1 beta 2 on localhost in WAMP and then I imported my database from the same forum online. I managed to correct everything (paths and URl's and so on) except in Themes and Layout > Theme Settings, last entry at the bottom of the page, for Base URL to the same directory: it says https://localhost/forum/Themes


Now, everything else seems to be just fine, except I can't find a way to change this to http.


All other settings that I went through are not forcing SSL, and are plain http. When I go to the forum on localhost, it tries to go to https and Chrome chokes.


(The online version of this has https and SSL throughout.)


What should I be doing next?


Regards.


Edit: I just found that in Cookies and Sessions, "Force cookies to be secure" was selected (I deselected it), the "Force cookies to be made..." was not selected (I selected it, then tried again unselected), but when I save the changes, I get this error: "An Error Has Occured: The domain introduced seems to be invalid, please check it and save again."

Offline jonesH

  • Jr. Member
  • **
  • Posts: 158
  • Gender: Male
Re: changing from https to http in Theme Settings
« Reply #1 on: November 04, 2015, 08:45:47 PM »
Problem solved: I exited the forum, restarted Chrome, went to the forum URL (no https this time!), logged in and all the misbehaving settings from before were now OK.


Thise errors though while going through the settings changes and the changes themselves not reflecting upon Save should probably be looked at anyway.


I hope this helps.