News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Wide A Responsive Theme

Started by gecitli, February 28, 2016, 05:19:34 PM

Previous topic - Next topic

naijacrux

Quote from: lurkalot on September 02, 2019, 02:41:26 AM
Quote from: naijacrux on September 01, 2019, 10:36:50 PM
op , hope you are good. i need help with this theme, it doesnt resize url link images, they show very big. how do i fix this

Have you set a image size in Admin > Features and Options > Layout >>

Max width of posted pictures (0 = disable)
Max height of posted pictures (0 = disable)



Max width of posted pictures (0 = disable)
Max height of posted pictures (0 = disable)

are both set to disable and i have added several low sizes but didnt resize so i guess the theme only use those settings for image attachments and not url [img] links images. but i installed this mod below and it solved the problem now.maybe op can check the mode and see what was added  and use it to upgrade the theme soon.

https://custom.simplemachines.org/mods/index.php?mod=1769

i still have other issues , the logo png not showing full size of my logo 350 x 120 . my old theme dani shows full size, how do i may the smf logo show actual size . what to change in css file. also i changed from dani to this wide theme because of responsiveness, dani is not fully responsive and doesnt help with google rank.i just started using this theme but i observed its a bit slow and will try it for more days.

i tried boru theme on one of my website and i must give it up for boru for its speed , boru ranked my website within 24hours.the site have not rank before i installed boru. what i dislike about boru is the black theme and also it doesnt open topics accurate. boru is very fast and rank website fast.i will suggest to boru op to change that disgusting black color and make links and topics open normal, until then i will keep trying different themes that are fully responsive and good for seo.i am giving wide theme a trial and i suggest op looks at boru theme and emulate some changes.

lurkalot

Quote from: naijacrux on September 02, 2019, 04:01:48 PM
Quote from: lurkalot on September 02, 2019, 02:41:26 AM
Quote from: naijacrux on September 01, 2019, 10:36:50 PM
op , hope you are good. i need help with this theme, it doesnt resize url link images, they show very big. how do i fix this

Have you set a image size in Admin > Features and Options > Layout >>

Max width of posted pictures (0 = disable)
Max height of posted pictures (0 = disable)



Max width of posted pictures (0 = disable)
Max height of posted pictures (0 = disable)

are both set to disable and i have added several low sizes but didnt resize so i guess the theme only use those settings for image attachments and not url [img]


Those settings do work for images using image tags.  They won't however change existing images, (images already posted).

Schizophren1c

Problem whenever i modify thread it gives strange code msg before actual thread im using 2.1 rc

kujio

#123
I to am experiencing this, the issue is caused by index.css lines 3600 and 3603 which just puts a bunch of gibberish in the page.

m4z

Quote from: kujio on September 24, 2019, 10:41:30 PM
I to am experiencing this, the issue is caused by index.css lines 3600 and 3603 which just puts a bunch of gibberish in the page.

@Schizophren1c already reported this in another thread.
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

emma301

Thanks, the theme is very good. And the problem am facing is, if I login with the theme on my laptop. I can't locate the "Unread Replies, Read Replies And logout button on my laptop.

gecitli

http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.

gecitli

Quote from: emma301 on September 25, 2019, 06:54:28 AM
Thanks, the theme is very good. And the problem am facing is, if I login with the theme on my laptop. I can't locate the "Unread Replies, Read Replies And logout button on my laptop.

Where do you live the problem

http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.

wylekk

Скорость загрузки стандартной темы на PageSpeed Insights выше на 10 единиц чем темы Wide ;)
Тему установил на основной форум, сделана неплохо.

Не работает скроллинг, надо в строке 195 вставить так и все заработает :)
<header class="main-header"; id="top_section">

Забыл написать - форум SMF2.1 RC2

gecitli

Quote from: catyr on December 12, 2019, 03:25:27 AM
Скорость загрузки стандартной темы на PageSpeed Insights выше на 10 единиц чем темы Wide ;)
Тему установил на основной форум, сделана неплохо.

Не работает скроллинг, надо в строке 195 вставить так и все заработает :)
<header class="main-header"; id="top_section">

Забыл написать - форум SMF2.1 RC2

Hello Sorry I don't know your language
http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.

wylekk

Scrolling does not work, you need to insert in index.template.php in line 195 and everything will work

<header class="main-header"; id="top_section">

gecitli

http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.


Shambles

Hi gecitli and thank you for this theme.

I'm experimenting with a few themes recently and thought I'd give vVide a shot.

Not being a graphics person at all, where should my forum logo be appearing?



There are no mods applied to this 2.0.17 installation.

When I inspect the page I can toggle .logo>height to make part of the logo appear but it's not in a position that's useful:



Can you offer assistance getting the logo to show please?

As it stands, the logo file is 790px * 150px

gecitli


Hello  Shambles
index.css
Find:

.main-header .logo {
    -webkit-transition: width 0.3s ease-in-out;
    -o-transition: width 0.3s ease-in-out;
    transition: width 0.3s ease-in-out;
    display: block;
    float: left;
    height: 57px;
    font-size: 20px;
    line-height: 50px;
    text-align: center;
    width: 230px;
    font-family: "Helvetica Neue", Helvetica, Arial, sans-serif;
    padding: 0 15px;
    font-weight: 300;
    overflow: hidden;
}


Replace With:

.main-header .logo {
    float: left;
    text-align: center;
    width: 230px;
    overflow: hidden;
}


Find:

/* Styles for print media.

Add After:

.main-header .logo a img {
  -webkit-transition: width 0.3s ease-in-out;
  -o-transition: width 0.3s ease-in-out;
  transition: width 0.3s ease-in-out;
  display: block;
  float: left;
  height: 57px;
  font-size: 20px;
  line-height: 50px;
  text-align: center;
  width: 230px;
  font-family: "Helvetica Neue", Helvetica, Arial, sans-serif;
  padding: 0 15px;
  font-weight: 300;
  overflow: hidden;
}


index.template.php
Find:
<a href="', $scripturl, '"><i class="fa fa-graduation-cap"></i>&nbsp;', empty($context['header_logo_url_html_safe']) ? $context['forum_name'] : '<img src="' . $context['header_logo_url_html_safe'] . '" alt="' . $context['forum_name'] . '" />', '</a>
Replace With:
<a href="', $scripturl, '">', empty($context['header_logo_url_html_safe']) ? $context['forum_name'] : '<img src="' . $context['header_logo_url_html_safe'] . '" alt="' . $context['forum_name'] . '" />', '</a>
http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.

Shambles

Thanks, I'll give that a go when I get back from work.

Shambles

The first block to find ".main-header .logo {" didn't exist in the index.css file as posted above, however a cutdown version of it did, which I replaced as instructed.

.main-header .logo {
    float: left;
    text-align: center;
    width: 230px;
    overflow: hidden;
}


I also added the bits you recommended between the comment and the "@media print" section.

/* Styles for print media.
------------------------------------------------------- */
.main-header .logo a img {
  -webkit-transition: width 0.3s ease-in-out;
  -o-transition: width 0.3s ease-in-out;
  transition: width 0.3s ease-in-out;
  display: block;
  float: left;
  height: 57px;
  font-size: 20px;
  line-height: 50px;
  text-align: center;
  width: 230px;
  font-family: "Helvetica Neue", Helvetica, Arial, sans-serif;
  padding: 0 15px;
  font-weight: 300;
  overflow: hidden;
}
@media print
{
#headerarea
{
display: none;
}

.tborder
{
border: none;
}
}


I also edited the template as instructed.

Whilst better than before, the image is truncated.



Here's what the whole image should be:



Thanks for your help.


Shambles

I played around - quite randomly - with some of the heights and widths and ended up with this, which I'm happy with.



Cheers

jonat

What is the purpose of the following code in index.css?


.topic_pages::before {
content: " ÂÃ,«";
}
.topic_pages::after {
content: " ÂÃ,»"
}


All it seems to do is corrupt the display of pages in the topic listing. I downloaded the hxxp:widerc.zip [nonactive] three times to make sure it wasn't some sort of download issue.

gecitli

http://www.webtiryaki.com
webmaster forumu
Free & Premium Responsive Themes for SMF.

Advertisement: