Advertisement:

Author Topic: "Updated Topics" error  (Read 5896 times)

Offline shapeshifter

  • Semi-Newbie
  • *
  • Posts: 29
Re: "Updated Topics" error
« Reply #20 on: May 14, 2016, 06:56:22 PM »
Yes, it's the correct database in settings.php, and that release is the one I used to update this morning. Thanks

Offline qc

  • Jr. Member
  • **
  • Posts: 140
Re: "Updated Topics" error
« Reply #21 on: May 14, 2016, 07:47:52 PM »
Ok, so if nobody else has a better idea, I would suggest you to do the following:
  • Open Sources/Recent.php
  • At line 909 you should find the following code: list ($num_topics, $min_message) = $smcFunc['db_fetch_row']($request);
  • Add a new line just before that line 909 with the following code: die(print_r($request, true));
  • Try to reproduce the error. You should see some debug output. Please post that output here and revert your changes made to Sources/Recent.php.
Playing quizduell? Having quizduell questions? Our german quizduell forum quizcommunity.de is looking for quiz freaks to come and play quizduell with us :)

Offline shapeshifter

  • Semi-Newbie
  • *
  • Posts: 29
Re: "Updated Topics" error
« Reply #22 on: May 14, 2016, 08:02:00 PM »
I found it on line 913 and added your code before it and got this as soon as I clicked "Unread Posts":

mysqli_result Object ( [current_field] => 0 [field_count] => 2 [lengths] => [num_rows] => 1 [type] => 0 )

Offline qc

  • Jr. Member
  • **
  • Posts: 140
Re: "Updated Topics" error
« Reply #23 on: May 14, 2016, 08:05:20 PM »
I found it on line 913
Ah, would you mind posting lines 891 to 913 of your Recent.php here then? You seem to have another version of that file than at github ( https://github.com/SimpleMachines/SMF2.1/blob/release-2.1/Sources/Recent.php#L891 )!
Playing quizduell? Having quizduell questions? Our german quizduell forum quizcommunity.de is looking for quiz freaks to come and play quizduell with us :)

Offline shapeshifter

  • Semi-Newbie
  • *
  • Posts: 29
Re: "Updated Topics" error
« Reply #24 on: May 14, 2016, 08:17:00 PM »
I found it on line 913
Ah, would you mind posting lines 891 to 913 of your Recent.php here then? You seem to have another version of that file than at github ( https://github.com/SimpleMachines/SMF2.1/blob/release-2.1/Sources/Recent.php#L891 )!

Well, I definitely did download the zip from github and upgraded, got the upgrade menu and went through the usual steps, so I'm not sure why that file wouldn't have been updated. This is the page I got it from, in case there's another I missed somewhere:

https://github.com/SimpleMachines/SMF2.1

But good news! It's fixed! All I needed was for you to point out that something was off with the lines and to see that page you linked to, copied it over to my own recent.php file and now everything works. Wow! Thanks so much for your patience and going back and forth with me on this all day. It's very much appreciated.

Offline qc

  • Jr. Member
  • **
  • Posts: 140
Re: "Updated Topics" error
« Reply #25 on: May 14, 2016, 08:28:09 PM »
Better make sure all your files are really updated to the newest version at github - https://github.com/SimpleMachines/SMF2.1/archive/release-2.1.zip

At least you thoroughly tested the SMF 2.1 database upgrade process today ;)
Playing quizduell? Having quizduell questions? Our german quizduell forum quizcommunity.de is looking for quiz freaks to come and play quizduell with us :)

Offline shapeshifter

  • Semi-Newbie
  • *
  • Posts: 29
Re: "Updated Topics" error
« Reply #26 on: May 14, 2016, 11:04:36 PM »
I've actually deleted the contents of the entire directory at least twice today, did a full install with 2.1 beta 2 and then upgraded with the github package each time. I'm not sure how any file couldn't have been overwritten/updated already - which is why it didn't occur to me that the recent.php file might not be the correct one. Bit of a mystery. But I guess that means you're right, I should maybe do it one more time, just in case.  O:)

Thanks again!

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,500
  • Gender: Male
    • Kindred-999 on GitHub
Re: "Updated Topics" error
« Reply #27 on: May 15, 2016, 05:36:35 PM »
no no no no no....   that won't work


that's why we say don't use the beta unless you know what you are doing.

You can not upgrade between beta versions

You need to either do a clean install of the NEWEST beta from github -- or do an upgrade from 2.0.x
there is no upgrade path from beta to beta
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,267
Re: "Updated Topics" error
« Reply #28 on: May 15, 2016, 06:36:07 PM »
You can not upgrade between beta versions

You need to either do a clean install of the NEWEST beta from github -- or do an upgrade from 2.0.x
there is no upgrade path from beta to beta

yes there is an upgrade path from beta to beta, you can still upgrade from a beta to another beta. this was discussed but has not changed in behavior. bugs that have been reported on the upgrade process from a beta to a beta are still being fixed.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,500
  • Gender: Male
    • Kindred-999 on GitHub
Re: "Updated Topics" error
« Reply #29 on: May 15, 2016, 08:01:48 PM »
I was told very clearly that there was no and would be no database update script for beta to beta...   
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,267
Re: "Updated Topics" error
« Reply #30 on: May 15, 2016, 08:28:04 PM »
well it seems to be working and related bugs are still being fixed. the person that made that decision did not let others know that may or may not be on the dev team.